Support » Plugin: StopBadBots » Blocks Printful Plugin’s API

  • Resolved dubh

    (@spmcnerd)


    Hello, Your plugin blocks Printful plugin’s API preventing them from syncing with my site daily. I don’t see any Printful bots in the table but the only way for me to sync is to deactivate StopBadBots. Thank You

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author sminozzi

    (@sminozzi)

    Hi,

    You can use the test mode:
    Dashboard => Stop Bad Bots => Settings => General Settings.
    Mark Test Mode and SAVE CHANGES.
    Then, enable also the email Notifications at the Notifications Tab.
    After that. Go to your site and open one page.
    Then, go to your email inbox and look for messages from your site. Check also your spam folder.

    Please, read also our StartUp Guide
    Dashboard => Stop Bad Bots => Settings => Start Up Guide.

    Please, read also our troubleshooting page:
    http://siterightaway.net/troubleshooting/

    Cheers,
    Bill

    dubh

    (@spmcnerd)

    Hi again,
    I did the above and deactivated all the emailed bot blocks.
    When I try to sync on Printful, their error is only “JSON ERROR:” try again.
    I don’t get emails from those blocks when Printful tries. Thank you!

    Plugin Author sminozzi

    (@sminozzi)

    Hi,

    Try to mark these options with No on the settings page:
    Dashboard => Stop Bad Bots => Settings => General Settings Tab.

      Block all IPs included at Bad IPs Table?

      Block all bots included at Bad Referer Table?

      Enable Firewall? (available only in pro version)

      Block all with Blank User Agent?

    Then test. If works, begin to change, one each time, to Yes.

    Cheers,
    Bill

    • This reply was modified 7 months ago by sminozzi.
    dubh

    (@spmcnerd)

    Hi Bill,
    I marked all the options above to No and it didn’t sync. Thanks!

    Plugin Author sminozzi

    (@sminozzi)

    Hi,

    Unfortunately looks like our plugin doesn’t block the other but they are not compatible. I don’t know why. Try to find a replacement plugin that does the same thing.
    I will keep an eye on and if I receive any new information or discovery something useful I will let you know.

    Cheers,
    Bill

    dubh

    (@spmcnerd)

    Thank you. You can close

    dubh

    (@spmcnerd)

    Hi Bill, Totally my fault. I’m using another security plugin that was causing the JSON error that has now been remedied. I appreciate the time!

    Plugin Author sminozzi

    (@sminozzi)

    Hi Dubh,

    Glad to hear it is working fine.
    Thanks for letting me know and for the great review.
    Good luck with your sites.

    Cheer,
    Bill

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.