blockquote fails validation (11 posts)

  1. tom_raftery
    Posted 10 years ago #


    I was using the blockquote tag to highlight quotes from others in my posts until I realised they weren't validating when I ran my site through the w3c validator.

    Is there any way to use blockquote in posts and still be valid?


  2. Mark (podz)
    Support Maven
    Posted 10 years ago #

    Beelzebub XVI
    <blockquote>He has described homosexuality as a "tendency" towards an "intrinsic moral evil". During the US election campaign, he called for pro-choice politicians to be denied Communion.</blockquote>

    That validates from my site.
    I always start a blockquote on a newline then keep it all inline, completing by starting a newline for anything else.

  3. tom_raftery
    Posted 10 years ago #

    Nice one Podz,

    I'll try that,



  4. tom_raftery
    Posted 10 years ago #

    Excellent Podz - that worked. Thanks again.

    Is that documented anywhere, do you know?


  5. fatalcure
    Posted 10 years ago #

    i still get error

  6. tom_raftery
    Posted 10 years ago #

    Are you starting the opening blockquote tag on a new line and starting anything, after the closing blockquote tag, on a new line?

  7. Lorelle
    Posted 10 years ago #

    Double space and then start the blockquote tag. And then I recommend, for consistency more than anything else, double space after the blockquote.

  8. Lorelle
    Posted 10 years ago #

    fatalcure: Make sure you have double spaces, like described above, before and after the blockquote. On a rare occassion, WordPress' auto format feature will put:

    <p><blockquote>blah blah</p></blockquote>

    or something like that. It must be paid out at the max:

    <p><blockquote>blah blah</blockquote></p>

    Or in a way that the paragraph tags aren't even there. It's the order of things that is probably screwing you up.

  9. TH
    Posted 10 years ago #

    This doesn't fix my page. I have validation errors on all blockquotes and they stay there no matter what I do in terms of line breaks. Tried all combinations; single double, double in front, single in back and vice verca.

    Any other suggestions? Please?


    P.S. This has to qualify as a bug, right? Since it is appears in every blockquote like that?
    Using WP 1.5.1

  10. Lorelle
    Posted 10 years ago #

    In the source code, I find this:

    <blockquote>“After reading a story......to the rescue?”</blockquote>
    SHHH, the Society.....

    Since I can't see your actual post code, this tells me that you have only put one line break between the paragraph above and the one below the blockquote. If you did put two lines between the blockquotes, then try three between them...why not?

    Also, are you using Textile or Markup or any of the markup and formatting plugins? That might be causing a problem too.

    And if you can't figure out why it is doing this, try putting paragraph codes around the paragraph before and after the blockquote, and no spaces between them, and see if this makes a difference. Just trying to see what works.

    And this isn't a bug so much as WordPress' autoformat trying to read your mind.

  11. TH
    Posted 10 years ago #

    Yes, I can feel that autoformat thing reading my mind right now.

    Didn't mean to confuse you there; yes I removed the double space again after I tried it and it didn't work, so as not to drift too far away from how it originally was.

    Textile was the problem! You solved it for me. And fast too! That was the quickest reply I have ever seen to a post. I am very happy now. And grateful! Thank you!

Topic Closed

This topic has been closed to new replies.

About this Topic