Support » Plugin: Appointment Hour Booking - WordPress Booking Plugin » Blocking rearranges intervals

  • Resolved newschrems

    (@newschrems)


    Hi,

    when i am blocking specific time periods, it rearranges the appointments coming afterwards.

    I’ve set up the form with appointments lasting 60 minutes, and appointments to be created every 75 minites.

    So for example we usually have the following available times:
    17:30-18:30 ; 18:45-19:45 ; 20:00-21:00

    When i am blocking the first time now, the others show up as follows:
    18:30-19:30 ; 19:45-20:45

    How can i fix this?

Viewing 3 replies - 1 through 3 (of 3 total)
  • samgruvr

    (@samgruvr)

    Have you set a buffer time after each appointment? If so, that might be interfering with the auto-generation of slots.. Also, I found that with buffers, by making the end time after the buffer that would be after the last session, it created that last session as I expected.

    If you want to end at 2100 and have a 15 minute buffer, set the end time to 2130.. see if that helps..

    Plugin Author codepeople

    (@codepeople)

    Hi,

    Set the appointment length to 60 minutes and use the padding times features with a “padding after” of “15”:

    https://apphourbooking.dwbooster.com/customdownloads/padding-time.png

    Thank you for using the plugin!

    Thread Starter newschrems

    (@newschrems)

    I tried setting the padding time at 15 minutes.
    But it only added that 15 minutes after the last appointment.

    Bit i could solve it by adding a padding time of 15 minutes before all appointments, which are now added even when i am blocking the first time period completely.

    So it’s now set:

    Duration: 60 min
    Padding time before: 15 min (which is only added before the first time)
    Generate slots every: 75 min

    Thanks for your help!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Blocking rearranges intervals’ is closed to new replies.