• Resolved macdabby

    (@macdabby)


    I have a product with the category “Dealers Only”. at the url “product/flat-bill-cap/”. I created a content control restriction on “products with category” and selected the category, and set it to require a logged in user with a role. When i access the page as an unauthenticated user (in incognito window) i am still able to see the content. This is a woocommerce product. Is this plugin broken?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support mlchaves

    (@mlchaves)

    Hi @macdabby,

    Thanks for posting.

    Can you check your Protection settings?

    For your case, we recommend your Protection settings are:

    – Redirect
    – Login & Back

    If you use those settings (instead of Custom Message), you should be prompted to log in when you try to bring up that URL again.

    Otherwise, if you use the Custom Message protection, you can still access that product page (without logging in), but you won’t see the full description. The full description is what’s protected.

    You can also protect the short description by wrapping it with the [content_control][/content_control] shortcode.

    Please let us know how that works out.

    Cheers!

    Mark

    • This reply was modified 1 month, 2 weeks ago by mlchaves. Reason: Typo
    • This reply was modified 1 month, 2 weeks ago by mlchaves. Reason: Clarification
    Thread Starter macdabby

    (@macdabby)

    I was hoping for just a message and not show the product. However, I tried changing it to redirect and it works if i am logged in, but if i open a new incognito window, i still see the product.

    Plugin Support mlchaves

    (@mlchaves)

    Hey @macdabby,

    Can you make sure you log out of your wp-admin before opening an incognito. Opening an incognito doesn’t log you out of your session.

    Using a different browser for your private/incognito window should help too.

    I usually log in with Firefox to make changes while doing all my testing in Chrome incognito (not logged in).

    Please let us know how that goes.

    Cheers 🙂

    Mark

    Hi

    I have the same issue.

    And I saw this reply from a Plugin author.

    https://wordpress.org/support/topic/restrict-access-to-products-categories/#post-12306541

    Hasn’t it solved yet?

    Plugin Support mlchaves

    (@mlchaves)

    Hello @eriz,

    Thanks so much for posting.

    Correct! The Content Control plugin supports restrictions for WooCommerce product categories.

    Please see the screen capture for what that setting looks like.

    https://share.wppopupmaker.com/lluoXY9l

    If you’re having the same issue as the OP (original post) in this thread, can you follow the instructions in this response?

    https://wordpress.org/support/topic/blocking-not-working-3/#post-14842080

    Please let us know how that goes.

    Cheers!

    Mark

    Thread Starter macdabby

    (@macdabby)

    Hi, the category is not the issue. I have had the product category selected the whole time.

    It does appear to be working now. Maybe it was a cache issue.

    Plugin Support mlchaves

    (@mlchaves)

    Hello @macdabby,

    Thanks so much for the follow-up.

    Understood. Yes, your OP was not about a category issue. Sorry, there was a second thread started after yours.

    At any rate, we’re glad that it’s working now for you.

    Have a great day 🙂

    Mark

    • This reply was modified 1 month, 1 week ago by mlchaves.
Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.