Support » Plugin: All In One WP Security & Firewall » Blocking .htaccess blocked me out of my site

  • I recently installed the plugin as I wanted my site to be secure. well, it’s extremely secure now as no one can access it…

    I clicked the .htaccess blocking and after saving I was blocked out. I can’t enter the wordpress admin panel, site itself gives me error:

    “WebsitePanel IIS Modules Error
    AuthName directive not found.

    File: PATH\.htaccess”

    I tried to remove the plugin by removing the plugin files from the plugin directory and restoring the .htaccess file from another fresh WP installation (without any security plugins), to no help – still can’t access my site. Any ideas? I’m really not looking for remaking my site….

Viewing 10 replies - 1 through 10 (of 10 total)
  • Please anyone? This damn plugin locked me out of my site and the site is my source of income.. Any ideas?

    If you can access the sql database you can turn off all plugins and regain access to your site.
    Login to the mysql database.
    Open the database that holds all the configs, on GoDaddy mine started with OFT…
    Open the table that ends with …_options
    click on the browse tab
    edit option 32 [it may be on the second page]
    delete all the text in that option and save the table.

    This will deactivate ALL your addons, they will still be installed just deactivated. Go and re-activate all but the All In One WP Security plugin.

    Thanks for the reply and a solution proposal. Unfortunately the edit didn’t restore my site, I still get the same Error. I do have access to the database, but it wasn’t completely equal as you told, I’m thinkin it’s due different MySQL admin software. Anyway, the row I edited was named as active_plugins, on row number 33. I figured that’s the one you mentioned, and emptying it didn’t change a thing. 🙁

    • This reply was modified 3 years, 8 months ago by lausas.

    Nope it’s labeled .._options and it’s ID 32. This will disable all the addons only, it will not uninstall them.

    The option_id with 32 is named moderation_keys, and it was empty in the begin with.

    you’ve got the wrong table and maybe the wrong database. as far as i know anyway…

    the only table that ends in _options, and the WP database, double checked, all correct…

    In my config I have 2 databases “Information_Schema” and “offt321…….” [a bunch of numbers]

    It’s under the second database, the offt…

    The table of wp_[serial number]_options. The item you’re looking for is option_id “32”, option_name “active_plugins”.

    Find the “active_plugins” option and delete it’s “option_value” contents.

    I have multiple databases, but I know which belongs to which site as I have named them accordingly, and in the same table there’s right webaddress also, so I’m definetily working with right table. There are no other _optios ending tables in the schema.

    I did empty the value, but it didn’t work.

    So none of them have an “active_options” object?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Blocking .htaccess blocked me out of my site’ is closed to new replies.