Support » Plugin: AntiSpam for Contact Form 7 » Block sending of only one CF7 module

  • Greetings! I have 4 modules on my site. All work, except 1 which is in the link, which always gives red message and doesn’t send. I redid a new module from scratch and this red error too. Disabling your plugin worked and that new form also submits fine. Need an update for your plugin? Thank you

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Erik

    (@codekraft)

    Ciao @edodemo

    Can I ask you to check if in that form you are using one of the words reserved by the honeypot? for example “name” (and not “your-name” which is correct), “phone” (and not “your-phone”) are reserved because those are the ones that are most easily filled by the bots.

    You can find the reserved words in the honeypot section -> “Name for the honeypots inputs[*]”

    Let me know if this is the problem, so in the next versions I will try to make sure it doesn’t happen! thank you in advance!

    Thread Starter edodemo

    (@edodemo)

    Well, in the section I read: “Name for the honeypots inputs[*]” :

    name
    email
    address
    zip
    town
    phone

    Are these good or bad?

    This is text in my form CF7:

    Il tuo nome [text* your-name akismet:author autocomplete:name]

    La tua email [email* your-email akismet:author_email autocomplete:email]

    Oggetto [text* your-subject]

    Il tuo messaggio (facoltativo) [textarea your-message]

    [submit “Invia”]

    What names should I change? Thankyou

    • This reply was modified 3 weeks, 6 days ago by edodemo.
    • This reply was modified 3 weeks, 6 days ago by edodemo.
    Plugin Author Erik

    (@codekraft)

    Those are names not to be used in your forms (in fact contact form 7 uses “your-name” by default), are used in order to generate fake honeypots inputs.

    This is because the bots have a list of fields they already know how to fill and example the field “name” or “phone”, so I encourage you to use nonstandard names, even in Italian is better, you could name the field “nome” or “telefono” and will fit perfectly!

    ps. double check your js script named “search.js” which prevents the input verification of cf7… there is an issue on line 19
    !target.closest('#search-form').length() has to be replaced with !target.closest('#search-form').length

    • This reply was modified 3 weeks, 6 days ago by Erik.
    Thread Starter edodemo

    (@edodemo)

    Oh ok! Got it, I’ll try right away

    Thread Starter edodemo

    (@edodemo)

    It still doesn’t start. These are the fields I put in Italian in form:
    Il tuo nome [text* tuo-nome akismet:author autocomplete:name]

    La tua email [email* tua-mail akismet:author_email autocomplete:email]

    Oggetto [text* your-subject]

    Il tuo messaggio (facoltativo) [textarea your-message]

    [submit “Invia”]

    Plugin Author Erik

    (@codekraft)

    try this
    >  double check your js script named “search.js” which prevents the input verification of cf7… the issue is on line 19
    !target.closest('#search-form').length() has to be replaced with !target.closest('#search-form').length

    Thread Starter edodemo

    (@edodemo)

    Ok made this change in .js file but still red error
    in sending form

    • This reply was modified 3 weeks, 6 days ago by edodemo.
    Plugin Author Erik

    (@codekraft)

    looks now it is working (i just send an email), remember always to delete browser cache after changing js/css files with [shift + ctrl + r] after changes 😉

    Thread Starter edodemo

    (@edodemo)

    Yes now it works because I deleted the text after: akismet author autocomplete etc… Now that I put the words back it doesn’t work. Try it too. I still don’t quite understand which name is not good and must be different😞</img>

    Plugin Author Erik

    (@codekraft)

    Ok, I got it!!! I can try to send the email but it looks like it’s blocked as spam, however looking at the response I’m not sure if it’s the cf7a plugin doing this.

    check out this is the answer from server: {
    “invalid_fields”: []
    “status”: “spam”,

    }

    if you have flamingo try to look with that the reason for the spam mail or as soon as I finish my workday I will try to install an environment similar to yours (with akismet…) so I can tell you something better!

    Thread Starter edodemo

    (@edodemo)

    Agree very nice. You make yourself pure when you are free. For now I tend the forms without spam checking so they send. If you get more clear information, let me know. Thanks again

    Plugin Author Erik

    (@codekraft)

    hi @edodemo I just wanted to tell you that I have tried several times to reproduce your issue on my website an with some vm, with the same code you provided and the standard settings, with and without Akismet, but I have never been able to reproduce the issue.

    From the way you describe the problem, it sounds like something related to js, and since the cf7 anti-spam script loads from the footer, I suspect that the cause came from before (e.g. those console errors that there were) and the anti-spam crashed as a consequence. BTW I could be wrong of course if you can find a way to reproduce the failure let me know

    The good news is that I have updated the plugin to 0.4.4 with a new bot trap that checks request headers and some fixes (I don’t think they were related to your problem though). I wish you a good evening!

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.