Support » Plugin: Yoast SEO » Block ?p= search results page

  • Resolved pixelstorm

    (@dfhectik)


    I see yoast will put a no index on /?s=search-query but it still allows /?p=search-query to be crawlable. How can i stop the page search query url /?p=search-query from being indexed?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Suwash Kunwar

    (@suascat_wp)

    Hi @dfhectik,

    If /?p=search-query is a custom search query page, you need to set the noindex manually for this custom search query page. Noindex via Yoast SEO plugin can be set on WordPress generated page via a dashboard.

    Thread Starter pixelstorm

    (@dfhectik)

    thank you. ok i’ll set it to no index manually. This is not custom though. I’ve tested this on 3 wp sites and on all 3 sites ?p=sadkad returns blog posts.

    Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    the ?p= is a parameter set by WordPress which permits users to search by the post ID. So if you have mysite.com/?p=98, WordPress will show the page/post which has the post ID of 98.

    If you enter in letters instead of numbers, WordPress will show you page which all your blog posts on it. So mysite.com/?p=sadkad would return the blog page which shows all the blog posts on it.

    While we are not sure if your set-up we would not expect Google to crawl or index those ?p= pages. We say this as the canonical points elsewhere. So Google will index the canonical.

    If you can provide us an example post/page we can verify this.

    Thread Starter pixelstorm

    (@dfhectik)

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    Thanks for sharing the relevant URL with us. We were able to reproduce the issue on our end.

    We see the relevant page that includes /?p=*** isn’t a search page but it’s a page with the plain permalink structure enabled on it. It’s odd as it looks like you have pretty permalink enabled on your site.

    Can you please confirm what permalink structure do you have by looking at the WordPress permalinks page?

    On the other hand, when looking at the relevant page, we couldn’t find any canonical URL at all and that explains why the relevant page is appearing in the Google search results.

    Thread Starter pixelstorm

    (@dfhectik)

    Thanks, we are using custom structure /%category%/%postname%/

    When you say relevant page do you mean /?p=***

    thanks again for your help.

    Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    We mean that the asterisks can be any value. In reviewing the issue we can see all those kinds of /?p=*** pages like: https://cfooncall.com.au/?p=sjdas or https://cfooncall.com.au/?p=sadakn all go to the homepage https://cfooncall.com.au/ .

    While we are not seeing a canonical tag in the source code but we aren’t seeing those URLs appear in Google. It seems likely is just crawling the URLs and telling you it found them. It does not appear Google is actually indexing them and making them appear in Google.

    We have seen this kind of issue before and usually what happens is that some searchbox on the site is not created correctly so Google gets into the searchbox and starts crawling URLs and reporting them.

    To resolve this issue we suggest the following:

    1. Contact your theme developer and ask them to verify that the searchbox has been created in a way that prevents search engines from crawling URLs.

    2. Consider creating a robots.txt rule which will tell Google to not crawl those URLs. This guide explains how to edit the robots.txt: https://yoast.com/help/how-to-edit-robots-txt-through-yoast-seo/

    You can use this guide to create a disallow rule: https://searchengineland.com/a-deeper-look-at-robotstxt-17573

    Thread Starter pixelstorm

    (@dfhectik)

    Thank you so much.. some great SEO insights here.

    Plugin Support Priscilla Chapman

    (@priscillamc)

    Hi @dfhectik,

    Thanks for getting back to us. We’re marking this issue as resolved.

    You’re welcome to create a new forum topic if you have any other questions.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Block ?p= search results page’ is closed to new replies.