Support » Plugin: All In One WP Security & Firewall » Block Fake Googlebots is blocking Google / pages removed from google index.

  • Hello,

    I have a big problems with my website in Google Search Console and google index:
    1. Google couldn’t see any content in my sitemaps. When I turn off “Block Fake Googlebots” in All In One WP Security & Firewall, everything works fine. So i have question if I disable this option, my site will be enough secure? Or are you doing something in this direction to fix it? Because I have already seen a similar topic.

    2. After some updates in september – december. My site has been almost completely removed from the google index (from 2000 pages to 100). I do not know exactly what the fault is.
    But the site was always run with all the google guidelines, so the problem must be on the side of wordpress plugins, which block google bots. Maybe it’s a fault “Block Fake Googlebots” option?

    In google search console I have information about excluded pages from index – its “error 404” and “The page is blocked by a robots.txt file” (but my robots file is clear – User-agent: *
    Disallow: /wp-admin/
    Allow: /wp-admin/admin-ajax.php)

    Please help me! My site is going down because of this, and I dont know what to do…

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, is your issue similar to the following support thread? If it isn’t what SEO plugin are you currently using?

    Thank you

    yep its simillar.but I didnt find any solution to my problem there. im using yoast seo and bimber theme, but I checked other plugins that making sitemaps and still had the same issue. so any solution than using another security plugin? I’m afraid to use something else. because cooperation with others security plugins ended in the fact that the site was infected. Can I just have this option “Block Fake Googlebots” turned off? is it very dangerous?

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, I am currently also using Yoast plugins.

    The following is a list of all the Firewall features enabled in my site. Currently my security meter is set at 281/505.

    Basic Firewall Settings

    Enable Basic Firewall Protection:
    Completely Block Access To XMLRPC:
    block access to debug.log file

    Additional Firewall Rules

    Disable Trace and Track
    Forbid Proxy Comment Posting

    6G Blacklist/Firewall Rules

    Enable 6G Firewall Protection

    Internet Bots

    Block Fake Googlebots.

    Prevent Hotlinks

    Prevent Image Hotlinking.

    404 Detection

    Enable IP Lockout For 404 Events

    The above works for me and Google does not penalize my site at all.

    Let me know if you need more information or help.

    Kind regards

    • This reply was modified 1 year, 1 month ago by  mbrsolution.
    silviuclg

    (@silviuclg)

    This is the solution:

    wpsolutions (@wpsolutions)
    1 month, 2 weeks ago
    Hi @svayam,
    Did you try changing the IP address settings to see if that makes a difference?
    I’m referring to the following settings:
    Settings >> Advanced Settings >> IP Retrieval Settings

    Sometimes people have a hosting setup where there might be load-balancers or proxies and retrieving the IP address via the $_SERVER[‘REMOTE_ADDR’] gives the proxy address instead of the real visitor IP address.
    Try selecting “HTTP_X_FORWARDED_FOR” and see if that improves the situation.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Block Fake Googlebots is blocking Google / pages removed from google index.’ is closed to new replies.