Support » Fixing WordPress » Block editor won’t save if there is a link in the article

  • Resolved glanzi

    (@glanzi)


    Hi!
    I have a recurrent problem with the block editor, and now I would like to solve it once for all, hope you can help me 🙂

    I really like the block editor, but when I try to add a link to the text, the editor won’t save the article anymore.

    I tried to narrow down the problem and it seems that is the attribute href that causes the issue.

    It simply goes like that: I edit some text as a link (I tried both with block editor and html view editor) and when I press publish (or save as draft), it says that has failed the update.

    I tried with just <a> tag, and it’s fine, but when I add the href=” attribute, the editor won’t save anymore.
    Is that a known issue? I didn’t find anything on the internet.

    P.S.
    My wordpress version is 5.4.2, all plugins are up to date.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and switch to the default Twenty Twenty theme. If the problem goes away, enable them one by one to identify the source of the problem.

    If you can install plugins, install Health Check. On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    Thank you for the answer James.
    I already tried to identify a single plugin, but when I activate the diagnosys mode, the problem persists.

    I did it again, and I noticed that the error is a bit more verbose and says (I had to translate from Italian):
    “Update failed. The answer is not a valid JSON’s answer.”

    Any idea?

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Try downloading WordPress again, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel (consult your hosting provider’s documentation for specifics on these), and delete then replace your copies of everything on the server except the wp-config.php file and the /wp-content/ directory with fresh copies from the download. This will effectively replace all of your core files without damaging your content and settings.

    Some uploaders tend to be unreliable when overwriting files, so don’t forget to delete the original files before replacing them.

    Ok, I will try it after being sure to have a proper backup, just in case.

    Can’t I just rename the old root folder and upload the fresh version? I think that’d be quicker.

    First of all, thank you for your help!

    I did it as you suggested, James, but nothing changed.

    Here’s what I did:
    1. Using Filezilla, I erased everything from the /www/ folder on server, except wp-config.php, the favicon file and the folder /wp-content/ (On the server the root folder contains /www/ and /logs/ folder, just to be clear).
    2. Downloaded and unzipped WP file from the official wordpress.org website. I immediately removed the /wp-content/ folder and the wp-config-sample.php file from local extracted folder.
    3. Uploaded everything left in the /www/ folder on the server, where the old file were.

    Website works flawless as before, but the block editor issue is still there.

    I also tried again to disable all the plugins with “health check”, still no solution, sadly.

    Any idea now? Am I damned? 🙂

    One other thing, just to be sure:

    I downloaded an english version of WP, but when I uploaded it on the server, it has the Italian language, which is the one I used before. Is this setting either on /wp-content/ or wp-config.php?

    If not, the erase command on server didn’t work, and that would make the past attempt useless.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Ok, please make sure that your browser is up to date: https://browsehappy.com/

    If it is not, please try updating your browser or switching to a different browser.

    If it is, please do these two things:

    1. Try clearing your browser’s cache and cookies.

    2. Try with all browser extensions or add-ons temporarily disabled.

    Please let us know how each step goes for you, and which browser (and version of) you’re using if you’re still having trouble.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Sorry, I forgot the last question. Language is set at Settings > General in your site’s Dashboard.

    Clear the cache worked for me!
    Hooray!

    Thank you a lot James, I really appreciate your help!
    I really want to use the block editor as default!

    It was great to find a kind and clear moderator that helped me. I had terrible times in other forums before.

    Have a nice rest day or night (wherever latitude you are).

    Cheers!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.