Support » Fixing WordPress » Block Editor show error message that JavaScript is required

  • Just upgraded our sandbox system to WordPress 5.0.3.

    Opened a page in the block editor, getting an error message saying that Block Editor requires Javascript. Double checked in my browser settings (Safari Version 12.0.2 (14606.3.4)), Javascript is on – so the error message is not correct.

    Generally, the block editor seems to work despite the error message. However, I am not 100% sure of that. Don’t have the chance to do extensive testing on this right now and some blocks from a 3rd party plug in show strange behaviour (might be their issue, not sure).

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 18 total)
  • +1 I’m getting this also. There’s a bug going round…..

    @kaicho are you also using Safari?

    If either of you could share a screen shot of what you are seeing. Also if you can a screen shot of the console log if you see any errors there.

    Info on Console Tab for Safari here: https://support.apple.com/guide/safari-developer/console-tab-dev170bfef99/11.0/mac/10.13

    I’m also getting this error, using Chrome. Gutenberg is working as expected.

    Clean install, upgraded to 5.0.3. WPML primary plugin (WPML Multilingual CMS) seems to be the cause…disabling it removes the UI error. No related error in dev tools console.

    Not sure how to share a screenshot, here’s the message text and the console output:

    MESSAGE:
    The block editor requires JavaScript. Please enable JavaScript in your browser settings, or try the Classic Editor plugin.

    CONSOLE:
    [Log] JQMIGRATE: Migrate is installed, version 1.4.1 (load-scripts.php, line 9)
    [Warning] wp.date.getSettings is deprecated and will be removed from Gutenberg in 4.4. Please use wp.date.__experimentalGetSettings instead. Note: Unstable APIs are strongly discouraged to be used, and are subject to removal without notice. (product-category-block.js, line 69)
    [Error] Error: Syntax error, unrecognized expression: #/
    error (load-scripts.php:2:12788)
    tokenize (load-scripts.php:2:18792)
    select (load-scripts.php:2:21596)
    fa (load-scripts.php:2:7322)
    find (load-scripts.php:9:3692)
    find (load-scripts.php:2:24114)
    find (load-scripts.php:9:8937)
    init (load-scripts.php:2:24681)
    init (load-scripts.php:9:3143)
    n (load-scripts.php:2:420)
    hashNavigation (vc-accordion.min.js:1:10656)
    i (load-scripts.php:2:27455)
    fireWith (load-scripts.php:2:28215)
    ready (load-scripts.php:2:30018)
    K (load-scripts.php:2:30374)
    [Error] Error: Syntax error, unrecognized expression: #/
    error (load-scripts.php:2:12788)
    tokenize (load-scripts.php:2:18792)
    select (load-scripts.php:2:21596)
    fa (load-scripts.php:2:7322)
    find (load-scripts.php:9:3692)
    find (load-scripts.php:2:24114)
    find (load-scripts.php:9:8937)
    init (load-scripts.php:2:24681)
    init (load-scripts.php:9:3143)
    n (load-scripts.php:2:420)
    hashNavigation (vc-accordion.min.js:1:10656)
    dispatch (load-scripts.php:3:12450)
    handle (load-scripts.php:3:9179)
    [Log] JQMIGRATE: Migrate is installed, version 1.4.1 (load-scripts.php, line 9)
    [Error] Failed to load resource: the server responded with a status of 404 () (slick.min.css.map, line 0)

    Also: Just tried deactivating WPML. With WPML inactive, the error message does not show.

    Should I open a ticket with them?

    I was using Chrome on Windows 10. I really don’t have patience. I don’t know why Gutenberg was implemented in the way that it was. People are dealing with commercial entities and massive changes implemented quickly are bound to produce this type of issue. Therefore, Classic Editor should have been principle with the option of Gutenberg until absolutely stable. Bugbears aside, I wanted no doubts as to results so I immediately installed classic editor working alongside the pre-existing WPBakery Page Builder so error is gone because Gutenberg is.

    … however, prior to the WordPress update I was pleasantly surprised by Gutenberg. It was the first time I’d decided to take the plunge and use it. But I’m not having any clouds hanging over the sites I’m working on so I’ve got out the water for a while.

    • This reply was modified 10 months, 1 week ago by kaicho.

    I observe the same with Firefox. “The block editor requires JavaScript. Please enable JavaScript in your browser settings, or try the Classic Editor plugin.”

    With WP 5.0.3. and latest versions of WPML.

    • This reply was modified 10 months, 1 week ago by TiramiSue. Reason: added WPML

    Created a support ticket over at WPML for this as well…

    @awilmsmeier – I am experiencing same issue in Chrome and running WP 5.0.3 and latest version of WPML. I don’t see it as ‘known issue’ yet in WPML Support Forum. Wonder if I should submit a ticket as well or just wait and see what comes of yours.

    Not sure if that would help. Normally, WPML support is quite quick in responding.
    Here’s the link to my WPML ticket in case you’d like to follow it: https://wpml.org/forums/topic/block-editor-shows-error-message-that-javascript-is-required/

    @awilmsmeier thanks for that. I’ve commented over there to follow along.

    @awilmsmeier Thank you very much for taking care.

    Mihai Apetrei

    (@apetreimihaidaniel)

    Hello everyone.

    I have just responded here: https://wpml.org/forums/topic/block-editor-shows-error-message-that-javascript-is-required

    The notification should disappear as soon as we launch the update on Monday the latest and it shouldn’t affect anything on your site functionality-wise until then.

    Kind regards.

    @apetreimihaidaniel – Awesome, thanks. So cool when the Internet works for good. 🙂

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Block Editor show error message that JavaScript is required’ is closed to new replies.