Support » Fixing WordPress » Block editor no longer working: only shows HTML

  • Resolved James

    (@exelejames)


    I’ve made lots of changes to my WordPress site recently and now the block editor (i.e. Gutenberg) does not work, nor can I see the Visual and Code tabs on the classic editor when I have the classic editor plugin installed. Here’s the (related?) changes I’ve made, as best as I can remember:

    • Installed the new Gutenberg plugin
    • Installed the classic plugin
    • Added & Connected Jetpack to my site (self-hosted)
    • Removed and Added Jetpack, Gutenberg, and Classic editor plugins many times while debugging this issue

    Here’s a screenshot of my block editor, notice the block add button is greyed out:
    Can’t add blocks

    Here’s a screenshot of the post where only HTML is shown:
    Block editor stuck showing HTML

    The keyboard shortcut to switch between visual and code (CTRL-SHIFT-ALT+M) does nothing.

    When I installed the Classic Editor plugin to see if that helped, I can’t see the visual or code tabs:
    Classic editor plugin: no visual or code tabs. This was done in troubleshooting mode on 2019 theme and there were no JS errors in the console.

    Here’s some more information I’ve gathered and actions I’ve performed in troubleshooting all this:

    • First saw this issue in 4.9.8, upgraded to version 5.0.0, and now upgraded to 5.0.1. This is still a problem.
    • Run health check and have done all this with troubleshooting mode on and all plug-ins disabled
    • With troubleshooting mode enabled, there are no JS errors in the console
    • Verified that the option to disable the visual editor is unchecked for my user account
    • With Jetpack connected to the site, I was able to edit posts and pages using the Visual/Code editor (no Gutenberg, but I think that requires the plugin?). But editing posts and pages in wp-admin still showed the problems I’m describing. I worked through it with Jetpack support, but since it’s not really an issue with Jetpack I’ve migrated to the support forums.
    • Checked for related cases, and they either don’t apply or the solutions don’t work:

    I’d appreciate any assistance. I can do HTML, but I’d rather have access to HTML and the new block editor!

    I’m happy to include any more information that would be helpful.

    • This topic was modified 1 year, 1 month ago by James.
    • This topic was modified 1 year, 1 month ago by James. Reason: Add WP version when problem started and has continued through subsequent WP versions
Viewing 7 replies - 61 through 67 (of 67 total)
  • @exelejames OOPs! Never mind. Got HTTPS figure out and installed. Sorry to bother.

    Not sure about the long-winded solutions some have posted on this topic, but after trying them all and failing, I finally figured it out and it was really simple. And all my fault!

    For some dumb reason, I had been into my User Profile and at the very top of ‘Personal Options’ I stupidly ticked the ‘Visual Editor’ Box (Disable the visual editor when writing). Not quite sure why I did this, but I do now vaguely remember doing it a couple of weeks ago.
    Yes, I am a fool!

    But anyway, un-ticked it and all is well again.
    That easy!

    I was also facing this problem and my solution was also in the profile tab.

    But my case was a little different: I created a user some time ago directly in the database (the previous admin only gave me FTP and database access, so that was the only option to create a user). The ‘screen name’ was not set. So basically my profile was broken. After inserting and saving the screen name, Gutenberg started working again!

    Hi, My name is imran chandio and I run a blog https://thefanmanshow.com
    I was also facing the same issue.
    after logging in to dashboard, the every page on opening must should open and give an option to update the page from there (front end) but it was not happening.

    After two hours, I found an issue. I have changed my website from http to https and some internal links were with http
    for example https://thefanmanshow.com/mobile/all-secret-codes-for-iphone-2018/
    was interlinked in some other page with http://thefanmanshow.com/mobile/all-secret-codes-for-iphone-2018/
    I was opening a page with http version and found the editor missing. So, i would recommend you to try this solution may be this should work for you.
    before this I have also tried
    Delete and reinstall WP Bakery VC (but this solution didn’t worked for me)

    formerfatguy

    (@formerfatguy)

    @arabnas your heads up about the user having the visual editor turned off was the info I needed. Thanks

    mukeshtruweight

    (@mukeshtruweight)

    I have same issue now whene i updated to WP5.3.2 –
    When using the “classic Editor” bare on a page, the Visual tab is there, but when I click on it, it gets a blue halo (active?) but the Visual tab never really opens. Text editing is all that is available.

    Plz help me ASAP as its my current Production site.

    praveen9620

    (@praveen9620)

    @arabnas Thank you . You saved my time

Viewing 7 replies - 61 through 67 (of 67 total)
  • You must be logged in to reply to this topic.