Support » Fixing WordPress » Block editor no longer working: only shows HTML

  • Resolved James

    (@exelejames)


    I’ve made lots of changes to my WordPress site recently and now the block editor (i.e. Gutenberg) does not work, nor can I see the Visual and Code tabs on the classic editor when I have the classic editor plugin installed. Here’s the (related?) changes I’ve made, as best as I can remember:

    • Installed the new Gutenberg plugin
    • Installed the classic plugin
    • Added & Connected Jetpack to my site (self-hosted)
    • Removed and Added Jetpack, Gutenberg, and Classic editor plugins many times while debugging this issue

    Here’s a screenshot of my block editor, notice the block add button is greyed out:
    Can’t add blocks

    Here’s a screenshot of the post where only HTML is shown:
    Block editor stuck showing HTML

    The keyboard shortcut to switch between visual and code (CTRL-SHIFT-ALT+M) does nothing.

    When I installed the Classic Editor plugin to see if that helped, I can’t see the visual or code tabs:
    Classic editor plugin: no visual or code tabs. This was done in troubleshooting mode on 2019 theme and there were no JS errors in the console.

    Here’s some more information I’ve gathered and actions I’ve performed in troubleshooting all this:

    • First saw this issue in 4.9.8, upgraded to version 5.0.0, and now upgraded to 5.0.1. This is still a problem.
    • Run health check and have done all this with troubleshooting mode on and all plug-ins disabled
    • With troubleshooting mode enabled, there are no JS errors in the console
    • Verified that the option to disable the visual editor is unchecked for my user account
    • With Jetpack connected to the site, I was able to edit posts and pages using the Visual/Code editor (no Gutenberg, but I think that requires the plugin?). But editing posts and pages in wp-admin still showed the problems I’m describing. I worked through it with Jetpack support, but since it’s not really an issue with Jetpack I’ve migrated to the support forums.
    • Checked for related cases, and they either don’t apply or the solutions don’t work:

    I’d appreciate any assistance. I can do HTML, but I’d rather have access to HTML and the new block editor!

    I’m happy to include any more information that would be helpful.

    • This topic was modified 11 months ago by James.
    • This topic was modified 11 months ago by James. Reason: Add WP version when problem started and has continued through subsequent WP versions
Viewing 15 replies - 46 through 60 (of 65 total)
  • If all else fails, just install the “Disable Gutenberg” extension and get on with work.

    James

    (@exelejames)

    @rzon Thanks for the post, this may be something people want. But I don’t want future readers to this think this will solve the issues this thread addresses.

    For future readers, the issues with Amazon CloudFront removing headers were present in my system when Gutenberg was installed and also after Gutenberg was removed. Please note in my original post:

    Removed and Added Jetpack, Gutenberg, and Classic editor plugins many times while debugging this issue

    I’ve got the same problem. My user already had a nickname and the ‘Disable visual editor’ setting was unchecked; toggling both did not work. I changed my Cloudflare SSL setting from ‘Full (Strict)’ to ‘Full’, and even put Cloudflare into inactive Development mode, then refreshing the Edit page shows no change. I am dead in the water, can’t edit a page. Would appreciate some insight!

    I have the same issue in WordPress 5.2.

    The solution for me was to disable plugin Column Shortcodes, by Codepress

    Now Editor works fine and can switch between Visual or HTML editor.

    • This reply was modified 5 months, 4 weeks ago by bgrgroup.

    Thanks bgrgroup. My problem turned out to be a Firefox extension, User Agent Switcher. Disabling that fixed it.

    I am having the same problem as everybody else with the Block Editor in Version 5.2.1 of WordPress. I have tried all the solutions mentioned above, but I cannot resolve the problem.

    When I go to ADD NEW POST, I get a “tip” that I can access blocks by clicking on the + sign on the upper left of the screen, but the + is greyed out and is not accessible.

    I have deleted every plugin. I have downloaded WordPress several times. I am utterly frustrated.

    Does anybody else have any suggestions?

    Did you try a different browser?

    Hi Jim,

    I have tried Safari (because I use a Mac), Chrome and Firefox. Same result.

    I tried all seven of the default themes, in case there was one that worked. No luck.

    I deleted all but one of the themes. No luck.

    I deactivated all plugins, No luck.

    I deleted all plugins. No luck.

    Finally, I downloaded the plugin “Disable Gutenberg”, which at least allowed me to return to the classic editor. So I am “reasonably” happy for now.

    I wonder if the problem may be that, as a rank amateur and non-techie, I am using HostGator for my setup and server. Once in a while, I get a message that says that I do not have the latest version of PHP, which I cannot fix on my own, as it is installed by HostGator. When I go to HostGator, it simply says that they will use the most recent PHP version available, but I have difficulty figuring out which one is being used. Perhaps they have not yet updated to Version 7.xxx.

    In any case, as a beginner, I am happy for now. Once my site is up and I have a bit more time, I will re-investiage Gutenberg and Block Editing. But if you do have any other ideas, please fire away.

    Many thanks for responding.

    Brian

    You can see what PHP version is being used at Tools > Site Health > Info > Server. Apparently this is a difficult problem with all sorts of different causes.

    • This reply was modified 5 months, 1 week ago by Jim.
    James

    (@exelejames)

    Glad you were able to get things working @jwmc.

    @obiedo32, the thing that helped me solve my issue is detailed in this post. If CloudFront is not part of your architecture, or something you have control over, you can test adjusting your functions.php like the post describes.

    Obviously YMMV, and i suggest backing up your site before making an edit like that.
    Good luck 🙂

    @jwmc , thank you for that info. It appears that I am using Version 7.1.14, which seems to be the most recent.

    I will try the solution suggtested by @exelejames .

    Much appreciated.

    @exelejames, thank you for the suggestion. I am not much of a tech person, but I will try your suggestion.

    Thanks for taking the time.

    Brian

    Uhhhh! What is YMMV, por favor?

    James

    (@exelejames)

    @obiedo32 YMMV is short for “Your mileage may vary”. What I meant to communicate is that the functions file modifications worked for me, but your situation may work out different 🙂

    @exelejames I have looked at the Functions.php file in the Theme editor, and I would have NO IDEA where to insert the function that you provided. I will wait until I have access to a programmer.

    Another question while I have you: Site Health says that I am not using https, but I have no idea how to use it. Does that take a programmer too?

    Man thanks once again.

Viewing 15 replies - 46 through 60 (of 65 total)
  • You must be logged in to reply to this topic.