Support » Fixing WordPress » Block editor no longer working: only shows HTML

  • Resolved James

    (@exelejames)


    I’ve made lots of changes to my WordPress site recently and now the block editor (i.e. Gutenberg) does not work, nor can I see the Visual and Code tabs on the classic editor when I have the classic editor plugin installed. Here’s the (related?) changes I’ve made, as best as I can remember:

    • Installed the new Gutenberg plugin
    • Installed the classic plugin
    • Added & Connected Jetpack to my site (self-hosted)
    • Removed and Added Jetpack, Gutenberg, and Classic editor plugins many times while debugging this issue

    Here’s a screenshot of my block editor, notice the block add button is greyed out:
    Can’t add blocks

    Here’s a screenshot of the post where only HTML is shown:
    Block editor stuck showing HTML

    The keyboard shortcut to switch between visual and code (CTRL-SHIFT-ALT+M) does nothing.

    When I installed the Classic Editor plugin to see if that helped, I can’t see the visual or code tabs:
    Classic editor plugin: no visual or code tabs. This was done in troubleshooting mode on 2019 theme and there were no JS errors in the console.

    Here’s some more information I’ve gathered and actions I’ve performed in troubleshooting all this:

    • First saw this issue in 4.9.8, upgraded to version 5.0.0, and now upgraded to 5.0.1. This is still a problem.
    • Run health check and have done all this with troubleshooting mode on and all plug-ins disabled
    • With troubleshooting mode enabled, there are no JS errors in the console
    • Verified that the option to disable the visual editor is unchecked for my user account
    • With Jetpack connected to the site, I was able to edit posts and pages using the Visual/Code editor (no Gutenberg, but I think that requires the plugin?). But editing posts and pages in wp-admin still showed the problems I’m describing. I worked through it with Jetpack support, but since it’s not really an issue with Jetpack I’ve migrated to the support forums.
    • Checked for related cases, and they either don’t apply or the solutions don’t work:

    I’d appreciate any assistance. I can do HTML, but I’d rather have access to HTML and the new block editor!

    I’m happy to include any more information that would be helpful.

    • This topic was modified 11 months, 1 week ago by James.
    • This topic was modified 11 months, 1 week ago by James. Reason: Add WP version when problem started and has continued through subsequent WP versions
Viewing 15 replies - 1 through 15 (of 65 total)
  • @exelejames i think its really helpful thread.

    Can you please check the console is there have any error notes?

    Thanks @rajanit2000

    By console, do you mean the console in my browser? If so, there are no errors in JS. I mentioned this in my post (but it is very long, isn’t it!).

    I have an old screenshot, but here’s one from today for good measure: No JS errors in console.

    I just noticed (and I updated to 5.01 today) that I have no Visual tab in my WPBakery text block element. I have Classic Editor installed. Pages render OK, but I wanted to paste some text from another page that contained links, and now only the text shows up. Anyone know if there is a reason the Visual tab had to be removed? I’m posting on this thread, because it seems to be related.

    – Edited to add:

    A staging site clone of my production site (where the problem is happening) is NOT having the problem, the text and Visual tabs show up as normal, and the staging site was also updated to 5.01. So … weird. The staging site is almost identical to the production site, but it has diverged somewhat in terms of plugins, etc. I won’t have time to dig into this more today, but clearly it’s not as simple as pointing fingers at the update. *sigh*

    Another clue: When using the “classic Editor” bare on a page, the Visual tab is there, but when I click on it, it gets a blue halo (active?) but the Visual tab never really opens. Text editing is all that is available.

    Regarding staging sites, I have two. I updated both to 5.01. The older one (cloned from production maybe 3 weeks ago) is working fine. The other one (cloned this week) is exhibiting the bug.

    Oh, and none of these sites use Jetpack, so that is almost certainly not involved.

    Another clue: The WPBakery “Backend Editor” shows the bug, but the “Frontend” editor still has both tabs that work in the text element. Pasting rich text (including links) works as expected. Opening those pages in the backend editor or the classic editor do not work properly.

    The Classic editor does show both tabs, but regardless of the tab shown, it acts like the “text” tab, and clicking the tab does not switch, it just creates the “Active” (blue) halo around the tab, but doesn’t go anywhere.

    • This reply was modified 11 months, 1 week ago by edwardroofvents. Reason: Crossed out wrong info. The Visual tab does act like the Visual Tab when you manage to get to it in the Classic editor

    Thanks @edwardroofvents

    I wonder if we’re experiencing different issues, in this case. WPBakery recommends not running WordPress 5 with their themes on their site:

    We strongly recommend you to disable Gutenberg editor for WPBakery Page Builder based themes. If you use WordPress with built in Gutenberg editor you can disable it with this official plugin.

    I’m experiencing this issue while in troubleshooting mode with no plugins active.

    • This reply was modified 11 months, 1 week ago by James. Reason: Remove redundant statement and clarify my issue

    Possible, but on my staging site exhibiting the bug I disabled WPBakery, and the bug in the classic editor is still there. The tabs show up, but you can only use the one you start in. I no longer have the option of the Frontend editor, of course. So … it may still be related, though it could look different depending on what plugins are installed.

    designsimply

    (@designsimply)

    Can you completely uninstalling the Gutenberg and Classic Editor plugins and try with WordPress 5.0.1 again?

    Have you tried testing with all plugins turned off? (It sounds like you have, but I wanted to double check since you said you added and removed plugins but didn’t specifically mentioned testing will all plugins deactivated.)

    Does the same problem happen for you in more than one browser?

    James

    (@exelejames)

    Hi @designsimply, thanks for your attention and assistance!

    I have tested with all plugins turned off using troubleshooting mode. I did mention it above:

    Run health check and have done all this with troubleshooting mode on and all plug-ins disabled

    …but after reading my original post I can see where the state of the site during my testing and screenshots (and the current state of my site) is not clear. I hope this helps:

    1. I uninstalled the Gutenberg plugin after installing WP 5.0.0
    2. All gutenberg-related issues above were tested in troubleshooting mode with WP v5.0.1, 2019 theme, all plugins disabled
    3. The classic editor issues were tested in troubleshooting mode, WP v5.0.1, 2019 theme, all plugins disabled except the classic plugin

    The Gutenberg plugin was already uninstalled, and I have just uninstalled the Classic Editor plugin (it was already disabled, but now it’s gone completely). With the classic editor plugin removed, I still see the same issues in multiple browsers:

    • Chrome 71 on Win10: Can’t add a block and only can access HTML, no visual mode. There are no JS errors in the console.
    • Edge 42 on Win10: Can’t add a block and the editor is stuck in HTML, no visual mode available (sorry, didn’t look at the JS console. I can, though, if that would be helpful.)

    Thanks again 🙂

    • This reply was modified 11 months ago by James. Reason: Simplify wording
    • This reply was modified 11 months ago by James. Reason: Add notes on other continuing issues

    I have the same problem.

    Visual Mode does not work and neither the options nor the
    selector for Visual Mode or Code Mode.

    I am running WordPress 5.0.1 and have tried to disable all plugins but the problem continues.
    It also has no errors in the Javascript Console.

    The funny thing is that in my local environment everything works perfectly.
    I’m having trouble in the homologation environment that is in AWS

    FWIW, I installed this ancient plugin to see if it would help. It identified that Visual Editor was off and allowed me to enable it but yet again nothing happens.

    https://www.edapp.com/blog/wp-admin/plugin-install.php?tab=plugin-information&plugin=modify-visual-editor&TB_iframe=true&width=600&height=550

    This all started with (I think) the 4.9.9 Update that promised to “Honor Visual Editor being turned off.” Whatever was done at that point seems to have killed everything.

    • This reply was modified 11 months ago by elyi.
    James

    (@exelejames)

    i’ve found a few issues on Gutenberg’s GitHub page that seem related to this problem. Here’s a list for reference:

    edwardroofvents

    (@edwardroofvents)

    Updating to 5.0.2 seems to have fixed the problem I was having. I can now get to visual and text modes in the tabs, both in bare classic editor, and in text element boxes.

    James, I’m curious if you’ve tried this update, and if it helped.

    James

    (@exelejames)

    @edwardroofvents, thanks for the tip 🙂

    i got the email telling me about my site’s auto-update to 5.0.2 last night and checked as soon as i could!

    Unfortunately, i’m still in the same boat.

    designsimply

    (@designsimply)

    I just noticed that the first StackExchange link you included ( https://wordpress.stackexchange.com/questions/126110/visual-editor-missing-server-side-problem-how-would-you-debug-it ) did update their question to include the solution that worked for them:

    Turns out for some reason my php.ini dropped the apc segmentation and thus my entire server got fragmented and it would break JS

    Source: https://wordpress.stackexchange.com/a/126156/10377

    That sounds like such a long shot to me, especially if you have a pretty standard hosting setup—which I should ask about, is your web server setup customized or is it something pretty standard?

Viewing 15 replies - 1 through 15 (of 65 total)
  • You must be logged in to reply to this topic.