• Hi,

    I’ve found info about your plugin on WP Tavern. It really looks promising and I wanted to try it on my WP multisite (network) setup.

    However, after installing and activating the plugin and trying to edit existing page I got the error message in block editor (Gutenberg): “The editor has encountered an unexpected error. [Attempt Recovery] [Copy Post Text] [Copy Error]”

    After clicking the “[Copy Error]” button, here is what the error looks like:

    TypeError: this.activateMode is not a function
        at ./wp-includes/js/media-views.min.js?ver=5.4.2:2:24708
        at st (./wp-content/plugins/editorplus/build/build.js?ver=1.1.0:9:4747)
        at Function.sa (./wp-content/plugins/editorplus/build/build.js?ver=1.1.0:9:40708)
        at i._createModes (./wp-includes/js/media-views.min.js?ver=5.4.2:2:24668)
        at initialize (./wp-includes/js/media-views.min.js?ver=5.4.2:2:24077)
        at initialize (./wp-includes/js/media-views.min.js?ver=5.4.2:2:25732)
        at initialize (./wp-includes/js/media-views.min.js?ver=5.4.2:2:29623)
        at i.h.View (./wp-includes/js/backbone.min.js?ver=1.4.0:2:14225)
        at i.constructor (./wp-includes/js/wp-backbone.min.js?ver=5.4.2:2:2608)
        at i.constructor (./wp-includes/js/media-views.min.js?ver=5.4.2:2:23524)

    Can you please check and fix if possible?

    Thank you and best regards,

    Oliver

Viewing 9 replies - 1 through 9 (of 9 total)
  • BTW, I’ve tested on WP 5.4.2 with Twenty Twenty 1.4 theme and only Editor Plus plugin is active.

    I have the same error.

    Hi @munirkamal,

    I can see there is a new plugin version but the issue still persist. Could you please look at it and fix it? Thank you!

    Best regards,

    Oliver

    Plugin Author Munir Kamal

    (@munirkamal)

    Hi,

    Thank you to report this. I will debug this further, but it seems like a cache issue to me.

    Can you try to clear editor cache via chrome console using this command?

    window.localStorage.clear();

    Let me know.

    Hi @munirkamal,

    Thank you for quick response.

    I’ve tried pressing CTRL+SHIFT+R multiple times in Chrome. Usually this clears the cache in the browser. But indeed, using the code in console seems to do the trick for me. Thank you for this tip!

    I can confirm everything is working fine for me now. Closing the issue so.

    Thanks for help!

    Oliver

    BTW, after quick play with the plugin, it looks really promising! Thank you!

    Plugin Author Munir Kamal

    (@munirkamal)

    Hi Oliver,

    Thank you for the update. Sounds great. 😇

    Do pass your feedback & suggestions to improve this plugin.

    Regards,
    Munir

    loireau

    (@loireau)

    I found an easy way to clear the cache, which worked for me when I had the same error. See Clear Chrome cache

    1. Pull up the Chrome developer console by pressing F12 and then (with the console open):
    2. Right click (or hold left click) on the reload button at the top of the browser and select “Empty Cache and Hard Reload.”

    This will go beyond “Hard Reload” to empty the cache entirely, ensuring that anything downloaded via javascript or etc. will also avoid using the cache. You don’t have to mess with settings or anything, it’s a quick 1-shot solution.

    • This reply was modified 3 weeks ago by loireau.

    Cool tip, @loireau, thanks for sharing! I will give it a try next time I get the error.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.