Support » Plugin: Disable Gutenberg » “Block Editor” appears as an option on the Posts screen and Pages screen

  • Resolved Patty J. Ayers

    (@pattyayers)


    The plugin seems to be working great overall. However, on the Posts (list) Screen and the Pages (list) Screen, when I mouse over a post to choose “Edit”, the option is “Block Editor.” I really need to have that not be there! I’d prefer to use your plugin, but I had to install Classic Editor on those sites to make that Block Editor link go away.

    Is this a known bug? I’d be glad to provide more info if that helps.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Jeff Starr

    (@specialk)

    The new shortcut links can be disabled, see this sticky post:

    https://wordpress.org/support/topic/please-read/

    Thank you, I just read the post.

    I looked at the basic options in Disable Gutenberg and I thought that I had opted to remove all references to the Block Editor, so didn’t know of any reason to go looking for more options.

    Also: I didn’t see links for “Edit” *and* “Block Editor” – just the latter. It’s hard to describe just how disastrous it would be if one of my clients clicked on that link. I’m kind of surprised the plugin doesn’t remove it by default.

    Plugin Author Jeff Starr

    (@specialk)

    I will update the plugin again to try to make it clearer with the links (and make them disabled by default, as you suggest). Right now I admit it is confusing. But it should be resolved either way once you disable the shortcut links, correct?

    • This reply was modified 9 months, 1 week ago by  Jeff Starr.
    Plugin Author Jeff Starr

    (@specialk)

    So just to be sure, before I update the plugin with new changes, does disabling the new “edit” link option help to resolve your issue? Thank you,

    I had to do something right away, I’m sorry — I don’t have Disable Gutenberg installed anymore. I know I’m not being very helpful; I just honestly didn’t have time to do anything but find an immediate solution before I have a client uprising and multiple hours of unpaid work. 🙁

    I had to do something right away, I’m sorry — I don’t have Disable Gutenberg installed anymore. I know I’m not being very helpful; I just honestly didn’t have time to do anything but find an immediate solution before I have a client uprising and multiple hours of unpaid work. 🙁 Anyway, I’ll change the review, since you’ve fixed the issue.

    Plugin Author Jeff Starr

    (@specialk)

    Yes, thank you. I am working on the update now. All traces of Gutenberg (including the Edit links) will be disabled by default, as of version 1.5.2. Totally understand if you had to find another solution, client uprisings are no fun. Hopefully you will consider Disable Gutenberg for any future projects. And thanks Patty for updating your rating, it really is appreciated.

    I installed Disable Gutenberg a couple of hours ago and some of my pages still go to the new Block style editor AND these pages won’t update (Fail to update) AND I can’t preview any of my new pages (404 error) 🙁 I don’t know what’s wrong. Been searching for solutions and am now about to pull my hair out.

    Plugin Author Jeff Starr

    (@specialk)

    @tgendron Are you able to find any related errors in your site’s error/debug logs (other than the 404 error)?

    HI Jeff! I went to Cpanel and searched for a debug log or errors and couldn’t find any logs of this sort. I’m fairly beginnerish when it comes to wordpress – although I have two websites I’ve been working on for a few years and it’s been relatively smooth.

    I just did a bit more experimenting and found that I could create a new Page and preview it with no problem (in classic editor) but as soon as I published it, I got 404 error when I hit preview…and it also gets the 404 error when I put the clean url into the browser.

    I’ve updated the .htaccess a million times, hit save on the permalinks the same amount of time, made sure the site addresses were the same, removed an url under the Writing section….I don’t have a clue what’s happening unfortunately 🙁

    The only page that is available for preview is my home page -but I can’t edit it, it ‘fails to update’ and it’s in the new wordpress Block style. http://ninthhousedesigns.com/

    Once you did that update today, I can’t get the regular editor to work only the block editor. Can you please fix this plugin so we can not edit in Guttenberg? I want the old editor back, please!

    Cosmica – are you able to preview your pages? Do you get the ‘fail to update’ message when the block editor is in play?

    Plugin Author Jeff Starr

    (@specialk)

    @tgendron, @cosmica: I’m glad to help, but from my tests everything is working properly. In order to investigate, I will need to either look at a live example or get the required steps to replicate the issue. If either of you would like to continue troubleshooting on your site, please reach me directly via my contact form.

    Thank you!

    • This reply was modified 9 months, 1 week ago by  Jeff Starr.

    I’d love your help, thank you!!

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘“Block Editor” appears as an option on the Posts screen and Pages screen’ is closed to new replies.