WordPress.org

Support

Support » Themes and Templates » Blix and Widgets

Blix and Widgets

  • I recently installed the widget plugin that allows you to drag and drop widgets into your sidebar. It all works perfectly inside the WP admin, but on the site nothing displays on the sidebar after I’ve dragged a widget to the “sidebar box.” Adding the following code to my sidebar just produces an error:

    <?php if ( function_exists('dynamic_sidebar') && dynamic_sidebar() ) : else : ?>

    <?php endif; ?>

    Is there any way to display certain widgets along with the sidebar info I currently have in sidebar.php?

    Thank you for your help. The site I’m talking about is: http://www.bakingandbooks.com

Viewing 6 replies - 1 through 6 (of 6 total)
  • Also, just a note: I tried using the “widgitized” version of Blix and got the same errors.

    Which “widgitized” version? There’s a couple of them.

    What error are you getting? Can’t help us help you if you don’t tell us what’s going on.

    I uninstalled the widgitized theme, so that my site would work. I used this one.

    So right now I’m just trying to get the widgets I’ve dragged and dropped in the admin panel to show up on my sidebar. But when I add the code referenced above to sidebar.php one of two things happens:

    1 – Nothing. If I add both pieces of code near the top of sidebar.php, right before
    <?php if (is_home()) { ?>

    2 – This error, if I put endif at the bottom of sidebar.php as instructed here.
    Parse error: syntax error, unexpected T_ENDIF in

    Thank you for your help and sorry my site is loading so slowly. The images for AMM are going really, really slow and I can’t figure out how to fix it. 🙁

    You also have to copy the functions.php file from the theme folders included in the widgets distro (classic and default – whichever most closely matches the theme you’re using, just use one of the files) into your theme folder and upload.

    has anyone gotten a wigetized version of bix to work? i tried the above linked theme and the widgets indeed do not show up.

    I used this one. I don’t recall having any issue with it.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Blix and Widgets’ is closed to new replies.