Support » How-To and Troubleshooting » Blank white screen when inserting image,

Blank white screen when inserting image,

  • Yup, its the same old problem for me.
    As described here.

    I can upload the image fine, it shoes up in the uploads folder (checked using FTP), it shows up in the Media Gallery, but as soon as I click insert the window goes white (whith the grey bar and close box along the top) and FF says Done in the bottom left corner.

    I am hosted on Media Temple and I first noticed this problem today (19th May 2008). I have tried adding the following code to my root, wp-admin and wordpress directory’s .htaccess file and it had no effect.

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off

    I have no idea what to do. I re-uploaded all my files as described in the sticky, I re-installed flash, cleared cache and it all made no difference. I don’t see this as an upload problem as the file is getting uploaded fine, it’s just not getting embedded into the post.

Viewing 15 replies - 1 through 15 (of 19 total)
  • OK, so it works in IE7. Although the popup window loads half off the bottom of the page. I re-installed FF and it still doesn’t work. Very strange. Any ideas?

    Is anyone else having this issue? It seems like at least a few people are over here. I’m stuck using IE7 half off the bottom of the page at the moment.

    Do you have more than I tab open in FireFox when you attempt to insert an image? If so, try inserting an image with only your administration window open and no tabs… this worked for me.

    Thanks for the help rlovison.

    Unfortantly it doesn work for me using the one tab open workaround. I’m going to try FF3BETA later tonight, maybe that will help. It’s real annoying that it doesn’t work.

    I still haven’t figured out how to get it to display right with IE7 yet either. It’s still half off the bottom of the page.

    Thanks anyway.

    One last thing… have you tried the no-flash-uploader plugin? I’m using that as well.

    No I haven’t tried that plugin. I’ll give it a go. Do you use any other upload plugins? I use Flexible Uploader (I get the same problem if thats disabled), but I wonder if I can use both Flexible and the No Flash plugin together (I doubt it).

    The no-flash plugin is the only upload plugin I’m using.

    Well, it seems to work if I have just one tab, and one browser window open. It’s pretty annoying, but not as bad as using IE7! (And I’m not using the no flash plugin, just flexible upload).

    What a strange problem. Does anyone else seem to get this, and what could it be?

    I just had this bizarre problem happen to me a few minutes ago.
    I had the white screen after uploading the picture and it wouldn’t insert the pic into the post.

    I tried it in Safari though and it worked so I just quit Firefox and reopened it and voila – it works again. I know its completely weird but I was messing around with the lightbox thing but its probably not that that….anywho try completely quitting the application of restarting if necessary.

    I still get this problem, sometimes with only one tab open. It’s so strange. I just tried it with FF BETA3 RC2 and it’s the same problem, so I am stumped as to what causes this problem.

    I had the same problem, but from 5 different computers, in two very different locations, and on BOTH FF and IE.

    I seem to have beat this problem:

    I upgraded to the latest version of JAVA.
    *Even though you get no advice to reboot, REBOOT afterwards.*

    I then open up FireFox and like one other person previously suggested, had only one tab open.

    At that point, I was able to add images.

    Try changing the permissions on wp-content folder to 777. It worked for me.

    I have the same problem. I reinstalled everything. CHMOD is 777 on wp-content. .htaccess files (including in wp-admin) are set to modify mod_security. I deactivated all plugins at one point, and that made no difference, either.

    10 other WP installs on the same server (same install, same theme, same settings, same .htaccess files for mod_security, and even the same graphic) all work fine.

    This one — and only this one — uploads the images, I can see them in my Media Library, I click to insert an image, and then… a blank white screen that hangs.

    The no-flash plugin doesn’t seem to do anything at all.

    I tried inserting images with just one tab open in FF, and bingo, it works.

    This absolutely baffles me, and I’m adding my two cents in case anyone spots a pattern to this, or something that hasn’t been considered yet.

    Here what has work for me
    Add the Line to your htaccess file.

    AddHandler application/x-httpd-php5 .php.

    If forces you to use php5

    NOt sure why it worked but it did for me.
    Please let me know if this helps for anyone else.

    I’ve had this problem since 2.5.1 and hoped upgrading to 2.6 would solve it.

    It didn’t.

    I followed the upgrade directions to the letter, so I was not overwriting any files. Allt he fiels are new. Flash is updated.

    The probelem happens on both FF and IE7 on any computer I use, so it’s not my browser. Furhter, on another 2.6 blog I contribute to it works fine, so it’s not even my own comptuer with the problem.

    The error console box says the error is character 1 of line 4 of media-upload.php and the error is PERMISSION DENIED.

    However, I have not been able to find any post that talks about permissions. It’s undoubtedly 1&1 and their crappy Linux hosting server (business package) but please someone tell me what permission needs to be set where.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Blank white screen when inserting image,’ is closed to new replies.