WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] blank wp-comments-post.php page when commenting

[Resolved] blank wp-comments-post.php page when commenting

  • I’m working on a custom theme, but there seems to be an issue with the comments. I haven’t changed anything outside of the theme directory, so perhaps someone could give me a hand with what’s wrong here…I’m a bit new to CSS and PHP.

    When someone tries to post a comment to my blog candycornstudios.com/ArtistAlley the wp-comments-post.php comes up blank after the reply button is hit. I don’t know what’s wrong…help?

Viewing 11 replies - 1 through 11 (of 11 total)
  • I’m having the same problem, using the Mallow theme. Any ideas as to what’s going on?

    Nope, I still haven’t figured it out. When I searched the backlogs I found one other person with the problem, but they never got answered…figured it out themselves. Apparently there was something wrong with a file in the parent directory of the blog install. I don’t think there are any files in my parent directory that could affect my blog…and they didn’t say what it was, so I can’t check. Sorry I can’t be of more help…I’m just checking this thread daily. ^^

    Songjewel: It’s the “Submit” button ( sorry just had to mark that ;-), but it works fine for me. I don’t get a blank page but the same single post page, including my comments.

    And by the way. Your blog looks really great!

    petit…I think you’re posting in the wrong one. You’re posting in the CandyCorn studios blog and not the ArtistAlley one…you probably didn’t get the whole URL. And yes, it is the submit button. >< Sorry about that.

    You’re right of course – sorry about that!
    It’s the night of sorries – er..

    So I tried the right address, and of course, once I made my comment I got your empty page.
    What it should do is to give a redirect to the same page, but it does not!
    I have seen this behavior on quite a few blogs, and it’s very unsatisfactory, as the commenter will never know if the comment was saved.
    I’ll look into it and see what’s going on.

    I compared the comment submit forms on my blog ( which works ) and your blog.

    Both submits as the should to wp-comments-post.php
    In my form I have two hidden input variables:
    <input type="hidden"
    name="comment_post_ID"
    value="125" />
    <input type="hidden"
    name="redirect_to"
    value="/blog/2006/01/26/some-post-slug/" />

    These variables are missing in your comments form, and certainly the second is the one responsible for the correct redirect.

    Edit: This is different in different themes. The wp-comments-post.php uses this explicit redirect value or the get_permalink( $comment_post_ID ) function to get the permalink of the commented post.

    Thanks you! I will try the code as soon as I get back from class. I appreciate the help!

    Well, it wasn’t what you posted petit, althoguh thanks for the time. You gave me the idea to replace bits of code that differred from the default comment form (I should have done that initially. ><), which worked. I just Took the default of comments.php and re-worked it instead of using the one from the theme.

    Sabrina, you might try looking at that…see if the default comments.php file works in place of the one from your theme. It might be an error with the comment form.

    You’re a jewel! 😉

    hi!

    when i want to submit a comment, i get “site not found” error. i would be glad, if there was at least a blank page.

    any idea where the error could be? would be thankful for every help.

    pati

    ps: when i look in the admin-area comments are there.

    hi again.

    problem was the permalink structure, which still don’t work. put the permalink structure back to default and comments work .

    best wishes,
    pati

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] blank wp-comments-post.php page when commenting’ is closed to new replies.