Support » Alpha/Beta/RC » Blank WP-Admin – Accessing upgrade.php

  • Resolved Jonathan


    We’re upgrading a dev site from 3.4 to 3.5 RC3 and we’re seeing a blank wp-admin with the following in the browser bar. I’ve tried flushing our cache, flushing APC/MemCache, and restarting Litespeed to flush the cache so that we can get things to go through, though each time we’re presented with a blank page.


    The primary dev site works fine (front-end), though the back-end is having issues it seems. I tried accessing ./wp-login.php and logging in, which worked, but was redirected back to /wp-admin/ which remains blank.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Just did an upgrade from 3.4 to 3.5 RC3 with no problem.

    Do you have debug logging enabled? That might help track it down.

    The error we’re seeing is as follows:

    Fatal error: Cannot redeclare win_is_writable() (previously declared in /home/path/to/wp-includes/functions.php:1433) in /home/path/to/wp-admin/includes/misc.php on line 554

    The same error is filling our logs on every page refresh – it’s also the only error that’s popping up :-).

    It looks like that function got moved during the 3.5 cycle.

    How did you go about doing the upgrade process? I copied the 3.5 RC3 files over the top of my 3.4 and it worked fine. Trying to figure out how you went about it to see how that error could pop.

    I did the same 🙂 – All files copied direct from the ZIP, overwriting all existing.

    It sounds like the wp-admin/includes/misc.php file did not get overwritten. That’s the old location of the function. Double check that it got updated.

    And the issue was….permissions related :-). It was indeed that the file didn’t upload as the account we were using to test didn’t have permission to overwrite the file (or 200-300 others). After a quick chown all is well with the update.

    The only issue that persists now is that register & enqueue_style seem to have stopped working.

    All is working as of now – perhaps I should sleep just a tad bit more in-between upgrades :-).

    Thanks again mindctrl – appreciate you jumping in and pointing that out as that was honestly the last thing I would have checked.

    Glad you got it working!

    I still have this problem 🙁

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Blank WP-Admin – Accessing upgrade.php’ is closed to new replies.