Support » Plugin: Wordfence Security - Firewall & Malware Scan » Blank window for Firewall Optimization instructions on new Siteground site

  • Resolved Darlene Cain

    (@darlenecain)


    Hello. When I click the link to optimize the Wordfence Firewall, the resulting window, which normally contains instructions to guide you through the optimization process, is blank.

    I think this may be related to Siteground’s recent change from cPanel to a custom hosting dashboard. I have used Wordfence on a couple of other Siteground sites, when Siteground still used cPanel, and this issue did not occur.

    In spite of the blank window, I attempted to follow the instructions (at https://www.wordfence.com/help/firewall/optimizing-the-firewall/ ) to manually optimize the firewall on Siteground sites. I manually created a wordfence-waf.php file by copying one from a different Siteground site and changing the pathnames in it to the ones for the current site. I then set the auto_prepend_file variable. After doing this, the site loaded properly, the Wordfence message telling me to optimize the firewall disappeared, and the Protection Level was reported as Extended Protection, so I thought I had optimized the Firewall correctly.

    However, after I logged out of the WordPress dashboard, I was not able to log back in. I both the wp-admin and wp-login urls gave me a blank screen. So, I undid the firewall optimization by renaming the wordfence-waf.php file, unsetting the auto_prepend_file variable, and commenting out the line referencing auto_prepend_file in php.ini . I was then able to log into the site again, and the site loads and works fine, but the firewall is not optimized, of course.

    I apologize for the lengthy post, but I felt it was necessary to fully explain my problem. Obviously, I was not successful in correctly optimizing the firewall manually, and that caused my login issues. Also, I’m wondering if the measures I took to undo the manual optimization were correct or thorough. Is there something I need to change on Siteground before attempting to optimize the firewall again? What is causing the blank instruction window?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support WFGerroald

    (@wfgerald)

    Hey @darlenecain,

    Thanks for the detailed information.

    Do you see any errors in your browser console when on the blank pages?

    https://www.wordfence.com/help/advanced/troubleshooting/#how-to-inspect-the-browser-console

    Can you enable WP_DEBUG to see if it reveals any errors on the blank pages?

    https://codex.wordpress.org/WP_DEBUG

    Last but not least, if you check your PHP error logs are you seeing any errors when the blank pages are active? If you’re not sure where these are your host can provide them to you.

    Please let me know what you find.

    Thanks,

    Gerroald

    A screenshot of the browser console, which does show errors, is at https://www.dropbox.com/s/wer6ihrrbf4bg6l/Browser%20Console%20screenshot%20-%20Console.png?dl=0

    I enabled WP_DEBUG, but it did not reveal any errors.

    I downloaded the php error log. I don’t know if any of the errors in it are relevant to my problem. It is at https://www.dropbox.com/s/ys2gqw4lv6lsi6h/php_errorlog.txt?dl=0

    Thanks for your help!
    Darlene

    Plugin Support WFGerroald

    (@wfgerald)

    Hey @darlenecain,

    Thanks for the information.

    It sounds like there might be a conflict either with the theme or one of the plugins you’re using, could you try temporarily switching to a default theme if you’re not already using one and disabling all other plugins to see if it helps? If it does, then reactivating them one by one to find the offending plugin(s).

    Please let me know how it goes.

    Thanks,

    Gerroald

    Hi. I switched to the 2019 theme and deactivated all the plugins, but when I click to optimize the firewall, I still get a blank window.

    Thanks,
    Darlene

    Plugin Support WFGerroald

    (@wfgerald)

    Hey @darlenecain,

    Can you send me a Diagnostics report so I can get a better overview of your environment? Please navigate to Wordfence > Tools > Diagnostics. Here you can select SEND REPORT BY EMAIL. Please include your WordPress.org username and update this thread after you’ve sent it.

    Thanks,

    Gerroald

    Hi Gerroald, I emailed the diagnostics report as you requested. Thanks again for your help. –Darlene

    Darlene,
    I’m having the same issue! Also on the new Siteground hosting. I can add a really weird error in my console. Also note that as soon as I click the “Click Here To Configure” button and the modal window opens, this error starts repeating in my console over and over and over. It will repeat indefinitely until I leave the page. And note that if I don’t click “Click Here To Configure” The error never happens. But as soon as I click it the error starts and repeats, literally several times per second and will continue indefinitely ( let it run into the 10s of thousands) until I leave the page. Here’s what the notice in the inspector looks like (expanded):

    Uncaught TypeError: Cannot read property ‘strokeDashoffset’ of undefined
    at Object.set (jquery.js:4)
    at init.run (jquery.js:4)
    at i (jquery.js:4)
    at n.fx.tick (jquery.js:4)
    setInterval (async)
    n.fx.start @ jquery.js:4
    n.fx.timer @ jquery.js:4
    pb @ jquery.js:4
    g @ jquery.js:4
    dequeue @ jquery.js:3
    (anonymous) @ jquery.js:3
    each @ jquery.js:2
    each @ jquery.js:2
    queue @ jquery.js:3
    animate @ jquery.js:4
    (anonymous) @ admin.1566486436.js?ver=7.4.0:3788
    each @ jquery.js:2
    each @ jquery.js:2
    jQuery.fn.wfCircularProgress @ admin.1566486436.js?ver=7.4.0:3723
    (anonymous) @ admin.php?page=Wordf…age=waf_options:645
    (anonymous) @ admin.php?page=Wordf…age=waf_options:652

    It would be great to get to the bottom of this. I love Siteground hosting AND Wordfence. I would hate to not be able to use Wordfence.

    Plugin Support wfscott

    (@wfscott)

    @darlenecain

    Can you reach out to SiteGround and have them consider disabling HTTPs Enforce from site tools to see if that remedies the issue. Let them see the console errors as well if possible. They should be able to help with an alternate setup for HTTPs on their side then. This is something we saw recently with another case and HTTPs Enforce was a fix.

    Scott

    Hi Scott,

    I logged into Siteground and disabled the HTTPS Enforce in Site Tools, but I still get a blank window for the Firewall Optimization instructions. Thanks for your help.

    –Darlene

    Plugin Support wfscott

    (@wfscott)

    Thanks for trying Darlene. Can you clear all your cache and then try again, or try from another browser to double check?

    Hi Scott,

    Success! I tried both of your suggestions. Clearing the cache and trying again from the same browser I’ve been using (Chrome) did not work, but clearing the cache and trying from a different browser (Firefox) did: the Firewall Optimization instructions appeared in the window as they should, I followed the instructions, and the firewall is now optimized!

    Thanks a ton!

    –Darlene

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.