Support » Fixing WordPress » Blank White Page After Posting New Blog Entry

  • Resolved WordWeaver777



    For quite some time now, after posting a new entry on my blog, I am taken to a blank white page with the following URL:

    The new message is posted just fine, and I do see it if I go to my blog’s home page. It is just the fact that I am taken to the blank white page after posting the new message.

    I don’t know if I accidentally screwed up some of the code somewhere in one of the .php files or what, but this began occurring quite a few months ago.

    BTW, I use a proprietary theme, which is a modification of the twentyten theme. However, I have been using my proprietary theme for over two years, so I am assuming that the problem lies elsewhere.

    BTW, I run my own server and have direct access to the physical blog files. I have also verified that all permissions are set properly.

    Any assistance would be appreciated.

    Thank you.

Viewing 9 replies - 1 through 9 (of 9 total)
  • IMHO, and experiences, this is due to a local and/or server caching issue.

    Clear both and try again.

    Does anyone else have any ideas what may be causing this problem?

    Thank you?

    Moderator Andrew Nevins


    Front-end developer

    Did you check your site’s error logs for more info?

    Have you tried deactivating your plugins and switching to the default theme to see if any plugins or your theme are the cause?

    Andrew, I just did another test post on my blog with the Apache error log window open, and absolutely nothing is appearing in the error log.

    The only thing I am seeing in relation to my blog are quite a few attempts to access the “wp-login.php” doc and the “admin.php” doc using incorrect URL’s. These errors are NOT being generated by me, however, but rather by external IP addresses, probably meaning would-be hackers. Concerning them, the log says “not found or unable to stat”.

    WPyogi, I just switched to the default theme — Twenty Thirteen? — and did another test post. The results were the same; that is, a blank white page after I hit the “Publish” button.

    To reiterate what I said above, despite the blank white page, the new entry is posted on my blog, and I can see it if I go to my blog’s home page.

    I will try deactivating all plugins next, and will post another test message to see what happens.

    Oh great . . . I just deactivated every single plugin, and tried another test post. Guess what? This time it published the new entry, and took me to the “Edit Post” page.

    It has been so long since this has worked right that I can’t even remember if that is what it is supposed to do after hitting the “Publish” button. Is it supposed to take me to the “Edit Post” page, or to the blog’s home page?

    At least I am not getting the blank white page now. However, this means that I have to reactivate ** 31 ** plugins one by one in order to determine which one is the culprit, and post as many as ** 31 ** test messages to find out, all of which will be published to my Facebook timeline. Oh joy, oh bliss! Not! 🙁

    Bravo! Issue resolved!

    As it turns out, it was the Publisher plugin that has been causing the blank white page issue. I don’t know if the problem is related to the Zend gdata api that it uses — maybe my version is outdated — or something else. Whatever the case may be, I have deactivated the plugin, and will be totally removing it from my blog, being as I don’t use anymore anyway.

    Thanks fellows for your assistance.

    I just wanted to add a final note here so that the author of the Publisher plugin doesn’t look bad.

    As it turns out, the problem was NOT with the plugin itself.

    What actually happened is that sometime during the course of the last year and four months, as I continued to update the web server software that I use, the Zend library which is required by the plugin, somehow got zapped out of the PHP folder.

    So, just a few minutes ago, I reinstalled the plugin, and reinstalled the Zend library in the proper place, and the plugin is now working properly again; meaning that it is automatically syndicating my blog posts to again.

    I have already written to the plugin developer and informed him of this latest development.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Blank White Page After Posting New Blog Entry’ is closed to new replies.