Support » Plugin: WP HTML Mail - Email Designer » Blank space inside content section

  • Sant_Ph



    Congratulations on making a wonderful plugin which has been a great help for a newbie like me in the world of wordpress.

    I am using the default email template plugin with my contact form 7 and I am getting this blank space first up inside the content section before the first line of my content and end of header block. How to remove that blank space inside the content section. Thanks in advance.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hi,
    I have same issue!
    I removed header and footer text in woocommerce mail setting.
    Now there is blank space as <p><br><br></p> in header of mail and <p></p> in footer.
    also i removed extra codes in php mail template.
    Still problem is exist and seems that is blank space of header and footer that i removed their text in woocommerce mail setting.
    any idea to fix?
    thanks for plugin.

    Hey @santushtiphotography,
    I just tried with Contact Form 7 on my test systems and couldn’t find any problem. Can you send me a message with CF7 to cf7test[AT]etzelstorfer[DOT]com?
    best regards, Hannes



    I got the same problem with a lot of line breaks in the content section.

    The solution: Uncheck the “Use HTML content type” option in the Mail tab of CF7 contact form settings.

    I have this same problem with gravityforms and woocommerce everything else seems to work ok…

    I get about 5 extra <br> tags only with these plugins, I have disable auto format in Gravity forms but still the same problem, I will email my example to cf7test[AT]etzelstorfer[DOT]com any help would be grateful

    @menzer WooCommerce only works with the add-on

    hi Hannes, thanks for getting back to me… the email system works fantiastic with woocommerce, I have not problems with woocommerce of gravityforms the only problem is that something is inserting 5 <br> tags so there is a massive space in the content area… I sent you an example email ‘And the Winners are’ is the title did you receive it and can you see the space I am talking about…

    @menzer, if you are using Contact Form 7, try disabling the option Use HTML content type, it worked for me. Disabling it, will remove the blank space in the email body.




    Same issue here with Gravity Forms regardless of whether you click their ‘Disable Auto-formatting’ checkbox or not. Any ideas?

    Plugin Author Hannes Etzelstorfer


    Hey Joe,
    Gravity Forms is not fully supported yet because it wraps its emails in its own template.
    I’ve set up a poll for plugin support a few days ago where you can vote up Gravity Forms and suggest other plugins: visit poll



    Hi Hannes, I already voted in the poll two days ago. I’m ready for action! We will add some custom CSS to our Gravity Forms emails until you release an update.



    I tried disabling your plugin and Gravity Forms is sending the plain text email with no formatting or added template wrapper. Only when I activate WP HTML Mail does a series of <br> elements get added to the top and the bottom. Here is an example email output:

    <p>Test line 1</p>
    <p>Test line 2</p>

    Can you help? It looks pretty bad.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.