Support » Plugin: Jetpack by WordPress.com » Blank settings pages after 4.8.1 update

Viewing 7 replies - 1 through 7 (of 7 total)
  • The same thing. 4.8.1 corrects blank screen issues only half way for me.
    https://wordpress.org/support/topic/problems-after-update-jetpack/page/2/#post-8999101

    Same. It’s not a WSOD and Jetpack is actually connected and working. It’s a problem going to either the settings page or the Jetpack dashboard which appear completely blank.

    Here’s a related nginx error log entry (sanitized):

    2017/04/06 10:55:39 [error] 4142#4142: *5960955 FastCGI sent in stderr: "PHP message: PHP Warning: Cannot modify header information - headers already sent by (output started at /var/www/example.com/htdocs/wp-includes/formatting.php:5078) in /var/www/example.com/htdocs/wp-includes/rest-api.php on line 513" while reading upstream, client: <IP ADDRES>, server: www.example.com, request: "GET /wp-admin/admin.php?page=jetpack HTTP/1.1", upstream: "fastcgi://127.0.0.1:9070", host: "www.example.com", referrer: "https://www.example.com/wp-admin/plugins.php"

    I have the same issue – Jetpack dashboard and settings pages are both blank. The stats page loads, and I can assign a Jetpack gallery style in a post or page editor.

    Plugin Contributor Ryan Cowles

    (@ryancowles)

    @sephage: Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can contact us using the form here:
    http://jetpack.com/contact-support/

    Please make sure to include a link to this thread in your message. Thanks!

    @tohrumurakami @pjv @vesica: Could you please start your own thread, as per the Forum Welcome?

    https://wordpress.org/support/plugin/jetpack#new-post

    Thanks all!

    @ryancowles: I think I solved the issue. It seems like erratic update process caused blank dashboard and settings pages. Let me tell my story —

    1. Jetpack was auto-updated to 4.8 from 4.7.1, and the total blank-screen issue happened.
    2. Using FTP, deleted plugins/jetpack/ and uploaded 4.7.1 from a backup. The issue restored. Disabled auto-update to wait for a fix.
    3. 4.8.1 was released. Tried to update Jetpack in “Installed Plugins” page, but had write-errors, then remembered to have missed to change access privileges of uploaded 4.7.1 files. Using FTP deleted plugins/jetpack/
    4. Installed 4.8.1 from “Plugin install” page. Had blank dashboard and settings pages.
    5. Replaced 4.8.1 with 4.7.1 and fixed access privilege this time. Jetpack 4.7.1 worked OK.
    6. Updated Jetpack in “Installed Plugins” page, then all the issues restored.

    Uninstalling Jetpack 4.7.1 in “Installed Plugins” page, fresh-installing 4.8.1 from “Plugin install” page and re-linking it to the cloud also solved the issue.

    Scamaz

    (@scamazdid911)

    @tohrumurakami

    Thanks! the uninstall and reinstall solved my black settings issue as well!

    @ryancowles Thanks, it’s http://www.1winedude.com

    I’m not going to be able to try a full uninstall/reinstall for a week or two.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Blank settings pages after 4.8.1 update’ is closed to new replies.