Support » Plugin: Cloudflare » blank settings page. 3.0.3

Viewing 15 replies - 16 through 30 (of 37 total)
  • I have the same problem…

    PHP 5.6.30
    Wordpress 4.6.1
    Cloudflare WordPress plugin 3.0.3
    PHP 7.0.6
    Server IIS 8.5

    David

    (@dacosta1979)

    Same problem (grey screen) with the last plugin:

    Operating System : Linux
    Server : Apache
    PHP Version : 5.3.24
    MYSQL Version : 5.0.96-log

    Good, so it is not platform (Windows/IIS) dependent.

    Without really looking into it too far. I think it’s an issue with the ajax loading of the settings page.

    Same issue here, blank settings page. The website is loading without issue though.

    Hi Guys,

    Can you please give me some more information about your system?

    Does the “active zone” in the top left hand corner show your WordPress domain?
    Are there any errors in the browser console?
    Are there any errors in the PHP error log?

    Thanks,
    John

    Hey John,

    I posted my error logs above for you and in the Cloudflare ticket. I got a 500 error when updating which takes down the entire dashboard. Currently reverted to 1.x.

    Thanks!

    Hi John

    I don´t get any errors on the page or in the log, and everything else is working fine.

    If you provide me with html output, maybe that will help you? but then i need a email where I can send it to…

    Hi,

    Could post the list of plugins you are using?

    Thanks

    • This reply was modified 4 years, 5 months ago by thellimist.

    It´s not many

    Cloudflare
    cookie consent
    wp mail bank

    So i dont thing thats is the problem, I have 5 other sites with the same problem and different plugins….

    Hi,

    I am sorry for the inconvenience. I’d like to test a fix.

    Please test this if you’ve Cloudflare Plugin version 3.0.3 installed.

    – SSH to your server.
    – open “YOUR_WORDPRESS_PATH/wp-content/plugins/cloudflare/src/WordPress/WordPressAPI.php” in a text editor
    – Delete line 83 to 88 and replace it with

    return array($this->getOriginalDomain());

    After the change it should look like this:

    public function getDomainList($userId = null)
    {
        return array($this->getOriginalDomain());
    }

    – Save the file.
    – Open wp-admin dashboard
    – Deactivate Cloudflare plugin
    – Reactivate Cloudflare plugin
    – Open Cloudflare Plugin Settings page
    – Enter your email address and API Key
    – Check if everything is working

    If you’re still having errors:
    – Post the server PHP error logs
    – Open developer tools in your browser. Paste the console logs.

    Thank you

    @furkan811 I can confirm your fix works; had the same issue prior to changing that method on v.3.0.3 and after applying your fix, it now works.

    @furkan811 I just tested your fix on my development server and also my production server. Made the changes as per your instructions and also even went so far as to restart php to make sure it wasn’t caching any PHP files. I still get no change. The domain name is highlighted correctly in the drop down “Active Zone” but there is nothing else besides 3 blue buttons.
    Home, More Settings, Analytics.
    Then under that “Please select a domain that is provisioned with CloudFlare.”
    Then “Version: 3.0.3”

    When you switch pages nothing changes except the URL bar address.

    I get 0 PHP errors on server logs, global and per site logs checked on server.

    No errors in the console logs, which read like this

    
    JQMIGRATE: Migrate is installed, version 1.4.1
    Download the React DevTools for a better development experience: https://fb.me/react-devtools
     action @ 17:23:43.685 CONFIG_FETCH 
     action @ 17:23:43.818 CONFIG_FETCH_SUCCESS 
     action @ 17:23:43.820 CONFIG_UPDATE_BY_KEY 
     action @ 17:23:43.822 INTL_FETCH_TRANSLATIONS 
     action @ 17:23:43.825 USER_LOGIN_SUCCESS 
     action @ 17:23:43.828 ZONES_FETCH 
     action @ 17:23:43.831 @@router/TRANSITION 
     action @ 17:23:43.832 @@router/UPDATE_LOCATION 
     action @ 17:23:43.872 INTL_FETCH_TRANSLATIONS_SUCCESS 
     action @ 17:23:43.874 APPLICATION_INIT 
     action @ 17:23:45.192 ZONES_FETCH_SUCCESS 
     action @ 17:23:45.222 ZONE_SET_ACTIVE_ZONE 
     action @ 17:23:48.994 @@router/TRANSITION 
     action @ 17:23:48.995 @@router/UPDATE_LOCATION 
     action @ 17:23:49.891 @@router/TRANSITION 
     action @ 17:23:49.891 @@router/UPDATE_LOCATION 
     action @ 17:23:51.570 @@router/TRANSITION 
     action @ 17:23:51.570 @@router/UPDATE_LOCATION
    

    The last few entries are me switching pages.

    The only thing of interested I was able to dig up was, drilling into the ZONE_SET_ACTIVE_ZONE

    
    Object
    type
    :
    "ZONE_SET_ACTIVE_ZONE"
    zone
    :
    Object
    name
    :
    "website-domain.com"
    plan
    :
    Object
    name
    :
    ""
    __proto__
    :
    Object
    status
    :
    "inactive"
    type
    :
    ""
    __proto__
    :
    Object
    __proto__
    :
    Object
    

    This was in the “action” state. Not sure if the fact it says under the plan “inactive” means anything of value to you. I definitely have an active plan with the DNS properly configured, have been using it for a year flawlessly.

    After I applied the fix, the settings page was still blank but I started getting an error 403 in the console when trying to load /wp-content/plugins/cloudflare/config.js.

    I removed everything from my .htaccess file and the 403 error went away, but when I put the htaccess file back to the way it was, /wp-content/plugins/cloudflare/config.js continued working without the 403 error. After the 403 error was cleared up, the plugin appeared to be working properly. I reverted the fix to /wp-content/plugins/cloudflare/src/WordPress/WordPressAPI.php and the settings page was still working properly, so I completed setup on the settings screen and no problems after.

    I didn’t touch anything on my cloudflare account, so not sure where the problem was. Maybe cloudflare caching admin files?

    I also just installed the latest version and getting a 404 error in the console for

    /plugins/cloudflare/config.js

    which renders a grey screen at cloudfare plugin setup

    fix above does not fix this.

Viewing 15 replies - 16 through 30 (of 37 total)
  • The topic ‘blank settings page. 3.0.3’ is closed to new replies.