Support » Plugin: Cloudflare » blank settings page. 3.0.3

Viewing 15 replies - 1 through 15 (of 37 total)
  • Plugin Author jwineman

    (@jwineman)

    Hi,

    Sorry to hear that. Can you give me some information about your server?

    What version of PHP are you running?
    What version of wordpress are you running?
    Are there any errors in the PHP error log?
    Is your wordpress blog a sub domain?

    Thanks,
    John

    Same here, after update it just is stuck on the page asking you to select a domain that is provisioned with CloudFlare. It auto selected my URL from the list but nothing else happens. Clicking on any of the buttons ‘Home’ ‘More Settings’ ‘Analytics’ does nothing either.

    PHP v7.0.11
    No PHP errors in the site log or global log
    WP v4.6.1
    Not on a subdomain, not multi-site
    Also no errors in browser (checked in chrome dev tools)

    • This reply was modified 1 year, 2 months ago by  rifi2k.
    Plugin Author jwineman

    (@jwineman)

    @rifi2k,

    Have you provisioned your domain name on CloudFlare.com and set the nameservers?

    Thanks,
    John

    I have provisioned my domain on cloudflare. Everything was working fine before updating to 3.xx.

    I started 2 support threads:

    https://wordpress.org/support/topic/update-crashes-site-2/
    https://wordpress.org/support/topic/cant-configure-settings-in-3-0-2/

    The second one hasn’t been resolved. And it’s the exact same problem as this one. Version 3.0.3 did not fix the problems from 3.0.2.

    Yeah, it’s been on Cloudflare Pro Plan for around a year.

    Plugin Author jwineman

    (@jwineman)

    @rifi2k,

    Do you have multiple CloudFlare accounts? Is the domain provisioned under the CloudFlare account you logged in to the plugin with?

    Thanks,
    John

    100% the correct account

    Plugin Author jwineman

    (@jwineman)

    Alright to debug further I’m going to need your domain names. If you don’t feel comfortable posting it here please open a support ticket with:

    A link to this page
    Your PHP version
    Your WordPress Version
    Your CloudFlare Plugin Version
    The affected domain name

    Thanks,
    John

    I have the same issue, sites working for over a year, the new update 3.03 breaks the site. I have to disable to the plugin to get it working.

    When I try to activate the plugin I get.

    Fatal error: Can’t inherit abstract function CF\API\APIInterface::createAPIError() (previously declared abstract in CF\API\AbstractAPIClient) in /var/www/vhosts/yourweightloss.org/wp-content/plugins/cloudflare/vendor/cloudflare/cloudflare-plugin-backend/src/API/AbstractAPIClient.php on line 10

    defunct

    (@defunctlife)

    I am experiencing 500 errors when updating to 3.0.3, ticket ID #1215708.

    I’ll post some non private information here:

    PHP 5.6.24
    Wordpress 4.6.1
    Cloudflare WordPress plugin 3.0.3
    Also Using Cloudflare SSL plugin if that’s relevant.

    Error log upon updating:

    [22-Sep-2016 05:06:54 UTC] PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘\CF\Hooks\Init’ not found in /home/xxxxx/domains/xxxx.com/public_html/wp-includes/plugin.php on line 524

    [22-Sep-2016 05:06:54 UTC] PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘\CF\Hooks\AutomaticCache’ not found in /home/xxxxx/domains/xxxx.com/public_html/wp-includes/plugin.php on line 524

    Hello,

    I installed the WordPress plugin ver. 3.0.2 and activated it. When I open the settings screen in order to enter the API key I get only the blank grey screen without any logos, fields etc.

    I cleared browser cache, deactivated – reactivated the plugin, uninstalled and reinstalled – no result. I then manually installed 1.3.25 and it worked, however after applying the update to 3.0.2 the screen again became blank and grey.

    I also manually installed 3.0.1 and the screen was grey and empty.

    I tried deactivating all plugins and keeping only Cloudflare plugin activated – did not work.
    I run WordPress 4.6.1 with DIVI 3.0 theme, initially used PHP 5.3, but in the course of troubleshooting upgraded to ver 7.x

    I am on free plan at the moment, I opened a ticket #1214499 yesterday for the same issue. You can pull domain details from the ticket entry.

    What may be the cause of this? Thanks for some suggestions.

    I forgot to mention that I am running WordPress on Windows and obviously my webserver is IIS, ver. 7

    New user here.

    Ok, so let me get this straight, as part of installation/using this plugin you’d have to do something on the cloudflare site(aside from copying the API), ie. add the site’s domain, etc.. in there?

    If so why isn’t anything about this in any of the installation guides, here or in the “Using CloudFlare with WordPress” in your own site??

    API Key should contain all the information, specifically domain name

    So I shouldn’t have to do anything else unless I have the same problem as the OP?(which I also have and it seems many others do too.)

    There are a few ambiguities here that I feel should be a bit more public/easier to find.

    • This reply was modified 1 year, 2 months ago by  Minato3.
Viewing 15 replies - 1 through 15 (of 37 total)
  • The topic ‘blank settings page. 3.0.3’ is closed to new replies.