Support » Plugin: Cloudflare » Blank Settings Page

  • Resolved jbarker2018

    (@jbarker2018)



    I just installed a brand new wordress site on my locally hosted Windows Server running IIS. PHP is good, no errors. Version 5.6.

    The first task I set to do was setup the Cloudflare CDN before anything else. No content on the page even.

    There are zero plugins running except Cloudflare 3.3.1

    All I get is a blank page in settings. I’ve manually unzipped into the plugin folder and deleted and auto installed via WordPress. I’ve done multiple install attempts.

    I have another mature website running on a different local windows server that now has the issue as well. Many plugins installed on that website, but at one point it worked as its been connected to Cloudflare for 7-8 months. Now it shows a blank page. But because the brand new website has the issue I don’t think its plugin related on the old site.

    Below is output from the cloudflare config. It looks like its running, I just can’t get to the settings.

    {
    “debug”: false,
    “featureManagerIsFullZoneProvisioningEnabled”: false,
    “isDNSPageEnabled”: false,
    “isSubdomainCheckEnabled”: true,
    “useHostAPILogin”: false,
    “homePageCards”: [
    “ApplyDefaultSettingsCard”,
    “PurgeCacheCard”,
    “PluginSpecificCacheCard”
    ],
    “moreSettingsCards”: {
    “container.moresettings.speed”: [
    “AlwaysOnlineCard”,
    “ImageOptimizationCard”,
    “DevelopmentModeCard”,
    “BypassCacheByCookieCard”
    ],
    “container.moresettings.security”: [
    “SecurityLevelCard”,
    “WAFCard”,
    “AdvanceDDoSCard”,
    “AutomaticHTTPSRewritesCard”
    ]
    },
    “locale”: “en”,
    “integrationName”: “wordpress”,
    “version”: “3.3.1”
    }

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • In an effort to continue troubleshooting this. I just reinstalled from scratch on the same local windows server that had Cloudflare working. Same details as before.

    Completely fresh install of wordpress 4.9.1. New database. No plugins installed except for Cloudflare. I still get the blank settings page.

    My other site that is working with cloudflare still shows a blank settings page as well.

    Any thoughts or direction would be much appreciated.

    Thanks
    John

    Plugin Author thellimist

    (@furkan811)

    Hi,

    Thanks for trying to debug. This is most probably an issue specific to your environment. There are a few topics opened with similar issues. If you couldn’t find anything that works for you, could you:

    1) Open developer Console in your browser -> Go to Network tab -> refresh the page which is blank -> send any request which fails.
    2) Send php error logs.

    Please make sure not to send any confidential information.

    Thanks

    Thanks for responding. I completely forgot about developer mode in the browser. I am more network engineer side. But getting better in dev.

    I have tried both Chrome and Firefox and get the same error in both developer consoles:

    406 Not Acceptable
    Config_Fetch_Error

    I have verified the same error on both websites. The brand new one with zero info or plugins other than cloudflare and the older website that used to view the settings page.

    The brand new website just stops after the config_fetch_error

    I have searched the forums for cloudflare 406 error and I don’t see anything that I think is relevant. One post was a conflicting security plugin, which on the new website doesn’t apply. Another post had an improperly configured DNS which I know is wrong on the old website since its working as expected.

    I’ll do some more digging on the 406 error. Its not one I am familiar with.

    Log files are below.

    Brand new website:
    GET http://www.newwebsite.io/wp-content/plugins/cloudflare/config.js?ver=3.3.1 406 (Not Acceptable)
    (anonymous) @ VM129:1
    d.end @ compiled.js?ver=3.3.1:35
    o @ compiled.js?ver=3.3.1:35
    i @ compiled.js?ver=3.3.1:35
    (anonymous) @ compiled.js?ver=3.3.1:35
    (anonymous) @ compiled.js?ver=3.3.1:35
    dispatch @ compiled.js?ver=3.3.1:35
    (anonymous) @ compiled.js?ver=3.3.1:35
    (anonymous) @ compiled.js?ver=3.3.1:35
    value @ compiled.js?ver=3.3.1:35
    performInitialMount @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:6
    performInitialMount @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:6
    performInitialMount @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:6
    performInitialMount @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:6
    performInitialMount @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:6
    performInitialMount @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:6
    a @ compiled.js?ver=3.3.1:30
    perform @ compiled.js?ver=3.3.1:6
    u @ compiled.js?ver=3.3.1:30
    perform @ compiled.js?ver=3.3.1:6
    batchedUpdates @ compiled.js?ver=3.3.1:35
    i @ compiled.js?ver=3.3.1:6
    _renderNewRootComponent @ compiled.js?ver=3.3.1:30
    _renderSubtreeIntoContainer @ compiled.js?ver=3.3.1:30
    render @ compiled.js?ver=3.3.1:30
    (anonymous) @ compiled.js?ver=3.3.1:35
    t @ compiled.js?ver=3.3.1:1
    (anonymous) @ compiled.js?ver=3.3.1:1
    (anonymous) @ compiled.js?ver=3.3.1:1
    compiled.js?ver=3.3.1:35 action CONFIG_FETCH_ERROR @ 06:28:35.794
    compiled.js?ver=3.3.1:35 prev state {activeZone: {…}, app: {…}, config: {…}, intl: {…}, user: {…}, …}
    compiled.js?ver=3.3.1:35 action {type: “CONFIG_FETCH_ERROR”}

    The older site continues with the API key being verified as I had set it up previously.

    The older website:

    VM152:1 GET https://www.oldwebsite.com/wp-content/plugins/cloudflare/config.js?ver=3.3.1 406 (Not Acceptable)
    (anonymous) @ VM152:1
    d.end @ compiled.js?ver=3.3.1:35
    o @ compiled.js?ver=3.3.1:35
    i @ compiled.js?ver=3.3.1:35
    (anonymous) @ compiled.js?ver=3.3.1:35
    (anonymous) @ compiled.js?ver=3.3.1:35
    dispatch @ compiled.js?ver=3.3.1:35
    (anonymous) @ compiled.js?ver=3.3.1:35
    (anonymous) @ compiled.js?ver=3.3.1:35
    value @ compiled.js?ver=3.3.1:35
    performInitialMount @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:6
    performInitialMount @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:6
    performInitialMount @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:6
    performInitialMount @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:6
    performInitialMount @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:6
    performInitialMount @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:35
    mountComponent @ compiled.js?ver=3.3.1:6
    a @ compiled.js?ver=3.3.1:30
    perform @ compiled.js?ver=3.3.1:6
    u @ compiled.js?ver=3.3.1:30
    perform @ compiled.js?ver=3.3.1:6
    batchedUpdates @ compiled.js?ver=3.3.1:35
    i @ compiled.js?ver=3.3.1:6
    _renderNewRootComponent @ compiled.js?ver=3.3.1:30
    _renderSubtreeIntoContainer @ compiled.js?ver=3.3.1:30
    render @ compiled.js?ver=3.3.1:30
    (anonymous) @ compiled.js?ver=3.3.1:35
    t @ compiled.js?ver=3.3.1:1
    (anonymous) @ compiled.js?ver=3.3.1:1
    (anonymous) @ compiled.js?ver=3.3.1:1
    compiled.js?ver=3.3.1:35 action CONFIG_FETCH_ERROR @ 06:33:35.363
    compiled.js?ver=3.3.1:35 prev state {activeZone: {…}, app: {…}, config: {…}, intl: {…}, user: {…}, …}
    compiled.js?ver=3.3.1:35 action {type: “CONFIG_FETCH_ERROR”}
    compiled.js?ver=3.3.1:35 next state {activeZone: {…}, app: {…}, config: {…}, intl: {…}, user: {…}, …}activeZone: {id: “”, name: “”}app: {isInitialized: false}config: {config: {…}, isFetching: false}intl: {locale: “”, translations: {…}, isFetching: false}notifications: []pluginSettings: {entities: {…}, result: Array(0), isFetching: “”}routing: {locationBeforeTransitions: {…}}user: {isLoggedIn: false, isFetching: false}zoneAnalytics: {entities: {…}, isFetching: false}zoneDnsRecords: {entities: {…}, result: Array(0), isFetching: false, updateIsFetching: “”}zonePurgeCache: {isFetching: false}zoneRailguns: {entities: {…}, isFetching: false}zoneSettings: {entities: {…}, result: Array(0), isFetching: “”}zones: {entities: {…}, result: {…}, zoneDeleteIsFetching: false, zoneFetchIsFetching: false, zoneProvisionCnameIsFetching: false, …}__proto__: Object
    options-general.php?page=cloudflare:823 Live Support Info : Api key verified but user is not vip.

    Plugin Author thellimist

    (@furkan811)

    Thanks for the detailed response. http://www.checkupdown.com/status/E406.html

    The plugin is trying to fetch config.js file. I’m assuming you are using Apache or something similar. Is there any configuration which would not allow to fetch a javascript file?

    It’s possible that the plugin frontend might be missing accept-* headers your server is expecting.

    • This reply was modified 11 months, 1 week ago by  thellimist.

    No. this is actually IIS on a Server 2008 R2 Machine.

    The old website has a ton of .js fetches with other plugins that work correctly.

    I double checked the mime types for .js on the IIS server.

    It is there with MIME Type:

    application/x-javascript

    The link you posted on 406 was actually the one I was reading earlier. But thanks for posting.

    Plugin Author thellimist

    (@furkan811)

    config request uses the header Accept:application/javascript not application/x-javascript

    You can check from network tab in browser developer console

    do you think i should add a second entry to modify to application/javascript (if you even can) or change the existing mime type?

    That setting is whatever the default in this version of IIS was set to?

    Thanks for the help. Getting there!

    Plugin Author thellimist

    (@furkan811)

    That did the trick on the new website.

    Summary: Windows Server 2008 R2 is using an older version of MIME for .js and needs changed to : application/javascript

    This is found by opening IIS. Selecting the server name in the left hand window. Clicking on MIME types on the right hand pane. Scroll down until you see: .js

    Then modify to: application/javascript

    I restarted IIS service afterwards.

    The setting screen immediately appeared.

    The older website still has an issue, but at this point I assume its a conflict with another plugin. I can use the CF online dashboard to manage easy enough.

    Plugin Author thellimist

    (@furkan811)

    The information you wrote here will help others users. Thanks for being explicit and thinking about others.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Blank Settings Page’ is closed to new replies.