Support » Plugin: WordPress Importer » Blank screen w/o errors when importing w/ "Download and import file attachment"

  • I tried to import the WXR-file from one selfhosted server to another.
    All worked fine until pressing <i>submit</i> after assigning authors and ticked <i>Download and import file attachments</i>.
    Then two scenarios ‘occured’:

    1. If i did this on a fully clean WP-installation (deleted all media, pages, posts, categories, etc.), then the next page is completely blank (neither errors, nor something like “import successfull”, nor confirmation and “Have fun”.
    2. If i did this a second time (not deleting the above told import with the completely white page), then it says, all media (only images) “already exists”. After all images, the procedure breaks without any errors or confirmation (similar to scenario #1).

    After each scenario, i checked, what was imported:

    1. All media-files were imported correctly, as well as categories and catchwords (don’t know exactly, how its called in WordPress. Could be tags as well. In Germany, its “Schlagworte”). But no pages & comments.
    2. Nothing added.

    No errors were logged in the apache error-log-file (in both scenarios).
    I set up the ‘max_execution_time’ to 240. -> Didn’t changed anything (the script only executed about 30sec by the way). The equivalent in fcgi is higher than PHPs. My imported WXR-file has 340 KB (so very small).

    All in all, very strange.

    My Solution
    I had to untick <i>Download and import file attachments</i>, then all pages and comments were imported correctly.
    Maybe a hint (if you have the same problem and want to import the media, too): First import the media with the ticked option, then re-run the import with unticking the option.
    Still one problem is unresolved:I had to manually update all media-links. 🙁

    Maybe this will help, finding the mistake. I hope so! 🙂

    Potential related threads:

  • The topic ‘Blank screen w/o errors when importing w/ "Download and import file attachment"’ is closed to new replies.