Support » Plugin: Include » blank screen when clicking on “include” on left

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Michael Flynn

    (@mflynn)

    I just tested this, It’s not happening on my end.

    Can you let me know:
    – The version of PHP
    – The version of WordPress
    – Any related PHP errors from the error log

    AL Guevara

    (@albabes)

    I installed “up to date” plugin called “Error Log Monitor”, By Janis Elsts.
    It shows this:

    PHP Warning: file_get_contents(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /hermes/bosnacweb01/bosnacweb01bc/b1155/ipw.dbsatucs/public_html/wp-content/plugins/include/framework/mustache.php on line 1215
    Jul 30, 03:54:27
    PHP Warning: file_get_contents(http://dbsatucson.org/wp-content/plugins/include/views//admin_panel.mustache): failed to open stream: no suitable wrapper could be found in /hermes/bosnacweb01/bosnacweb01bc/b1155/ipw.dbsatucs/public_html/wp-content/plugins/include/framework/mustache.php on line 1215
    Log file: /hermes/bosnacweb01/bosnacweb01bc/b1155/ipw.dbsatucs/public_html/cgi-bin/php-errors.log (597 bytes

    AL Guevara

    (@albabes)

    I should say I actived php-errors.log via plugin mentioned, configed it, then CLICKED your “include” link on left navbar, and that produced the errors above.

    AL Guevara

    (@albabes)

    Plugin Author Michael Flynn

    (@mflynn)

    The issue is that your server config is conflicting with the templating engine this plugin uses. I’m currently working on a patch to try to change that setting via the code, but that’s assuming that your server will allow the code to override it’s setting.

    The setting is allow_url_fopen. It’s set to 0. It needs to be set to 1. Can you change the php config on your server?

    AL Guevara

    (@albabes)

    I have no idea?

    Plugin Author Michael Flynn

    (@mflynn)

    Ok, give version 4.0.14 a try. It’ll try to change your server setting, and error if it won’t work.

    If we can’t change that setting, there’s no change I can make to this plugin to get it working on your server, and you’ll have to revert to v3.4.41 (https://downloads.wordpress.org/plugin/include.3.4.41.zip)

    Let me know how it works, I’m going to set this as resolved.

    AL Guevara

    (@albabes)

    Did you somehow disable “fopen”?

    AL Guevara

    (@albabes)

    I just got an email from host saying fopen was disabled? My site was down for hours, they re-enabled, and now site is back up.

    AL Guevara

    (@albabes)

    Said my WordPress theme required fopen to be enabled.

    And now your plugin is working again.

    Plugin Author Michael Flynn

    (@mflynn)

    This plugin also requires fopen, all I did was change the php setting to allow php to access fopen. PHP has no power over your server’s programs.

    Plugin Author Michael Flynn

    (@mflynn)

    So, when you say that the plugin is working, does the admin screen display?

    AL Guevara

    (@albabes)

    Yes. When iPower host re-enabled fopen, website came back up, and your plugin worked again

    AL Guevara

    (@albabes)

    They said THEME I use required it

    AL Guevara

    (@albabes)

    Now that site is up and your plug is workn, I’ll give it all rest.

    Thanks

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘blank screen when clicking on “include” on left’ is closed to new replies.