WordPress.org

Support

Support » Installation » Blank screen ufter upgrading to 2.9

Blank screen ufter upgrading to 2.9

  • I just upgraded to wordpress 2.9. The auto way. But now my blog doesnt show, neither my admin panel.

    Dont know what to do! Im gonna try to delete plugins from my plugin folder.

Viewing 15 replies - 1 through 15 (of 20 total)
  • esmi

    @esmi

    Forum Moderator

    Try renaming the plugins folder first. And renaming your current theme’s folder.

    I downgraded to wordpress 2.8.6 again. im not planning to upgrade it to 2.9

    This is obviously just another ongoing unresolved issue that keeps coming up.

    I found this solution buried in a forum post from some time ago and it worked for me. If you dig deep enough and long enough you may find the original post.

    Plugin Name: Disable Canonical URL Redirection
    Create a file with the name “disable-canonical-redirects.phps”
    Copy the code into it:

    <?php
    /*
    Plugin Name: Disable Canonical URL Redirection
    Description: Disables the "Canonical URL Redirect" features of WordPress 2.3 and above.
    Version: 1.0
    Author: Mark Jaquith
    Author URI: http://markjaquith.com/
    */
    remove_filter('template_redirect', 'redirect_canonical');
    ?>

    Place the file in the plugins directory and activate it in the admin section of the plugins.

    I don’t think this plugin is even listed in the plugins or talked about in any help catagories.

    I needed it for both 2.8.6 and again with 2.9
    Probably would fix issues with previous versions as well but the first one I ever installed was 2.8.6.

    Regards.

    I made a typo in the name of the file in my previous post.
    It should be named: “disable-canonical-redirects.php
    (remove the “s” from .phps)

    Regards

    So… I should make the plugin and activate it before upgrading to 2.9 right?

    Cause after upgrading I wont be able to access the wp-admin

    You *should* be able to just add
    remove_filter('template_redirect', 'redirect_canonical');
    to your themes “function.php” file with out needing to downgrade to 2.8.6 in order to activate the new plugin, just to reupgrade to 2.9.

    I am getting the same problem from a fresh install of 2.9 (not an upgrade). It can’t write wp-config.php (so I paste it in thru an ssh connection), then hit “Run the install”, to be confronted by a blank screen.

    problem is when i create the file mentioned above – I can’t find anywhere to activate the plugin – still getting blank for everything (auto-upgrade)

    Any ideas where to activate using cpanel backend?

    funny thing – all I did was rename plugins folder, refresh site – it worked with NO plugins (obviously) then I changed folder back to “plugins” – all seems to be fin – not sure which plugin is the issue though!

    Chased the bug round and round for several hours. After I found the solution, I tested it out on 14 blogs having the same problem. Worked like a charm on 12 of the 14. The other two required upgrades to the plugins before the problem went away….. so start here…

    http://www.cenaynailor.com/blogging/wordpress-blogging/fix-the-wordpress-blank-page-error/

    Basically, it boils down to certain of your key files in the WordPress set having a blank line after the closing PHP tag. ( ?> )

    By opening wp-settings.php and wp-config.php and a couple of others, I was able to remove the blank line and log right in. I know, sounds crazy, but like I said, worked 12 out of 14 times.

    You can do the editing with your control panel file manager, an external FTP client or if you are smart… download WordPress to your local machine first, make the changes, then upload to your domain.

    I will be doing this to all future versions of WP, just to eliminate the possibility. I love WordPress, but do hate the upgrade issues that are pretty regular.

    A good place to start is by viewing the page source on the blank page. It will usually indicate which file is the problem.

    Did everything this thread expected me to do. Its still down. lease visit my site and advice.

    Solved. I wrote to my server providers. They solved it. But did not tell how.

    I had this also, after upgrading the server’s cache memory to 64 MB the problem was gone.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Blank screen ufter upgrading to 2.9’ is closed to new replies.
Skip to toolbar