Blank Screen on install.php with OpenBSD (6 posts)

  1. mccomc
    Posted 12 years ago #

    I'm having problems getting wordpress 1.0.2 working on my OpenBSD box. I'm running OpenBSD 3.3, Apache 1.3.27, AuthMySQL 3.1, PHP 4.2.3, and MySQL Ver 11.18 Distrib 3.23.55. (Apache is not running chroot)
    I have a wordpress DB in MySQL and can access it from the mysql command. Apache and PHP seem to be working fine because I have other PHP elements of my site working fine. When I run the install.php script I get a blank page. I have tried editing the wp-config.php file by hand but still get a blank page. What am I doing wrong? Does MySQL run in a jail? If so how do I un-jail it?
    Thanks in advance,

  2. Anonymous
    Posted 12 years ago #

    Tried a different browser? This seems to be a common problem. On one occasion, someone else on here had the same problem, they posted a link, I visited it and ran through the setup wizard, then gave him the password for the admin :)
    And, is the page really blank, or do you just not see anything on the screen? Peek at the source.

  3. mccomc
    Posted 12 years ago #

    I just tried using Safari instead of IE and did a view source and it was blank also. Any other ideas? I'll try just about anything! Feel free to see for yourself at http://www.equium.org/wordpress-1.0.2/wp-admin/install-config.php once you enter all the database connection details it hangs.
    Thanks for you suggestion!

  4. susane21
    Posted 12 years ago #

    I had this same problem, blank screen after doing the upgrade. The source code says the following:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head profile="http://gmpg.org/xfn/1">
    <b>Fatal error</b>: Call to undefined function: convert_bbcode() in <b>/home/myusername/public_html/blog/wp-includes/template-functions.php</b> on line <b>23</b>
    Do you know what this might mean?

  5. CeeJayCee
    Posted 12 years ago #

    mccomc: the page works for me (I'm using FireFox on Windows XP).
    Try manually creating the wp-config.php file instead of getting the script to make it for you. Does that help at all?

  6. mario
    Posted 12 years ago #

    Incredible! thank you very much Mark! mine (blank page in step 3 of installing) was the same problem of browser that Mark suggested to Christopher. With mozilla the problem has been solved (miracle of open source?).
    But, people, pay attention to the addresses of the links. After I got my password when I logged in, the file post.php had a different path: http://localhost/wordpress/wp-admin/post.php (in my pc) and not http://localhost/wp-admin/post.php as expected by wordpress.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.