Support » Plugin: Embed Any Document » Blank screen in visual classic editor in WP5

  • Resolved skyphilrock

    (@skyphilrock)


    Since I upgrade to WordPress 5, I am not able to edit post in Visual view of Classic editor. The editor part of the screen is empty.
    When I switch to text mode, I can see the post content.
    Anyway, web pages are well displayed with any document attached to the post using ‘Embed Any Document’.

    I can find this information in the inspect tab :

    media-editor.min.js?ver=5.0:1 Uncaught TypeError: <strong>wp.shortcode is not a constructor</strong>
        at Object.shortcode (media-editor.min.js?ver=5.0:1)
        at n.initialize (mce-view.min.js?ver=5.0:1)
        at n.b.mce.View (mce-view.min.js?ver=5.0:1)
        at new n (backbone.min.js?ver=1.2.3:1)
        at Object.createInstance (mce-view.min.js?ver=5.0:1)
        at mce-view.min.js?ver=5.0:1
        at Function.m.each.m.forEach (load-scripts.php?c=0…-upload&ver=5.0:348)
        at mce-view.min.js?ver=5.0:1
        at Function.m.each.m.forEach (load-scripts.php?c=0…-upload&ver=5.0:348)
        at Object.setMarkers (mce-view.min.js?ver=5.0:1)
    shortcode	@	media-editor.min.js?ver=5.0:1
    initialize	@	mce-view.min.js?ver=5.0:1
    b.mce.View	@	mce-view.min.js?ver=5.0:1
    n	@	backbone.min.js?ver=1.2.3:1
    createInstance	@	mce-view.min.js?ver=5.0:1
    (anonymous)	@	mce-view.min.js?ver=5.0:1
    m.each.m.forEach	@	load-scripts.php?c=0…-upload&ver=5.0:348
    (anonymous)	@	mce-view.min.js?ver=5.0:1
    m.each.m.forEach	@	load-scripts.php?c=0…-upload&ver=5.0:348
    setMarkers	@	mce-view.min.js?ver=5.0:1
    (anonymous)	@	plugin.min.js?wp-mce…80716-tadv-4.7.13:1
    c.fire	@	tinymce.min.js?ver=4800-20180716:2
    fire	@	tinymce.min.js?ver=4800-20180716:2
    Ox	@	tinymce.min.js?ver=4800-20180716:2
    setContent	@	tinymce.min.js?ver=4800-20180716:2
    load	@	tinymce.min.js?ver=4800-20180716:2
    ux	@	tinymce.min.js?ver=4800-20180716:2
    lx	@	tinymce.min.js?ver=4800-20180716:2
    vx	@	tinymce.min.js?ver=4800-20180716:2
    (anonymous)	@	tinymce.min.js?ver=4800-20180716:2
    (anonymous)	@	tinymce.min.js?ver=4800-20180716:2
    qt	@	tinymce.min.js?ver=4800-20180716:2
    s	@	tinymce.min.js?ver=4800-20180716:2
    n	@	tinymce.min.js?ver=4800-20180716:2
    u	@	tinymce.min.js?ver=4800-20180716:2
    load (async)		
    (anonymous)	@	tinymce.min.js?ver=4800-20180716:2
    qt	@	tinymce.min.js?ver=4800-20180716:2
    s	@	tinymce.min.js?ver=4800-20180716:2
    loadScripts	@	tinymce.min.js?ver=4800-20180716:2
    loadQueue	@	tinymce.min.js?ver=4800-20180716:2
    (anonymous)	@	tinymce.min.js?ver=4800-20180716:2
    waitFor	@	tinymce.min.js?ver=4800-20180716:2
    (anonymous)	@	tinymce.min.js?ver=4800-20180716:2
    (anonymous)	@	tinymce.min.js?ver=4800-20180716:2
    qt	@	tinymce.min.js?ver=4800-20180716:2
    s	@	tinymce.min.js?ver=4800-20180716:2
    n	@	tinymce.min.js?ver=4800-20180716:2
    u	@	tinymce.min.js?ver=4800-20180716:2
    load (async)		
    (anonymous)	@	tinymce.min.js?ver=4800-20180716:2
    qt	@	tinymce.min.js?ver=4800-20180716:2
    s	@	tinymce.min.js?ver=4800-20180716:2
    loadScripts	@	tinymce.min.js?ver=4800-20180716:2
    loadQueue	@	tinymce.min.js?ver=4800-20180716:2
    (anonymous)	@	tinymce.min.js?ver=4800-20180716:2
    Cx	@	tinymce.min.js?ver=4800-20180716:2
    xx	@	tinymce.min.js?ver=4800-20180716:2
    render	@	tinymce.min.js?ver=4800-20180716:2
    n	@	tinymce.min.js?ver=4800-20180716:2
    (anonymous)	@	tinymce.min.js?ver=4800-20180716:2
    qt	@	tinymce.min.js?ver=4800-20180716:2
    e	@	tinymce.min.js?ver=4800-20180716:2
    b.bind	@	tinymce.min.js?ver=4800-20180716:2
    F	@	tinymce.min.js?ver=4800-20180716:2
    init	@	tinymce.min.js?ver=4800-20180716:2
    e	@	editor.min.js?ver=5.0:1
    (anonymous)	@	editor.min.js?ver=5.0:1
    C	@	tinymce.min.js?ver=4800-20180716:2
    d	@	tinymce.min.js?ver=4800-20180716:2

    In order to use the visual classic editor, I had to disable the ‘Embed Any Document’ plugin.

    Thank you for your help
    Philipe

Viewing 3 replies - 1 through 3 (of 3 total)
  • Can you please provide a list of all active plugins in your site? Also can you please tell the version of Embed Any Document(is the latest: v2.4)?

    Hi,

    Please update to the latest version 2.4.1 and let us know if the issue is fixed or not! Thanks for reporting 🙂

    Hi,

    Update done for Embed Any Document 2.4.1 and Classic Editor 1.3

    I am now able to edit post is visual mode of Classic Editor without issue.

    Thank you for your support.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Blank screen in visual classic editor in WP5’ is closed to new replies.