Support » Plugin: WP Video Lightbox » Blank Screen appearing in the lightbox

Viewing 9 replies - 1 through 9 (of 9 total)
  • AMGill

    (@amgill)

    Same with the vimeo player. I have to force the page to be NON-secure in order for the popup to play the video. I looked through all the files in the plugin to see if the vimeo url could be changed to https:// but no luck. Hoping the plugin developer can fix this soon.

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi, is your issue similar or the same as in the following support thread? If it is can you follow the troubleshooting steps.

    Thank you

    AMGill

    (@amgill)

    Yes it is similar to that thread. I disabled all plugins and the same problem happened. I reverted to an early plugin verion and it still happened. I get the same mixed content error in Google console. The video works fine when I force the page to not be secure which I really don’t want to do longterm. Are you sure this is not an issue with the plugin pulling in http://player.vimeo.com when it should be https://player.vimeo.com?

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi,

    Are you sure this is not an issue with the plugin pulling in http://player.vimeo.com when it should be https://player.vimeo.com?

    The plugin works with https sites. If it didn’t many would have reported this issue. Currently there are more than 70,000 active installs. Most of them are running their sites using SSL.

    In the support thread I shared above the gentleman had an issue with one of his plugins loading an older version of prettyphoto.js. You can read more about below.

    The Nimble Portfolio plugin was loading in an older version of prettyphoto.js (v3.0.1) that was walking over your up-to-date version and causing the conflict. Getting that older version of prettyphoto.js out of the picture allows my youtube videos to display as intended.

    The older version of prettyphoto seemed to be dropping the protocol attribute from the YouTube URL and outputting it as http instead of https, hence the mixed content (even though my html specifies the https YouTube embed URL).

    Take care,
    Matt

    Once he fixed that issue our plugin was displaying the correct URL, i.e. https://.

    Let me know if you need more help.

    Kind regards

    Plugin Author wptipsntricks

    (@wptipsntricks)

    @amgill, Please provide a link to the page in question so we can take a look.

    Plugin Author wptipsntricks

    (@wptipsntricks)

    @cnis, I see this error in my browser console:

    
    Mixed Content: The page at 'https://www.commonwealthsocietyofindia.com/' was loaded over HTTPS, but requested an insecure resource 'http://www.youtube.com/embed/6Yn5jZJ9_HQ?rel=false'. This request has been blocked; the content must be served over HTTPS.
    

    And it’s coming from https://www.commonwealthsocietyofindia.com/wp-content/plugins/easy-image-gallery/includes/lib/prettyphoto/jquery.prettyPhoto.js?ver=1.2

    Please disable this script so our video lightbox plugin can function normally.

    For more information on how you can use your browser to diagnose JavaScript errors, please check this link:

    https://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

    AMGill

    (@amgill)

    @wptipsntricks

    Thanks for looking into this.

    I found the issue with the filtered gallery (TNiT Filter Gallery) that is on the page. Even though it loads the current version of pretty photo there is some sort of conflict. When I turned that plugin off and tested the video lightbox shortcode on another secure page the video played. So…that plugin was definitely the issue. Sorry for the runaround. Unfortunately that pluign is no longer supported so I may have to find another solution. Thanks for your quick response. Here are some links if you want to see where the issue is…

    I set up a copy of the page with https so you can see the mixed content error
    https://travelwebinars.com/replays-2/
    I have the public page here with http so it works: http://travelwebinars.com/replays/

    Click on any of the Watch Webinar buttons to see the problem.

    Thread Starter cnis

    (@cnis)

    Thanks… Yes its working after disabling easy image plugin script.

    Plugin Support mbrsolution

    (@mbrsolution)

    @cnis amd @amgill, I am happy to know you found the conflicting plugin. Well done!

    Enjoy the plugin.

    Kind regards

    • This reply was modified 3 years, 12 months ago by mbrsolution.
Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Blank Screen appearing in the lightbox’ is closed to new replies.