Blank RSS Feeds - Feeds not Working (4 posts)

  1. rycaps
    Posted 9 years ago #

    I am hosting a website that was just transferred from another server - http://www.jaredcramer.com.

    The RSS feeds were working fine prior to the transfer, and now, the feeds at:


    are entirely blank.

    When I run it through the validator I receive the following errors/output:


    This feed does not validate.

    line 1, column 0: XML parsing error: <unknown>:1:0: no element found [help]

    In addition, this feed has an issue that may cause problems for some users. We recommend fixing this issue.
    Feeds should not be served with the "text/html" media type

    Any idea as to how this can be resolved would be GREATLY appreciated.

    Thanks so much,

  2. justapreacher
    Posted 9 years ago #

    This is my site Ryan is talking about. I've dug some more and have found that the following feeds work:


    However, all of my subscribers have subscribed through a different feed address, one of these two:


    In fact, if you are using Safari, navigate to my site and click on the "RSS" button in the URL box, it will bring up the /?feed=atom address, even though it is blank.

    I don't know how it changed from the /?feed=rss2 format to the /wp-rss2.php format in the link, but I would like to change it back.

  3. justapreacher
    Posted 9 years ago #

    I'm still working on this issue. I tried the Feed Locations Plugin and set the default rss2 (http://www.jaredcramer.com/?feed=rss2) and atom (http://www.jaredcramer.com/?feed=atom) feeds to automatically redirect to the working rss2 (http://www.jaredcramer.com/wp-rss2.php) and atom (http://www.jaredcramer.com/wp-atom.php) feeds.

    Now if you click on the RSS button in the URL in Safari, it automatically redirects to the working atom feed.

    However, this still doesn't solve my problem because when you type in the non-working feed addresses (http://www.jaredcramer.com/?feed=atom and
    http://www.jaredcramer.com/?feed=rss2) they both come up blank still, instead of redirecting to the correct feed.

    Furthermore, when I try to add the feed from my blog on Bloglines it still brings up the non-working feed addresses and it only displays the posts from before those feed addresses stopped working.

    I think there must still be a basic error somewhere that I'm missing. Has anyone else ever heard of the ?feed=atom and ?feed=rss2 feeds suddenly ceasing to work while the wp-atom.php and wp-rss2.php feeds continue to work?

  4. nickgassmann
    Posted 8 years ago #

    I'm having this same issue. 7 months later. Anybody with knowledge of a fix or what we messed up out there?

Topic Closed

This topic has been closed to new replies.

About this Topic