Support » Fixing WordPress » Blank posts page

  • Hi, everyone and happy holidays!

    Having this problem, please help: my “posts” page is blank. I have my blog set under “reading” to show a static page (“home”), and for my “posts” page to be “blog”.

    It was working fine when I built the site. And it was working after I had problems (and fixed them) last week after having blank page problems (all pages and admin) related to Earthlink’s lack of mod_rewrite support.

    I am running 2.9 with the theme Atahualpa 3.4.4 plus a handful of plugins, and have done the following to troubleshoot this, to no avail:

    ~ reverted to the default theme
    ~ deactivated the plugins one at a time
    ~ changed the plugin folder to a blank folder
    ~ deleted and recreated the “blog” page
    ~ turned off and on the static page feature several times
    ~ did an auto-reinstall of WordPress from the Tools menu
    ~ added and deleted the Earthlink-specific .htaccess PHP version line from .htaccess
    ~ got rid of .htaccess completely
    ~ searched WP forums, Earthlink help, and BFA forums (where the Atahualpa theme comes from, though it seems to not be theme related)

    Also currently there are NO active plugins and the permalink structure is set to ‘default’.

    So, basically I stripped the whole installation down to the core and reinstalled the whole thing, have turned everything off (except the theme which seems to be unrelated), yet it’s still broken.

    Is there a chance there is some deep-down Earthlink issue? I am not having this problem on any of my other WP installs, none of which are on Earthlink.

    The URL of the site in question is: http://www.jetsetcouriers.com
    The page having the problem is “Blog”.

    Thanks for any insight you may have,
    Wyro

Viewing 15 replies - 1 through 15 (of 18 total)
  • I see that this issue is 5 days old already.
    I have the same problem. And I’m becoming totally discouraged.

    I changed themes, though that also didn’t help at all. The blank page goes to: http://xxxxx.com/wp-admin/post-new.php just like sites I have that DO work, so that isn’t it(whatever ‘that’ is).

    Unlike Wyro I don’t use Earthlink, which isn’t the problem anyway, since my other sites work normally.

    What can we do? We need to add posts or our readers will evaporate.

    jerice50

    I’m having the same issue, some older posts are fine (not all), although, any new post is blank when you visit the post’s page, it shows up fine on the main page.

    Mine seems to be related to a plugin, as I uploaded a the 2.9.1-RC1 version and it worked great, then i activated my plugin’s and it started showing up blank again, back to the drawing board.
    -peter

    Has anyone checked WordPress Trac to see whether the cause lies with bugs in 2.9?

    R

    Also –
    Cannot edit or add Pages.

    jerice50

    Everything works fine on mine EXCEPT the Edit function, which allows you to edit posts. Kinda creates a problem for me since I have posts coming in automatically that NEED editing.

    Wondering if this thread is being checked.

    Hi wyro,
    I’ve checked your page and it looks like your blog is working ok. Can you relay what you did to fix it?

    Still not working and I am plenty pissed with the whole mess.

    Hi jerice50,
    I’m new here but I’ll pass along what got my blank pages, posts and permalinks working again. I was trying to use just /%postname%/ as the permalink structure but when I did the whole Permalink Settings page went blank, along with my website. Then after noodling around I did the following and it worked:

    1) Went to phpmyadmin and deleted /%postname%/ from permalink_structure in wp_options. (This brought back my Permalink Settings page in WP)

    2) Set Permalink Structure to Month and name.

    3) Used Custom Permalinks plugin to set my posts link structure.

    This is what gat me going again. I hope it helps!

    Reginator,
    Thanks fr posting your point#1!!! Saved me a lot of frustration! Down with Earthlink for not supporting mod_rewrite!

    I’m having the same problem. posts page is blank. I tried resetting the Permalink Structure from numeric to Month and Name and it didn’t work. I’ll keep working on it, but if anyone has any other ideas, I’d be grateful for the guidance. Thanks.

    OK. I’m back and it’s *FIXED*. I deactivated the last plugin I added (WordPress Gravatars) and that brought back my Post editing capabilities. there must be a problem between my Techozoic Fluid 1.8.3 theme and the WordPress Gravatars plugin. I can deal with not having the Gravatars plugin for now. Hope this is helpful for someone else who runs into the same issue.

    Reginator,
    Your suggestion also solved my problem. After changing the permalink structure, I suddenly couldn’t access the admin pages to edit “Posts” or “Permalinks” — those sections were just displaying as blank white screens. Was tearing my hair out.

    I’m always a bit shy to mess with the phpMyAdmin side of things, so thank you for describing what to do. In my case, I just left the database’s permalink “option_value” field completely empty.

    Thank you so much!

    I’m having the same problem, can’t edit or add new posts with 2.9.2. I tried changing the permalinks as instructed above, no difference. I tried deactivating my plug-ins one by one, no difference.

    Any ideas?

    Thanks, Susie

    Well, never did figure out the cause. But I fixed it by
    1. exporting the wordpress files
    2. Removing wordpress
    3. Reinstalling
    4. copying the plugins (I already had them saved)
    5. copying the theme
    6. importing the wordpress files

    Which should give me exactly the same thing I started with, but now the new post page looks fine.

    –Susie

    Reginator,

    Thanks so much for your suggestion to remove the offending label in the permalink_structure file in the wp_options table of phpmyadmin. For EarthLink host users, this is found under the MySQL Databases portion of your control center. This got me back to where I could at least have the ‘ugly’ permalinks back and my web pages. I am going to post this on another thread that seemed to be needing the same fix.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Blank posts page’ is closed to new replies.