Support » Fixing WordPress » Blank Post.php but posts correct

  • Resolved Navjot Singh


    For past so many days on both versions 2.0 and 2.0.1 whenever I post instead of returning to show successful posting post.php opens as a blank page but the post gets on the blog successfully. I thought that it maybe a problem with ping so I removed all pings and now only default pingomatic service is there! But still post.php appears as blank Page!

    Help me! This problem is also on 2.0.1 version Now.

    My Blog:

Viewing 15 replies - 1 through 15 (of 15 total)
  • When I press save button post publishes properly and new page also loads! When I press Publish button blank page opens instead of a page showing that post is published successfully!


    Try removing from your options->writing screen and see if that makes a difference. Let us know if that helps.


    I have the same problem on my blog.
    I tried to remove the RCP link to pingomatic in options, but it didn’t solve the problem.

    I hope someone will find a solution to this problem…

    Problem solved now but not know how it has been solved!!! I did not remove pingomatic but still now everything worked!! Maybe 2.0.1 version is responsible for it!!

    Thanks anyways!!!

    I have the same problem. First, it was happening with 1.5.2 install but when I upgraded to 2.0.1 nothing changed. I removed pingomatic link but still no change.


    I am experiencing the same thing, could it be related to certain themes?

    bump – I’ve had the same prob since 1.5. Never found a solution to it.

    I’m using 2.0.2 and have noticed a similar problem. If I edit a post and click the Save button, I can see that the edit went through pretty much right away by visiting my site in another window. But the edit page takes a looong time to come back and when it does, it is blank (view source shows nothing).

    From Ecto, I get a “connection lost” error after a while of “busy cursor/spinning”. Again, the post actual _does_ go through.

    Anyone have suggestions of diagnostics or things to try to track this down?

    Try removing from your options->writing screen and see if that makes a difference. Let us know if that helps.

    This worked for me!!!! Woohoo!

    I tried that and it didn’t make a diff for me.

    I installed WP (latest version as of 05/06) on two domains on two servers. One blog works perfectly and the second just started acting up with the post.php pop-up problem two days ago.

    EVERYTHING is the same (same ping sites, same plug-ins, etc.). I do not have on either site.

    When I post something, it saves the post but it doesn’t seem to ping everything (it is much quicker 3 seconds verus 15 seconds on the working blog) and then Foxfire wants to know what I want to do with the post.php file… save to disk or open with some program.

    If I save it and look at it, it’s blank.

    This is very irritating!

    It used to work without error but not it pops up every time I post a message.


    Hmmm… oddly, I just deleted my entire list of ping sites and ADDED (so now it is the only ping site listed)…

    And it worked (no post.php pop-up)!

    I’m as confused as ever now.

    Thanks! I was having a similiar problem, and removed the and it works great now. thanks.

    This could be down to a memory usage problem, see this post for more details.

    I had this problem too. Even after removing the pingomatic URL it still didn’t work. I solved by going through my ping list and eliminating the ones that timed out.

    My current working ping list can be found at

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Blank Post.php but posts correct’ is closed to new replies.