WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Blank Permalink Admin Page after changing permalink type

[Resolved] Blank Permalink Admin Page after changing permalink type

  • (I have searched the forums and have attempted all similar issue solutions, with no success. This seems like an undocumented issue. If it is please comment with the link.)

    Hello,

    I’ve locked my self out in a big way.

    I have am running on Apache, with mod_rewrite on, my root permissions (i believe) set to allow wordpress to write to it, and i have an .htaccess document which contains the recommended text. I am using SVN for server access, but i don’t think that it is a factor.

    I can access the ‘admin’ page and can click to the internal links, but i get nothing below the update nag on the Permalinks page.

    I was experimenting with pretty-links for SEO purposes, and when i saved something custom like /%category%/%page_name%/ things went blank, and i was unable to navigate ‘back’ to change it to defaults. Is there some way to reset permalinks to default out side of the admin page?

    Any help is appreciated. A re-install seems out of the question.

    -Alex

Viewing 15 replies - 16 through 30 (of 51 total)
  • I am also experiencing this – really now, did no one manage to fix this??

    I’m confused, too. I backed up and then blew away my 2.9.2 installation. When I reinstalled and restored from backup, options-permalink was still blank.

    This happened to me today. I was able to access the mySQL database through my hosting account admin and manually remove the permalink_structure entry.

    In the database, I found the wp_options dataset and then the option_id 34 labeled “permalink_structure”. I cleared and re-saved this field.

    When I reloaded the WP admin, the permalinks panel reset.

    Good Luck –

    Had this same problem, took us forever to get our issue resolved. We did this:
    Rebuilt apache (using easyapache within cPanel) with version 5.2.x instead of 5.3.x

    Hey! I dont know if you’re still needing assistance… but this might just help you… it helped me!

    http://codex.wordpress.org/Changing_The_Site_URL

    read carefully.

    Thanks, jm300 for noting that it may be our host (Earthlink) that hasn’t supported the Apache mod_rewrite since 2007 and therefore not supported the pretty permalinks.
    I, too, had read every post possible and done all the recommended suggestions for getting back my posts before I came upon this helpful post. I will attempt some manual fix, even if it’s rebuilding.

    Also, a shame that no WordPress moderator stopped by. Perhaps they log this one under “beyond help” and don’t bother with it. Thanks to the community for finally figuring this out.

    Comments welcome as I don’t relish rebuilding in this manner.

    Whew! I found a really simple fix on this forum (via Google of all things) that helped me. It’s from a member not a moderator. Thanks, Reginator.

    “…I’ll pass along what got my blank pages, posts and permalinks working again. I was trying to use just /%postname%/ as the permalink structure but when I did the whole Permalink Settings page went blank, along with my website. Then after noodling around I did the following and it worked:
    1) Went to phpmyadmin and deleted /%postname%/ from permalink_structure in wp_options. (This brought back my Permalink Settings page in WP)
    2) Set Permalink Structure to Month and name.
    3) Used Custom Permalinks plugin to set my posts link structure.”

    Happy Blogging!

    1st of all i thank Reginator! FIXED 😀

    I was Trying to follow your steps. It took me nearly 10 mins to find “permalink_structure” in wp_options

    Just posting this since, people might have tough time with finding “permalink_structure” in phpmyadmin.

    1.After you log in to phpmyadmin and choose the Database name from the Drop down on the left side. You’ll get the list on the left, just click on “wp_options”

    2.You will get a list of options in the middle of your page.

    3. Now this is the list in which you need to find “permalink_structure”

    4. Scroll down to the bottom of the page you will have a drop down to choose the page. Jump to page 2. you will find “permalink_structure” there.

    5. Now just simply click the pencil icon to edit the entry.

    6. Here i didn’t understand ‘Reginator’ about deleting /%postname%/ from it. But what i did was, the 1st blank field under “value” had a number 33. I just deleted it and entered “0” and pressed the Go button to save it.

    Ta daaa.. My permalink page was up and i was able to change the permalink Structure.

    Had same problem. Followed GoingVeggie and added info from gowdemon. It worked. Thank you guys.

    When I changed number under Value (for me: 34, to 0) it did not work, but I deleted the entire entry in the option-value box (for me it was: /%category%/%postname%/) and it worked.

    Your posts have avoided a lot of trepidation. Thanks!

    Hi everyone, I’m facing the same issue here (Blank page for permalink settings) and would appreciate a little help please:

    For me the option_value is already blank and I’ve already tried setting the option_id to zero.

    Here’s what I did after reading the posts above:

    1. Deleted the wordpress sub-directory. Deleted the MySql database and the MySql user using the “MySql Databases” tool in cPanel. Ensured that PHPMyAdmin was clean (i.e. it read “no databases”).

    2. Did a fresh install of WP 2.9.2. Faced the same issue of the “options-permalink.php” page being blank (sans the line on the top).

    3. I then went into PHPMyAdmin –> wp_options –> Browsed to permalink_structure.
    – Noticed that the “option_value” textbox was blank (per the posts above, i think it needs to be that way?)
    – The value for option_id was set to 32 — I set it to 0 and saved :No joy. Set it back to 32 / different ‘unique values’ – back to 32.
    – Tried entering multiple different values in option-value – No difference – the page still won’t load. For some settings – It went completely blank.
    – Went to PHPMyAdmin –> ProcessList and restarted the thread – no difference.

    Thoughts anyone?

    /Abhi

    I encountered this problem on migrating a site to a new host – my solution is below.

    Everything worked OK after migration except as AFreeman described the Permalinks screen rendered blank after the admin header navigation appeared.

    I traced the issue back to a function in wp-admin/includes/misc.php
    got_mod_rewrite. It seems that the function was returning a false negative to mod_rewrite being installed (it most definitely was). Some funky setting on new server made it fail I guess.

    Anyhow below are the changes I made to get it working. Insert standard warnings about editing core files and losing these changes when upgrading.

    function got_mod_rewrite() {
    	//$got_rewrite = apache_mod_loaded('mod_rewrite', true); //old line with false negative;
    	$got_rewrite = true;//force the response to true as we know mod_rewite is installed;
    	return apply_filters('got_rewrite', $got_rewrite);
    }

    Hi all,

    Thanks for posting and solving this…

    This happend to me:
    Blog was working … But my admin page was blank (pretty white)
    Nothing showed up after login….
    Found this topic – Did not want to reinstall or take the time to mess with DB…

    QUICK-FIX
    So I just via FTP renamed my /wp-content/plugins to /wp-content/plugins-off
    Viola … The Kingdom is open! Got the admin page up again!

    Renamed the folder back to /wp-content/plugins
    Then I just activated each plugin one by one… and kept praying to the Mighty God … No errors…

    A few updates of some plugins and all is pure magic again! 🙂

    Hope you all can benefit from this?

    (I didn’t get Zeniph’s answer… Where did that function go?
    in -.htaccess or at what line in mics.php and adding or replacing?)

    Anyway… I don’t need it now… But maybe it could be in the next update!!

    Happy posting and feel free to check if my blog works:
    http://www.makesuccesseasy.com

    God bless you all

    @netzie – Were you able to configure pretty permalinks?

    Wow, thanks zeniph! I had the same problem with a 100% fresh WP 3 install– blank permalinks page. Then I changed that one line of code provided by zeniph, and it worked!

    WordPress is greatest, guys. Only a few minor issues every once in a great while. Recently I changed to a new webhost, and noticed the permalinks admin page in all 3 of my WP blog sites were broken. They are WP 2.9.2. Today I got a new domain, installed WP 3, but the permalink admin page was blank as well. This is strange if it has something to do with testing if mod-rewrite works. Mod_rewrite works on my website. Not sure what the fix is.

    Zeniph provides a hardcoded fix, right? Hopefully the WP code gurus can make the apache_mod_loaded() function work well.

    Thanks,
    Paul

    Eegads! Thanks Zenpih. I’ve been trying different solutions and yours was the one that worked. Just to be clear for everybody else coming into this thread the steps you should take are:

    1. access .htaccess file from your root directory and add the rewrite code
    2. go into wp-admin/includes/misc.php and replace
      function got_mod_rewrite

      with Zeniph’s code

      function got_mod_rewrite() {
      	//$got_rewrite = apache_mod_loaded('mod_rewrite', true); //old line with false negative;
      	$got_rewrite = true;//force the response to true as we know mod_rewite is installed;
      	return apply_filters('got_rewrite', $got_rewrite);
      }

    Thanks again. This is a godsend!

Viewing 15 replies - 16 through 30 (of 51 total)
  • The topic ‘[Resolved] Blank Permalink Admin Page after changing permalink type’ is closed to new replies.
Skip to toolbar