[resolved] Blank Permalink Admin Page after changing permalink type (52 posts)

  1. riacale
    Posted 5 years ago #

    Eegads! Thanks Zenpih. I've been trying different solutions and yours was the one that worked. Just to be clear for everybody else coming into this thread the steps you should take are:

    1. access .htaccess file from your root directory and add the rewrite code
    2. go into wp-admin/includes/misc.php and replace
      function got_mod_rewrite

      with Zeniph's code

      function got_mod_rewrite() {
      	//$got_rewrite = apache_mod_loaded('mod_rewrite', true); //old line with false negative;
      	$got_rewrite = true;//force the response to true as we know mod_rewite is installed;
      	return apply_filters('got_rewrite', $got_rewrite);

    Thanks again. This is a godsend!

  2. 2010
    Posted 5 years ago #

    Great. So it's not just me that is having problems with this. Before finding this thread I already tried many different things and was beginning to think I had to start from scratch.

    I've now tried Netzies 'quick fix', no fix. I will now try Zenpihs method as worked for riacale.

    Is strange that this glitch has not been sorted yet by WP tech guys.

    Cheers and good luck to future readers.

  3. 2010
    Posted 5 years ago #

    OK, so thanks to Zenpih and riacle I got the options on my permalinks tab/page to show up again.

    I replaced both htaccess files, root and public folder, with the new file as created with Zenpih method and changed code in ..../misc.php

    Even though I really want friendly urls i saved as default structure for now.

    Opened site in a new window and it's still not live...

    Humf...2 steps back, 1 forward, but still no complete fix in sight.

  4. riacale
    Posted 5 years ago #

    your site isn't live? what's the error text that shows up?

    The same thing happened to me too but it was because I changed the permissions on my index.php file in the root directory to 666 as per the other proposed solutions I found.

    When I brought it back to 644 then it went fine.

  5. 2010
    Posted 5 years ago #

    Great, I just read that somewhere else but understood it was for htaccess file permissions.

    Just changed back to 644 in index.php and were live!

    Thank you so much riacle for getting back to me :)

    Was error msg: 500 Internal Server Error

    I've been literally beside myself for the last 3 days with every spare second self educating on google and WP forums, buggering with .htacces files.

    I can finally move on to create the site in depth after sorting out the galleries and friendly urls (more htaccess files).

    Back in business...ahh. and maybe a holiday to Byron Bay one day too...

  6. Fifi
    Posted 5 years ago #

    Thank you, Zenpih :-)

    After I upgraded to WordPress 3.0 the "Permalink Settings" page was blank in my WordPress Admin Panel.

    Fixed that updating the following:

    1. Navigated to ../wp-admin/includes/misc.php

    2. Commented the second line under "function got_mod_rewrite ()"


    function got_mod_rewrite() {
    $got_rewrite = apache_mod_loaded('mod_rewrite', true);
    return apply_filters('got_rewrite', $got_rewrite);


    function got_mod_rewrite() {
    //$got_rewrite = apache_mod_loaded('mod_rewrite', true);
    return apply_filters('got_rewrite', $got_rewrite);

    3. ../wp-admin/options-permalink.php - shows up.

    Many thanks!

  7. kylerhizome
    Posted 5 years ago #

    More thanks to Zenpih!

    I had the same problem as Fifi, but it's all good now. I'm pretty sure I will have to go back in and make the same change when I update, however, which is annoying. Could this be a hosting issue at its root? I'm not averse to raising some cain with my host, but I don't really know what the problem is.

    If not, hopefully the fantastic WP development crew will get this worked out in an update soon.

  8. donboy7
    Posted 5 years ago #


    I am facing the same problem on my new WordPress 3.1 fresh installation plus 5 other wordpress domain name ... They all used to work ... Last time I remember was a month ago.. But Today i was unable to access that permalink page on all my domain names...

    however I did find the solution, and also hoping that WordPress will fix this bug in future release.

    Thanks for the solution

  9. yuzienborn
    Posted 5 years ago #

    Zenpih for president.

  10. AFreeman
    Posted 5 years ago #

    Hello friends.

    Try extending the amount of memory alloted to PHP from (what ever it is, probably 16M) to 32M or 64M (it's probably not much if your server has a gig or ram... don't be stingy!)

    Just be ready to handle all the issues that come with the ability to change your permalinks.

    Yes extending the memory solved this issue for me.
    I want to thank Esmi, and all of the rest of you for your contributions.

  11. ffwebdesigner
    Posted 5 years ago #

    excellent solution, Zeniph. Thanks a lot!

  12. monicharm
    Posted 5 years ago #

    Hi, got the same problem. Tried Netzie's quickfix and it worked!

    * changed plugin directory name
    * logged into admin, could access permalinks again and changed settings
    * changed plugin directory name back to original
    * problem resolved

    That was it! Thanks all for posting here; saved me some deeeeep trouble!

  13. gordolake
    Posted 5 years ago #

    zeniph BIG thank you.

    all working now with yours and yours only misc.php code fix


  14. zeniph
    Posted 5 years ago #

    no worries all - glad was of assistance

    I'm yet to try it but it sounds like AFreeman's (the original poster) solution above of increasing memory for PHP is the true fix - better than my hack to the core.

  15. Vijay Padiyar
    Posted 5 years ago #

    Hi Zeniph

    Thanks, that worked! My permalinks page is back.

    I confirmed with my website host that the issue is due to newer version of PHP (v5.3) installed on the web server recently.


    Vijay Padiyar

  16. Andrew Nacin
    Lead Developer
    Posted 5 years ago #

    Guys, please don't hack core. Whenever you hack core, a kitten dies. (Seriously.)

    You *don't* need to hack core here. Please. Really. There's a filter right below it that you can use. This is a plugin (works on WordPress 3.0 or higher) to force mod_rewrite:

    Plugin Name: Force mod_rewrite
    Description: Forces WordPress to believe mod_rewrite exists.
    Author: Andrew Nacin
    Author URI: http://andrewnacin.com/
    Version: 1.0
    add_filter( 'got_rewrite', '__return_true' );
  17. Andrew Nacin
    Lead Developer
    Posted 5 years ago #

    If you'd like to help us fix this, please try this core hack. Do as I say, not as I do ;-)


    This would be on line 3361 in WordPress 3.0.1. Add an @ in front of the phpinfo(8) call.

    If it works, great! Let us know and we'll include it in the next release.

  18. Ashkir
    Posted 5 years ago #

    I was experiencing this myself as well on fresh installs, autoinstalls, etc. I asked my webhost about it, they got back to me in a few hours. They told me to find this in wp-admin/includes/misc.php

    $got_rewrite = apache_mod_loaded('mod_rewrite', true);

    and replace it with:

    $got_rewrite = true;

    So that was interesting and it worked great! I had a friend test wordpress on his site he had the same issue and the fix my host gave me worked. I am going to try the core edit above as Andrew suggested, it did not work.

    Edit: I can confirm the 5.3 the host that has the blank permalinks pages is 5.3 PHP the hosts that don't have the problem are still at 5.2.

  19. Ashkir
    Posted 5 years ago #

    My webhost has pushed the change to all wordpress blogs so they won't break.

  20. pilaster
    Posted 5 years ago #


    Thanks to you may blog is alive again!

    I did the big mistake yesterday night (too tired to work correctly!) i changed the permalik structure JUST SO!
    Without anything else.

    All went white

    nothing worked

    You did the trick!

    Now I have some minor problems with plugins (they won't activate), but one by one I get it to work again!

    MANY thanks!

  21. Andrew Nacin
    Lead Developer
    Posted 5 years ago #

    Hi Ashkir,

    Think you could put us in touch with your web host? I'm interested in discussing this problem and determining a resolution for all WordPress users affected.

    They can email me at 'nacin' at this domain.

    Many thanks.

  22. amigoaldo
    Posted 4 years ago #

    Thank you very much. Thanks to all. Only changing the name of PLUGINS directory vorked for me.

    The problem is due, at leas for me, to a memory problem caused by too many plugins. The standard memory for my php.ini was 32M. Now has ben augmented to 64M.

    Aldo Furlan

Topic Closed

This topic has been closed to new replies.

About this Topic