The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

[resolved] Blank Permalink Admin Page after changing permalink type (52 posts)

  1. AFreeman
    Posted 6 years ago #

    (I have searched the forums and have attempted all similar issue solutions, with no success. This seems like an undocumented issue. If it is please comment with the link.)


    I've locked my self out in a big way.

    I have am running on Apache, with mod_rewrite on, my root permissions (i believe) set to allow wordpress to write to it, and i have an .htaccess document which contains the recommended text. I am using SVN for server access, but i don't think that it is a factor.

    I can access the 'admin' page and can click to the internal links, but i get nothing below the update nag on the Permalinks page.

    I was experimenting with pretty-links for SEO purposes, and when i saved something custom like /%category%/%page_name%/ things went blank, and i was unable to navigate 'back' to change it to defaults. Is there some way to reset permalinks to default out side of the admin page?

    Any help is appreciated. A re-install seems out of the question.


  2. AFreeman
    Posted 6 years ago #

    This is my dev-build, and when i compare it to the sister build, the URL is the same for http://www.mysite.com/wp-admin/options-permalink.php but on the dev build, there is nothing there, when i look at the page source. It's like it's unable to see the php document.

  3. Shane G.
    Posted 6 years ago #


    Set your desired permalink and add this code in htaccess:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    ErrorDocument 404 /index.php?error=404
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress


    Shane G.

  4. AFreeman
    Posted 6 years ago #

    I really wish i could! When i click on the Settings -> Permalinks i get a blank page. There's the side bar, and the header but all of the options and related text are missing.

    I updated my .htaccess with what you suggested, and committed it to the server, but it did not make a difference.

    Any other suggestions? I saw some one suggest using a php editor to change the php document, but they didn't specify how to force a default status.

    Thanks for your time,

  5. AFreeman
    Posted 6 years ago #

    Perhaps i should add the interoperability of my Post, Page, media, etc links on the admin-dashboard panel, and quick links. Much of the site displays blank pages as well. By blank i mean null content, nothing at all.

    What i really need to do is some how reset my permalinks to a default setting.

    I'll try anything.


  6. AFreeman
    Posted 6 years ago #

    It's interesting... in options-permalinks.php it specifies include (header), which in my situation is execuited. the very next line is
    $home_path = get_home_path();

    I can only assume that it's failing on this line, because it does include the header, but stops there.

    What exactly is associated with home_path ? Any ideas?

  7. AFreeman
    Posted 6 years ago #

    I've done more work on this. I've de-activated all plug-in programs. I've checked all of the dashboard options that are available to me, and they all check out, as standard / typical. My Server Admin tells me that mod_rewrite is on, that my .htaccess is write enabled. I've cleared my cache, tried alternate browsers, and i've even tried praying to the cyber-godz. Nothing has returned the permalinks configuration options.

    What would help, i think; is the table, and row, in SQL where the current setting for permalinks is stored. I understand the dangers of accessing and editing a SQL database.

    Thanks for all your help.

  8. Julian
    Posted 6 years ago #

    I am having the same problem! I just tried changing the permalinks to make it look classier. But, now I am totally stuck.

  9. Julian
    Posted 6 years ago #

    Has this ever happened to anybody? Any help would be greatly appreciated.

  10. Julian
    Posted 6 years ago #

    Oh well, I went ahead and imported my SQL Queries. My last backup was back in mid-December. But, I've learned my lesson to back-up my database more often.

  11. AFreeman
    Posted 6 years ago #


    Did resetting the SQL data work?
    Or did you just wipe it all off and re-install?
    If you manually edited the values, do you remember what the table was called?

    There are many threads all about 3 - 8 months old, all unresolved, regarding this issue. I think i've read them all twice now.

    I'm sort of hoping a moderator will be able to lend me a hand. I've done all that they've suggested on other posts; provided details, a clear summary of the issue, and my steps around-back-and-forth.

    If there is a moderator listening, help?


  12. Julian
    Posted 6 years ago #

    Luckily, when I upgraded to WordPress 2.8 to 2.9 I backed up the
    database just in case. I thought I deleted it. At first I went into phpMyadmin and looked for any tables containing permalinks. I found one which looked to be the structure. I thought, here it is. But, when I edited it, nothing happened. What I had to do was create a new database, go into phpMyAdmin and run the queries I had in my backup database. After that I went into WP-Config and changed the database of WordPress. Worked like a charm! However, I had to re upload some files and update some content since the database is a month old.

    For fun, I tried setting the permalinks to another structure, and the same thing happened. It's really weird. Looks like I am going to have to stick with the ugly looking URL. I wonder if it could possibly be the host. Currently, the WordPress site is being hosted on Earthlink. I am also wondering if there is a solution to this problem.

  13. Julian
    Posted 6 years ago #

    I think I found the problem that blocks Permalinks from working. Permalinks seems to require mod_rewrite and it looks like Earthlink doesn't have it.


  14. AFreeman
    Posted 6 years ago #

    Thank you for your posts JM300, but none of those things help me. Dumping and moving the DB is impossible, as it is integrated into a much larger system. I have mod_rewrite installed and active. I was hoping for a more precise location in SQL, but i do my best with your information.

    Are these forums even moderated any more?

  15. AFreeman
    Posted 6 years ago #

    Hey, Good news.

    I've given up.

    If you're reading this post, because your permalinks are killing you, just stop. Reinstall your site. If you're worried about loosing your data, navigate to the assets you can, and save the page-source. If nothing else you can rebuild from those ashes.

    Also, I want to apologize to the volunteers here at the site, who give their time to help people out, for what i've said. I was frustrated, and alone... not a good feeling, yanno?

    (If there are paid techs... shame on you.)

    With that, i give up on trying to solve this issue, and suggest you do the same. You're only waisting your own time. Time that could be used to rebuild.


  16. shahidr100
    Posted 6 years ago #

    Hi all,

    Even I am facing the same problem. Cannot see options when i click Settings->permalink

    It shows a blank page with no options. Tried clearing the cache, used firefox, IE6, IE7, I8, Opera but no luck.

    Tried WordPress 2.8 and 2.9.1 but of no use.

    .htaccess file was not there. So i created it manually and added the contents with Options Followsymlinks. That also did no good.

    I am stuck in the middle now. Any help from anyone?


  17. Cosmin
    Posted 6 years ago #

    I am also experiencing this - really now, did no one manage to fix this??

  18. dschrag
    Posted 6 years ago #

    I'm confused, too. I backed up and then blew away my 2.9.2 installation. When I reinstalled and restored from backup, options-permalink was still blank.

  19. WylieCreative
    Posted 6 years ago #

    This happened to me today. I was able to access the mySQL database through my hosting account admin and manually remove the permalink_structure entry.

    In the database, I found the wp_options dataset and then the option_id 34 labeled "permalink_structure". I cleared and re-saved this field.

    When I reloaded the WP admin, the permalinks panel reset.

    Good Luck -

  20. id eric
    Posted 6 years ago #

    Had this same problem, took us forever to get our issue resolved. We did this:
    Rebuilt apache (using easyapache within cPanel) with version 5.2.x instead of 5.3.x

  21. odjake
    Posted 6 years ago #

    Hey! I dont know if you're still needing assistance... but this might just help you... it helped me!


    read carefully.

  22. GoingVeggie
    Posted 6 years ago #

    Thanks, jm300 for noting that it may be our host (Earthlink) that hasn't supported the Apache mod_rewrite since 2007 and therefore not supported the pretty permalinks.
    I, too, had read every post possible and done all the recommended suggestions for getting back my posts before I came upon this helpful post. I will attempt some manual fix, even if it's rebuilding.

    Also, a shame that no WordPress moderator stopped by. Perhaps they log this one under "beyond help" and don't bother with it. Thanks to the community for finally figuring this out.

    Comments welcome as I don't relish rebuilding in this manner.

  23. GoingVeggie
    Posted 6 years ago #

    Whew! I found a really simple fix on this forum (via Google of all things) that helped me. It's from a member not a moderator. Thanks, Reginator.

    "...I'll pass along what got my blank pages, posts and permalinks working again. I was trying to use just /%postname%/ as the permalink structure but when I did the whole Permalink Settings page went blank, along with my website. Then after noodling around I did the following and it worked:
    1) Went to phpmyadmin and deleted /%postname%/ from permalink_structure in wp_options. (This brought back my Permalink Settings page in WP)
    2) Set Permalink Structure to Month and name.
    3) Used Custom Permalinks plugin to set my posts link structure."

    Happy Blogging!

  24. gowdemon
    Posted 6 years ago #

    1st of all i thank Reginator! FIXED :D

    I was Trying to follow your steps. It took me nearly 10 mins to find "permalink_structure" in wp_options

    Just posting this since, people might have tough time with finding "permalink_structure" in phpmyadmin.

    1.After you log in to phpmyadmin and choose the Database name from the Drop down on the left side. You'll get the list on the left, just click on "wp_options"

    2.You will get a list of options in the middle of your page.

    3. Now this is the list in which you need to find "permalink_structure"

    4. Scroll down to the bottom of the page you will have a drop down to choose the page. Jump to page 2. you will find "permalink_structure" there.

    5. Now just simply click the pencil icon to edit the entry.

    6. Here i didn't understand 'Reginator' about deleting /%postname%/ from it. But what i did was, the 1st blank field under "value" had a number 33. I just deleted it and entered "0" and pressed the Go button to save it.

    Ta daaa.. My permalink page was up and i was able to change the permalink Structure.

  25. jamesdolle
    Posted 6 years ago #

    Had same problem. Followed GoingVeggie and added info from gowdemon. It worked. Thank you guys.

    When I changed number under Value (for me: 34, to 0) it did not work, but I deleted the entire entry in the option-value box (for me it was: /%category%/%postname%/) and it worked.

    Your posts have avoided a lot of trepidation. Thanks!

  26. asingh
    Posted 6 years ago #

    Hi everyone, I'm facing the same issue here (Blank page for permalink settings) and would appreciate a little help please:

    For me the option_value is already blank and I've already tried setting the option_id to zero.

    Here's what I did after reading the posts above:

    1. Deleted the wordpress sub-directory. Deleted the MySql database and the MySql user using the "MySql Databases" tool in cPanel. Ensured that PHPMyAdmin was clean (i.e. it read "no databases").

    2. Did a fresh install of WP 2.9.2. Faced the same issue of the "options-permalink.php" page being blank (sans the line on the top).

    3. I then went into PHPMyAdmin --> wp_options --> Browsed to permalink_structure.
    - Noticed that the "option_value" textbox was blank (per the posts above, i think it needs to be that way?)
    - The value for option_id was set to 32 -- I set it to 0 and saved :No joy. Set it back to 32 / different 'unique values' - back to 32.
    - Tried entering multiple different values in option-value - No difference - the page still won't load. For some settings - It went completely blank.
    - Went to PHPMyAdmin --> ProcessList and restarted the thread - no difference.

    Thoughts anyone?


  27. zeniph
    Posted 6 years ago #

    I encountered this problem on migrating a site to a new host - my solution is below.

    Everything worked OK after migration except as AFreeman described the Permalinks screen rendered blank after the admin header navigation appeared.

    I traced the issue back to a function in wp-admin/includes/misc.php
    got_mod_rewrite. It seems that the function was returning a false negative to mod_rewrite being installed (it most definitely was). Some funky setting on new server made it fail I guess.

    Anyhow below are the changes I made to get it working. Insert standard warnings about editing core files and losing these changes when upgrading.

    function got_mod_rewrite() {
    	//$got_rewrite = apache_mod_loaded('mod_rewrite', true); //old line with false negative;
    	$got_rewrite = true;//force the response to true as we know mod_rewite is installed;
    	return apply_filters('got_rewrite', $got_rewrite);
  28. Netzie
    Posted 6 years ago #

    Hi all,

    Thanks for posting and solving this...

    This happend to me:
    Blog was working ... But my admin page was blank (pretty white)
    Nothing showed up after login....
    Found this topic - Did not want to reinstall or take the time to mess with DB...

    So I just via FTP renamed my /wp-content/plugins to /wp-content/plugins-off
    Viola ... The Kingdom is open! Got the admin page up again!

    Renamed the folder back to /wp-content/plugins
    Then I just activated each plugin one by one... and kept praying to the Mighty God ... No errors...

    A few updates of some plugins and all is pure magic again! :-)

    Hope you all can benefit from this?

    (I didn't get Zeniph's answer... Where did that function go?
    in -.htaccess or at what line in mics.php and adding or replacing?)

    Anyway... I don't need it now... But maybe it could be in the next update!!

    Happy posting and feel free to check if my blog works:

    God bless you all

  29. AFreeman
    Posted 6 years ago #

    @Netzie - Were you able to configure pretty permalinks?

  30. energymover
    Posted 6 years ago #

    Wow, thanks zeniph! I had the same problem with a 100% fresh WP 3 install-- blank permalinks page. Then I changed that one line of code provided by zeniph, and it worked!

    WordPress is greatest, guys. Only a few minor issues every once in a great while. Recently I changed to a new webhost, and noticed the permalinks admin page in all 3 of my WP blog sites were broken. They are WP 2.9.2. Today I got a new domain, installed WP 3, but the permalink admin page was blank as well. This is strange if it has something to do with testing if mod-rewrite works. Mod_rewrite works on my website. Not sure what the fix is.

    Zeniph provides a hardcoded fix, right? Hopefully the WP code gurus can make the apache_mod_loaded() function work well.


Topic Closed

This topic has been closed to new replies.

About this Topic