Support » Fixing WordPress » Blank pages when posting, commenting and more. Weird behaviour.

  • Resolved Keilya



    Everything was running fine and I didn’t touch any files or SQL tables, when I logged in to the Dashboard and discovered:

    1. The normal space for “WordPress Development Blog” and “Other WordPress News” is now empty. (But everything else is there.)
    2. When I post, edit a page or post a comment, a blank page loads after pressing the “Save” or “Post” equivalent buttons. However, the pages are saved, posts and comments are made safely.
    3. Under Manage >> Posts, my posts are not loading. However, my pages load fine.

    Lastly, everything on the site front is loading fine.

    Is this just an SQL glitch that will go away with time? I have another WP powered blog installed on a subdomain and everything seems to be fine there.

    Any clues? =(

Viewing 10 replies - 1 through 10 (of 10 total)
  • I have seen a lot of posts lately that look like related to the same origin.
    Do you use wp 2.2? The ajax part of wp-admin has been renewed. It sends ‘wrong’ headers, this is causing a lot of problems. I have encountered these problems too in the dashboard en with deleting posts. If so, you could have a look at the solutions in this post:




    Yup, I’m on WP 2.2. I upgraded about 2 weeks ago and the problem didn’t pop up till yesterday.

    I’ve tried the solutions posted in the thread you gave me. Which is pasting this:

    <IfModule mod_security.c>
    SecFilterInheritance Off

    OR this:

    <Files index-extra.php>
    SecFilterInheritance Off

    into a .htaccess file. I’ve uploaded it into the wp-admin directory but it doesn’t work with either code. =/

    The users there seem to be having this error message in their dashboard:

    You don’t have permission to access /wp-admin/index-extra.php on this server.

    I don’t…I just get a blank space. >.< So is this a little different…?

    If it helps, my server is running on:

    MySQL version 4.1.21-standard
    PHP version 4.4.6

    Thanks! >.<



    Anyone? 🙁 The blank space still prevails. Or perhaps I’m not doing my .htaccess file right? Are there any other words I need to insert before and after the code above? =/

    the mod_security fix doesn’t work on all servers. What version of httpd are you running?
    That you see a blank page could well be the same problem. After an error the server displays a predefined shtml page. Probably that page is a blank page at your site.



    I’m looking into my cpanel and it says “Apache version 1.3.37 (Unix)”, so I’m guessing it’s Apache?

    Since everyone is having this error across the board, is there any chance they would fix it with the next update?

    Thank you for your help! >.<

    I had exactly the same problem. The server I was on was running PHP 4.4.4. Fortunately my host ( has both PHP4 and PHP5 available and I can switch between them via .htaccess. When I changed to PHP5, everything magically started to work again — no more weird errors or blank pages or sudden reversions to the default theme.

    I suspect, but can’t prove because I’m not a WP developer by any means, that there might be some new code lurking around in WP 2.2 that is not well supported by PHP4.

    I don’t know if your host has PHP5 available or is willing to upgrade. If so, it might be worth a shot. It would be really interesting to see if PHP5 helps others having the same problems.

    Thanks for the info everyone. I am having the same problem as fantasyguy. Likewise, I also did not notice the problem on the first few day after upgrading to 2.2, it seemed to work, then suddenly — I am getting blank pages in the Admin when I Publish, Save And Continue Editing, Edit Comment, or Update File in the Theme Editor.

    I’ve been reading various threads, trying various fixes. So far, nothing.

    Now I’m going to ask my host about PHP 5, per jabecker’s advice.

    Wish me luck. I’m also considering rolling-back to WP 2.0.x, which would have its own problems if I do that.



    Well, I’m not really a guy, but that’s beside the point. (:

    I’ve check with my hosts. PHP5 is installed on my server, but the default running version is PHP4. They told me enable PHP5 via .htaccess by adding this line:

    AddHandler application/x-httpd-php5 .php

    Anyhow, I tried that for .htaccess file in the public_html directory and the wp-admin directory (together with <Files index-extra.php>SecFilterInheritance Off</Files>) but it still doesn’t work. =(

    The error on my site turned out to be a “space” at the end of a Plugin file…. a plugin that had nothing to do with posting or editing or the admin! Nevertheless, it was the culprit.

    To find this out, I had to De-activate ALL Plugins, and Re-activate one-by-one, with another browswer window open to continually check my blog for the error to pop up. Since I was testing for an error in the Write Post interface, I just kept adding a few words to a post and “Save And Continue Editing”.

    So you might want to see if your admin works ok with all plugins deactivated, if you have tried it.

    Good luck!



    Why of course! The difference between my WP site and my sister’s (the one in the subdomain) is the plugins!

    Hers was working fine while mine have me a whole range of errors!

    In fact, moments after I posted my last reply, my dashboard went BLANK completely. I could even access wp-admin/edit.php

    I was panicking till I read your post about the plugins. I logged into FTP, downloaded the Plugin files and then deleted ALL of them off the server. (I was then hit by a host of comment spams though as Akismet was taken off too. x.x) The dashboard sprang back immediately.

    *damn plugins*

    Now I’m off to find the culprit.

    Also I’ve been looking into the “spaces” issues. I noticed some php plugin files have ONE WHOLE LINE OF BLANK SPACE beneath their last coding. Is it advisable to delete those?

    Thank you!

    In case anyone was wondering. The plugin which caused a fatal error was UltimateTagWarrior. WP didn’t allow it to be activated.

    And yes this goes to show how important deactivating your plugins before an upgrade is. >.>

    *shall follow instructions now* =(

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Blank pages when posting, commenting and more. Weird behaviour.’ is closed to new replies.