Support » Installing WordPress » Blank pages in WordPress 2.0

  • Ive installed a new webserver today:
    apache 2.0.54 php 4.4.0 mysql 4.1.13

    All scripts i try work, databases work. But wordpress DOES NOT. When i log in nothing happens. IF i manage to log in it mostly shows blank pages (no error no thingy, the page-source is empty too!) I’ve tried to login on 4 computers they all turn up blank. In IE it says 404 on many pages.

    A clean install of WP2.0 doesnt make a difference. A clean install of 1.5.2 DOES work and keeps working but im not able to use that because of plugins and my database is upgraded already!

    What happened to 2.0 that its so crappy 🙁

    Please help me out here!

Viewing 15 replies - 1 through 15 (of 31 total)
  • Ive browsed the forum some more and found dozens of posts having the same problem. Is there no known fix? It seems to be pretty huge since it affects a lot of users and pages 🙁


    All plugins disabled?
    Changed to default theme?

    yes, i followed the steps in the codex.

    – I disabled all plugins.
    – Turned off permalinks (just incase)
    – default theme.
    – Then installed a fresh copy of wp2.0 on the new server
    – backedup the db and imported that in the new server.

    I should be able to login then with my existing account and find my self in copy of the original server.

    Then all goes to poop 🙁

    I tried deleteing ALL plugin files and themes except the default theme. but that doesnt work either.

    The install.php and public index.php just work fine. Until theres sessions cookies and logins involved…

    This exact setup worked for weeks on my old server… So its not the db corrupting. Also i tried several other scripts and they all work! Its just wordpress thats not.

    Well if I’m understanding this you are attempting an upgrade and a move of WordPress…right?

    How about moving your 1.5 system to the new server, and once it’s running, then upgrade to 2.0.1.

    Alright, since Apache out of the box is really akward, tell me the follow:

    Did you set it up to allow PHP?

    If you have, then lets go to to your logs folder, scroll down to the bottom. Personally I find Apache is a bugger to deal with when using PHP error reports. Look for things that look like:

    [Sat Feb 11 22:48:00 2006] [error] [client] PHP Fatal error:

    If you see any of those tell me which ones you see, unless you know what you’re doing, which I bet you do.

    This is pretty much not WordPresses fault, I’ve had the same problems.

    @ MichealH:

    Im not upgrading, i have a working 2.0 installation on a linux box. I want to move this to my new server.
    For this i thought the easiest way is to upload a fresh copy and move the db to use. Which didnt work as described.

    I tried a 1.5.2 install and upgrade that which also didnt work.

    @ Direkt:
    Ive install apache / php / mysql with Unix ports (im using freebsd 6.0 amd64)

    PHPmyadmin and other PHP scripts work perfectly, so does the mysql part. Apache itself works fine aswell as far as i can tell.

    I’ve looked in the httpd-error.log and found something disturbing:

    Allowed memory size of 8388608 bytes exhausted at /usr/ports/www/mod_php4/work/php-4.4.0/Zend/zend_execute_API.c:339 (Tried to allocate 0 bytes)
    Allowed memory size of 8388608 bytes exhausted at /usr/ports/www/mod_php4/work/php-4.4.0/Zend/zend_execute_API.c:339 (Tried to allocate 0 bytes)

    This happend when i tried to login, and ended up in a blank page.

    The httpd-access.log looks normal, no errors or weird things there.

    My apache is installed in /usr/local/etc/sbin/ /usr/local/etc/apache2/

    Its a bit nested just like mysql and php because its a port install.

    Hope this helps!
    Thanks in advance!

    If you see any of those tell me which ones you see, unless you know what you’re doing, which I bet you do. Erm, im fairly new to all this. Ive been running windows servers and preinstalled linux distros for some time. But i wanted to do something new and installed BSD on my servers. So yes i know what im doing when it comes to configureing a simple apache/php setup. No i need extensive documentation for BSD. 🙂

    Something tells me that your PHP install isn’t working as it should since that should REALLY never happen, and extensive documentation for BSD comes in around six pounds ( of weight ).

    ^^ I know manuals are huge and stuff. but ok.

    PHP is not working you say. Then explain this. Why are other scripts working aswell as phpmyadmin (which is fairly advanced itself).

    Ill try to reinstall php. See what that does. Ill post here the results.

    I’m pretty sure this goes beyond the scope of the WordPress forums, but you may want to ask the guys over at if you can’t fix the problem through the help here, personally, I can only give you assumptions at this time, as I run a Windows Apache server, and never saw anything quite like this before.

    Ive never saw this before too.

    I just reinstalled php4 completely…. But the problem persists.

    Im running out of options here but to switch from wordpress to another blogger tool. Which i really dont want!

    The error doesnt make sense to me since the directory included is NOT used by php… the /usr/ports folder is a database with installable software and install scripts. So im not sure what php has to do there exept for installing other software… (which is quite not possible i think)

    At some point im thinking it IS a wordpress bugg causing a memory leak or something!

    Well, I’d be damned if thats true, because it must be the way BSD handles it. The only things I can tell you is that:

    PHP 4.4 may have a bug in it,
    WordPress may have a bug in it,
    BSD might not like something PHP is doing.

    I use PHP 4.3 myself, so I’m not really sure what else to tell you. I see no references back to the file in the error so… I’m really outta of ideas here chap.


    I filed a bug report to

    You mentioned you had this type of problem aswell. can you describe how you solved it and where the error was?


    Uff quick reply. Theyre claiming its not a bug. Theyre probably right too 🙂 but ok. This is ANOTHER dead end to solve it 🙁

    Im so frustrated about it…

    This might be worth a try.

    Make sure that your are *at least* logging php errors in a specific file. The line you are looking for is in php.ini, and may look something like

    error_log = /tmp/php_error_log

    This will create a file in the /tmp folder and any php errors will be logged there.

    This caught me out when I rebuilt my server, since php’s default setting is to *not* output errors to the browser.

    HTH, but if not, good luck. 😀

    Ive set php to output errors E_ALL & ~E_NOTICE

    Also this is shown…

    Ill lookinto the separate file thing as this is a nice idea indeed!


Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘Blank pages in WordPress 2.0’ is closed to new replies.