Blank pages in WordPress 2.0 (32 posts)

  1. Arnan de Gans
    Posted 10 years ago #

    Ive installed a new webserver today:
    apache 2.0.54 php 4.4.0 mysql 4.1.13

    All scripts i try work, databases work. But wordpress DOES NOT. When i log in nothing happens. IF i manage to log in it mostly shows blank pages (no error no thingy, the page-source is empty too!) I've tried to login on 4 computers they all turn up blank. In IE it says 404 on many pages.

    A clean install of WP2.0 doesnt make a difference. A clean install of 1.5.2 DOES work and keeps working but im not able to use that because of plugins and my database is upgraded already!

    What happened to 2.0 that its so crappy :(

    Please help me out here!

  2. Arnan de Gans
    Posted 10 years ago #

    Ive browsed the forum some more and found dozens of posts having the same problem. Is there no known fix? It seems to be pretty huge since it affects a lot of users and pages :(


  3. MichaelH
    Posted 10 years ago #

    All plugins disabled?
    Changed to default theme?

  4. Arnan de Gans
    Posted 10 years ago #

    yes, i followed the steps in the codex.

    - I disabled all plugins.
    - Turned off permalinks (just incase)
    - default theme.
    - Then installed a fresh copy of wp2.0 on the new server
    - backedup the db and imported that in the new server.

    I should be able to login then with my existing account and find my self in copy of the original server.

    Then all goes to poop :(

    I tried deleteing ALL plugin files and themes except the default theme. but that doesnt work either.

    The install.php and public index.php just work fine. Until theres sessions cookies and logins involved...

    This exact setup worked for weeks on my old server... So its not the db corrupting. Also i tried several other scripts and they all work! Its just wordpress thats not.

  5. MichaelH
    Posted 10 years ago #

    Well if I'm understanding this you are attempting an upgrade and a move of WordPress...right?

    How about moving your 1.5 system to the new server, and once it's running, then upgrade to 2.0.1.

  6. Direkt
    Posted 10 years ago #

    Alright, since Apache out of the box is really akward, tell me the follow:

    Did you set it up to allow PHP?

    If you have, then lets go to to your logs folder, scroll down to the bottom. Personally I find Apache is a bugger to deal with when using PHP error reports. Look for things that look like:

    [Sat Feb 11 22:48:00 2006] [error] [client] PHP Fatal error:

    If you see any of those tell me which ones you see, unless you know what you're doing, which I bet you do.

    This is pretty much not WordPresses fault, I've had the same problems.

  7. Arnan de Gans
    Posted 10 years ago #

    @ MichealH:

    Im not upgrading, i have a working 2.0 installation on a linux box. I want to move this to my new server.
    For this i thought the easiest way is to upload a fresh copy and move the db to use. Which didnt work as described.

    I tried a 1.5.2 install and upgrade that which also didnt work.

    @ Direkt:
    Ive install apache / php / mysql with Unix ports (im using freebsd 6.0 amd64)

    PHPmyadmin and other PHP scripts work perfectly, so does the mysql part. Apache itself works fine aswell as far as i can tell.

    I've looked in the httpd-error.log and found something disturbing:

    Allowed memory size of 8388608 bytes exhausted at /usr/ports/www/mod_php4/work/php-4.4.0/Zend/zend_execute_API.c:339 (Tried to allocate 0 bytes)
    Allowed memory size of 8388608 bytes exhausted at /usr/ports/www/mod_php4/work/php-4.4.0/Zend/zend_execute_API.c:339 (Tried to allocate 0 bytes)

    This happend when i tried to login, and ended up in a blank page.

    The httpd-access.log looks normal, no errors or weird things there.

    My apache is installed in /usr/local/etc/sbin/ /usr/local/etc/apache2/

    Its a bit nested just like mysql and php because its a port install.

    Hope this helps!
    Thanks in advance!

    If you see any of those tell me which ones you see, unless you know what you're doing, which I bet you do. Erm, im fairly new to all this. Ive been running windows servers and preinstalled linux distros for some time. But i wanted to do something new and installed BSD on my servers. So yes i know what im doing when it comes to configureing a simple apache/php setup. No i need extensive documentation for BSD. :)

  8. Direkt
    Posted 10 years ago #

    Something tells me that your PHP install isn't working as it should since that should REALLY never happen, and extensive documentation for BSD comes in around six pounds ( of weight ).

  9. Arnan de Gans
    Posted 10 years ago #

    ^^ I know manuals are huge and stuff. but ok.

    PHP is not working you say. Then explain this. Why are other scripts working aswell as phpmyadmin (which is fairly advanced itself).

    Ill try to reinstall php. See what that does. Ill post here the results.

  10. Direkt
    Posted 10 years ago #

    I'm pretty sure this goes beyond the scope of the WordPress forums, but you may want to ask the guys over at php.net if you can't fix the problem through the help here, personally, I can only give you assumptions at this time, as I run a Windows Apache server, and never saw anything quite like this before.

  11. Arnan de Gans
    Posted 10 years ago #

    Ive never saw this before too.

    I just reinstalled php4 completely.... But the problem persists.

    Im running out of options here but to switch from wordpress to another blogger tool. Which i really dont want!

    The error doesnt make sense to me since the directory included is NOT used by php... the /usr/ports folder is a database with installable software and install scripts. So im not sure what php has to do there exept for installing other software... (which is quite not possible i think)

    At some point im thinking it IS a wordpress bugg causing a memory leak or something!

  12. Direkt
    Posted 10 years ago #

    Well, I'd be damned if thats true, because it must be the way BSD handles it. The only things I can tell you is that:

    PHP 4.4 may have a bug in it,
    WordPress may have a bug in it,
    BSD might not like something PHP is doing.

    I use PHP 4.3 myself, so I'm not really sure what else to tell you. I see no references back to the file in the error so... I'm really outta of ideas here chap.

  13. Arnan de Gans
    Posted 10 years ago #


    I filed a bug report to php.net.

    You mentioned you had this type of problem aswell. can you describe how you solved it and where the error was?


  14. Arnan de Gans
    Posted 10 years ago #

    Uff quick reply. Theyre claiming its not a bug. Theyre probably right too :) but ok. This is ANOTHER dead end to solve it :(

    Im so frustrated about it...

  15. chillijam2
    Posted 10 years ago #

    This might be worth a try.

    Make sure that your are *at least* logging php errors in a specific file. The line you are looking for is in php.ini, and may look something like

    error_log = /tmp/php_error_log

    This will create a file in the /tmp folder and any php errors will be logged there.

    This caught me out when I rebuilt my server, since php's default setting is to *not* output errors to the browser.

    HTH, but if not, good luck. :D

  16. Arnan de Gans
    Posted 10 years ago #

    Ive set php to output errors E_ALL & ~E_NOTICE

    Also this is shown...

    Ill lookinto the separate file thing as this is a nice idea indeed!


  17. chillijam2
    Posted 10 years ago #

    The settings (trimmed) from my stage server's php.ini file contains the following lines.

    error_reporting = E_ALL
    display_errors = Off
    display_startup_errors = Off
    log_errors = On
    log_errors_max_len = 1024
    ignore_repeated_errors = Off
    ignore_repeated_source = Off
    report_memleaks = On
    track_errors = Off
    error_log = /tmp/php_error_log

    As you can see, I have errors set to E_ALL, but they are still not output to the browser, only to a file. It also stops potentially security compromising error reports being shown to your visitors.

  18. Arnan de Gans
    Posted 10 years ago #

    Yep, i see and i know...

    Im going to reinstall everything soon, but right now im to much pissed off. Since custom installs wont work and the ports install doesnt do shit either... Its not funny anymore.

  19. _Gothic_666
    Posted 10 years ago #

    I have the exact same prob as you Shrikee. I was first experimenting with the WP2.0 on my own computer with "Easy PHP" (Includes Apache, Php, MySQL). Everything worked fine. But now I'we installed WP 2, a new clean install, on my webhotel and after the installation I can't login. Just a blank page. I looked at .htaccess and all works well chmodded it to 666. I can switch between PHP4 and PHP5. Plz if anyone know how to fix this tell us!! Btw, WP 1.5 works fine at the webhotel, I'm an admin for that site and was considering upgrading to 2 but I don't know about that just yet.

  20. Arnan de Gans
    Posted 10 years ago #

    Its just a nasty bug in WP although everyone denies it!

    We cant keep on saying its installation problems as ive seen just about to many people reporting this error!

  21. Chris_K
    Posted 10 years ago #

    I wonder if this post is related: http://wordpress.org/support/topic/59307?replies=20

  22. Arnan de Gans
    Posted 10 years ago #

    Seems similiar yes. And theres more of such posts.

    Ok now ive tried something wild here today.
    I installed Fedora Core 4 / apache 2.0.54 / php 5.0.4 / mysql 4.1.1x

    All out of the box installed by default installations and im getting exact the same errors as when i was on my Unix box yesterday!!

    now someone may explain to me why this ONLY happens with wordpress but its not a wordpress bug.

    On a sidenote:
    Also i noticed while browsing the board that ive seen Almost none if not none replies from the developers. Shouldn they be on top of this? I assume theyre busy and that we cannot demant support as this is freeware software. But if its not working its not state-of-the-art-weblog :(

  23. vigilant20
    Posted 10 years ago #

    I'm having this problem too...have been for some time. Been whining on this post http://wordpress.org/support/topic/52351?replies=8 but like you guys said, no one seems to know what's going on.

    WP just does NOT like to move! The problem is I have to because my current drive is failing. I host blogs for myself, family, friends, and my church so it's really important I get this working. WP works, PHP works, database works, it'll even run the upgrade to 2.0 process, but no go. It doesn't help that WordPress has NO WAY AT ALL to export your data, so I can't even try it another way besides the database restore.

  24. Arnan de Gans
    Posted 10 years ago #

    Vigilant20, which data is not exportable? You can just backup the database and use that copy to install a new one on the new server. The problem here is that the latest WP build seems to have some bug in showing account pages and admin pages... So what youre saying here is not only offtopic but also inaccurate to my ears...

    If you, however, are not able to administrate you database you should consult your network administrator OR webhost to do this for you.

  25. vigilant20
    Posted 10 years ago #

    Excuse me? That's not only rude, but it's wrong. The data is not exportable. Your own post verifies that. I DID backup the database and restore it. My point is that I can't verify if it's wordpress or the database backup which is causing the problem. That is why I was looking for other ways to move the data, but WordPress does not provide an export utility which is a pretty basic function for any application of this sort. But thank you for questioning my intelligence and ability, that really helped to solve everyones problems.

  26. Arnan de Gans
    Posted 10 years ago #

    @ vigilant20:
    Im not here to upset people. Im not here to start pointless discussion and im certainly not here to get pissed off by other people. If you are offended by my words then i hope we're all mature enough to just say so and drop it or drop it without saying.

    I believe wordpress doesnt include a export function as there are plenty of other ways to do this. If wordpress added such feature it would be overdone and unnessesary. (my opinion). Oh and maybe you missed it but by default a database backup/export plugin is included... So basically the option IS offered.

    Please if you want get back on topic and dont argue with me for things that were both partially are right in.

    @ everyone:
    Does anyone have ideas on the issue here? Im not able to solve this on my own :( nor cant i find anything about the error on the internet. So im pretty much clueless again :(


  27. _Gothic_666
    Posted 10 years ago #

    Now there is something anyway happening. I have done no changes but when I tries to log on now I get theese errors:

    Warning: Cannot modify header information - headers already sent by (output started at /customers/ohl.se/ohl.se/httpd.www/blog/wp-includes/locale.php:1) in /customers/ohl.se/ohl.se/httpd.www/blog/wp-login.php on line 9

    Warning: Cannot modify header information - headers already sent by (output started at /customers/ohl.se/ohl.se/httpd.www/blog/wp-includes/locale.php:1) in /customers/ohl.se/ohl.se/httpd.www/blog/wp-includes/pluggable-functions.php on line 274

    Warning: Cannot modify header information - headers already sent by (output started at /customers/ohl.se/ohl.se/httpd.www/blog/wp-includes/locale.php:1) in /customers/ohl.se/ohl.se/httpd.www/blog/wp-includes/pluggable-functions.php on line 275

    Warning: Cannot modify header information - headers already sent by (output started at /customers/ohl.se/ohl.se/httpd.www/blog/wp-includes/locale.php:1) in /customers/ohl.se/ohl.se/httpd.www/blog/wp-includes/pluggable-functions.php on line 247

    This is what they look like at the error lines:
    wp-login.php on line 9
    header('Content-Type: '.get_bloginfo('html_type').'; charset='.get_bloginfo('charset'));

    pluggable-functions.php on line 274
    setcookie(USER_COOKIE, $username, $expire, $cookiepath, COOKIE_DOMAIN);

    pluggable-functions.php on line 275
    setcookie(PASS_COOKIE, $password, $expire, $cookiepath, COOKIE_DOMAIN);

    pluggable-functions.php on line 247
    header("Location: $location");

    I hope this will make some diffrent for me now :) If anyone knows the error I mean.

  28. chillijam2
    Posted 10 years ago #

    Shrikee - Did you try setting display_errors = On in php.ini and then trying to view the site? Any php errors (and and WordPress bugs would *probably* be php errors) would be output to the screen.

  29. Arnan de Gans
    Posted 10 years ago #

    yes i have them set on... Its the first thing i configured.
    Also ive put on backward compatability with php4...

    gothic this error usually means there is something parsed / ouputted before the headers.. this cannot work.

  30. _Gothic_666
    Posted 10 years ago #

    oki... but the big question for me is now I shall solve this problem. I'm no expert on PHP so I don't know what to do. So any ideas and solutions is helpfull :)

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.