Support » Plugin: W3 Total Cache » Blank Pages after WP Update. What to do?

  • I updated WP from 4.4.4 to 4.5.3. A lot of pages are turning up blank on my website (white page without any source doe). They turn up fine when I disable this addon.

    Also, some pages like the homepage appear fine when I’m not logged in as admin, but appear blank (white page without any source code).

    I want to use this addon, but how to fix this error?

    https://wordpress.org/plugins/w3-total-cache/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi sgrx,

    Do you know which options you had enabled, for example, only caching, only minification, both, something else etc?

    Can you try enablin debug log in your wp-config.php by replacing define(‘WP_DEBUG’, false); with this code:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set( 'display_errors', 0 );

    Activate W3TC and visit your site, this should create debug.log file in your wp-content folder that could tell us what is going on.

    Cheers,
    Predrag

    Did you try manually clearing out the cache folder in wp-content?

    I disabled all the options, enabled them one by one to see which one was responsible. Debug.log contained only unrelated php notices. Suprisingly nothing worked. But I woke up today, enabled the plugin again and it worked this time. No idea why. Didn’t work with the same steps yesterday. Weird.

    Didn’t try manually clearing out the cache from the wp-content folder. Maybe the plugin did that today and it worked? Don’t know. It’s weird when a problem fixes itself without indicating how. Maybe I’ll know soon. Thanks.

    Hi sgrx,

    Probably the cache got cleared in the meantime and caused everything to get back to normal.

    Hopefully it stays this way 😉

    Cheers,
    Predrag

    Thanks Predrag Dubajic.

    Unfortunately the issue is back again.

    This time a very important page doesn’t does open fine when I’m not logged into my site (as admin), but if I’m logged in I get a HTTP 500 error. The source code is blank. The debug logs show nothing related to this as well.

    In Page Cache, I have these two ticked:

    1. Don’t cache pages for logged in users (Unauthenticated users may view a cached version of the last authenticated user’s view of a given page. Disabling this option is not recommended.)

    2. Don’t cache pages for following user roles: Administrator

    Unticking #1 and letting #2 be ticked helped; the page was visible again. It says Disabling this option is not recommended. I hope Admin pages won’t be cached if I leave #1 unticked and #2 ticked?

    I don’t know why this issue is there in the first place.

    Great content and super helpful.

    سئو سایت

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Blank Pages after WP Update. What to do?’ is closed to new replies.