Support » Plugin: WordPress MU Domain Mapping » Blank page with "pageok" on second domain?

  • Resolved MGmirkin


    Pretty sure I followed all the steps… Put in my ip address, pointed my new domain’s A record to the server IP address.

    I’m using GoDaddy. Some have noted that they sometimes do things slightly differently than other places?

    There seem to be two things I “can do” there. But I don’t know if they’re equivalent. One is to “Forward” the top-level domain to my server IP. The other is to use their new Domain Manager to look at and edit the DNS Zone. In there there’s an A record. with an @ next to it.

    I’ve tried both ways, but so far to no avail. Whenever I try to load my second domain it seems to either display the IP address in the URL bar and display “pageok” OR display the domain in the URL bar and display a completely white page with nothing on it in the main pane of the browser. Neither of which being optimal.

    I’m pretty sure I’ve got things set up right, I’ve got the IP listed in the right place, I’ve set the new domain to be primary rather than the subfolder of the new site.

    Added sunrise.php to the wp-content folder, modified wp-config.php, modified .htaccess

    Not sure what I’m missing. Fairly new to domain names, even newer to WP MU Domain Mapping plugin & MultiSite generally. Just started working on it tonight. Kind of amazed I got it 90% of the way there w/o breaking anything too badly.

    Main site still works. Not sure wy new site doesn’t.

    Also, may not have waited long enough for A record to update or for forwarding to update. Though I think forwarding updated pretty quickly.

    But, I took off forwarding and instead modified the A record to point to the server IP. As, I THINK this is the right way to do it?

    Any thoughts? Or point me to a thread where this has been dealt with already. I’m on WP 3.5.1 & WP MU DM, in case it matters?

    Any help appreciated. It’s probably something simple/stupid I’m overlooking…

    Oh, and just in case it was something THAT simple, yes, I tried setting to default theme. I’ve created a rudimentary menu & a couple pages. Set the menu to the primary navigation, set the default homepage to one of the static pages. But still nothing is showing up, other than white screen or pageok.


Viewing 11 replies - 1 through 11 (of 11 total)
  • Hmm, I see a page or two down some others were having similar problems & maybe I’m just being too impatient with GoDaddy & DNS servers propagating the changes to my A record?

    As long as the A record is right on both domains and both point to the server addy hosting wordpress, eventually the plugin should catch up once the change takes effect? Assuming I didn’t bugger it up by submitting too many change requests at once… Maybe I’ll go to bed now & see if it works in the morning. Unless there’s some known bug or something I forgot to do…

    Updated to developer version. Basically replaced the stuff in the plugins subfolder & Sunrise.php in/ wp-content/. No joy. Is it just an issue with taking a while for DNS updates or is there some specific GoDaddy issue as some have implied might be the case elsewhere on the interwebs?

    I suppose I should mention, if I haven’t already that none of the live previews or the live themes seem to show anything at all either. Just blank white screens to the right of the left menu bar. No “preview” as with other sites I admin, or as with the primary site, which all works fine. So perhaps it’s not just a DNS update issue?

    Plugin Author Ron Rennick


    DNS takes up to 72 hours to propagate.

    So, it might take a day or two for the second domain to “work” with MultiSite & Domain Mapping?

    Dang. So used to instant gratification! ^_^

    Am I at least correct in assuming that it’s better to edit the A record in DNS Zone than to “forward” the domain to the IP address?

    Still new to all this…


    Plugin Author Ron Rennick


    Am I at least correct in assuming that it’s better to edit the A record in DNS Zone than to “forward” the domain to the IP address?

    I would think so, yes. (I’ve never forwarded one so I’m not sure what it’s actually doing in that case.)

    Fair enough…

    But, it’s STILL just coming up with “Pageok” and still showing blank page in Theme Customization screen. But if I turn off Domain Mapping plugin, or if I switch to the subfolder as the primary URL, it all goes back to visible.

    Granted it hasn’t been 72 hours yet. But it’s been like 24-36. *Impatient foot tapping* ^_^

    Guess I’ll keep waiting. 😉

    Hmm, actually after a couple days of aggravation, I MIGHT know what’s going on now… After just running across this page:

    Actually, the issue is very simple. The pageok message will occur when there is a record in DNS that is pointing to your hosting server, but the domain name is not set up in your hosting account. This issue only affects Linux hosting accounts. There are two possible solutions.

    1. Make sure you have the domain name set up in your hosting account

    For every host entry (“A” record) that you configure in DNS, you must set the domain name up in your hosting account. To do this:

    1. Go to your hosting control panel
    2. Select “Hosted Domains”
    3. Add the domain or subdomain

    2. Make sure the entry you created in the “Hosted Domains” section of your hosting control panel is not still pending setup.

    When you add a domain to your hosting account, it can take a LONG time. Up to 24 hours, in fact. To check if yours is pending:

    1. Go to your hosting control panel
    2. Select “Hosted Domains”
    3. Find your entry and check its status. If its status is “pending” then you are going to see a pageok message.

    In fact:

    1. I’m using GoDaddy. Check!
    2. I’m using their Linux hosting. Check.
    3. I set 2nd domain to same IP as first domain via A record. Check.
    4. I didn’t realize there was another place you had to specify things, that is in the “Hosted Domains” area of the control panel. So, no record there for 2nd dpomain. Check.

    So, this is seeming like a pretty good match for my issue. I’ve added a record to the Hosted Domains list, for what it’s worth, and set it to ‘/’ root.

    We’ll see where that gets us in the next 24h+…

    If it works, then I guess I’d suggest this as one of the FIRST things to check if the issue comes up in the future. Especially for GoDaddy folks, since that seems to generally be the host on which the “Pageok” typically shows up (he says after Googling around for the error itself and mostly coming up with GoDaddy references).

    If not that, then maybe this:

    Directory Size: 17529

    Slightly different but related issue… Also includes a pageok. But seems to be name server related.

    Our testing has shown the solution to this problem to be to go into your GoDaddy Product Dashboard and click on the ‘Name Servers’ button. You then select ‘I want to park my domains.’ Then wait several minutes, maybe 10, and the go back to the ‘Name Servers’ setting and set it to ‘I have a hosting account with these domains.’ Wait another 10 minutes and then try to access the problem website again.

    The issue seems to be incorrect name servers being configured into the DNS records. Even if the name servers seem to be correct in the DNS manager they can apparently still be setup incorrectly and changing these Name Server settings apparently reconfigures the name servers correctly inside the GoDaddy DNS manager.

    It took us a couple of times repeating this process, but it did work. The problem is completely resolved and the website is fully functional.

    Again, that’s for the Pageok + ‘directory size’ text. Solutions seems to be to park and unpark the domain(s) to flush and re-load the name servers (even if they looked correct in the DNS Zone record?).

    Anyway, I’ll see about letting you know the results of my adding the secondary domain to the Hosted Domains list. *Fingers crossed* I’m hoping that fixes it and things start “just working” as they should.


    Eureka! Success!

    Okay, so their solution was seemingly the spot on correct one for my situation. Maybe it’ll help others?

    GoDaddy Pageok error I was receiving was pretty definitively due to not having listed the second [non-primary] domain name I was pointing at the hosting server’s IP address in the Hosted Domains Screen. Once I added it, it went into “Pending” status and a day later (once the second Hosted Domain entry came off “Pending” status) everything works. W00H00! Book the cruise. Issue defined and remedied, finally.

    If anyone else uses GoDaddy and receives that error, probably first thing to do is have them check that the domain they’re pointing to their server address is in fact in their Hosted Domains list. It’s actually on a different screen entirely than any of the pages relating to the DNS Zone, which is why it’s so blasted easy to miss…
    Fix that, PROBLEM SOLVED [for me].

    But, still having a problem with Live Preview.

    It works on the primary site but still brings up only a blank preview with sidebar at left for the secondary domain. Doesn’t seem to matter what theme. I can activate & customize or just “live preview” to the same blank results. If I switch back to subfolder view, live preview again works? Why would one work and not the other?

    Both when using the domain and when using the subfolder the Themes –> Customize link sends me to the same subfolder address + –> /wp-admin/customize.php

    Just when using my domain, it fails to load the preview part, but when using the subfolder approach, everything works fine.

    What gives?

    If it’s a bug in the mapping plugin, could we get it fixed?

    Should this be split out into a separate thread, or dealt with here?



    Just wanted to say thank you for documenting the pageok issue with your GoDaddy hosting. I am in the process of transferring 6 WordPress sites to GoDaddy, and I couldn’t figure out why two sites created on subdomains would only display “pageok” upon loading. Luckily I found this thread, which set me on the path to fixing my problem.

    In my situation the A records were already setup in my DNS Zone file and I had already added the subdomains in the “Hosted Domains” portion of the panel… but when the DNS changed over, I only saw “pageok” on the subdomains. So that made me think you might be right about everything “looking correct,” but in reality it was messed up on a level that we couldn’t see. I decided to simply remove the subdomains from “Hosted Domains,” which in turn removed them from the DNS Zone file, and then I immediately added the subdomains back into “Hosted Domains.” 5 minutes later everything was working just fine!

    Anyway, thanks for your notes on this and I hope this thread helps anyone else in the future.


    I’m getting “pageok” message when typing my domain without the “www” in front of it.

    Hosting: Godaddy
    A Record(s): (Your site is Live)

    It only works for me if I use “www” in front of the domain.

    It was working perfectly until 3 days ago.

    Could anyone help please?

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Blank page with "pageok" on second domain?’ is closed to new replies.