Support » Plugin: Gutenberg Custom Fields » Blank page when klicking on GCF

  • Resolved crolton

    (@crolton)


    After installing GCF I cannot see the GCF settings page. When clicking on the GCF menu item in WP Admin, I get a blank page. It’s a fresh WP 4.9.6 installation and no other plugins than Gutenberg 3.1.1 and GCF 1.5.2 are installed.

    Any idea?

    • This topic was modified 1 year, 4 months ago by crolton.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Riad Benguella

    (@youknowriad)

    Thanks for raising this, I’ll take a look and fix that asap.

    Plugin Author Riad Benguella

    (@youknowriad)

    Unfortunately, I can’t reproduce the error myself (can you check the console?)

    Also, I just released a new version with some fixes, maybe you can see if it’s better now?

    Hi,
    I have the same issue.
    I have been able to add a custom field to posts a few days ago. Everything worked fine.
    Today I tried to add one for pages, but I get a blank screen on the plugin’s settings page.
    Updated Gutenberg to 3.6.2
    Thanks a lot !

    I have this bug and I have tracked down the cause.

    The gcf-config-app js script cannot be enqueued because it depends on the gcf-fields script, which has a mistake in the dependency array. On gutenberg-custom-fields/lib/fields-script.php line 12 (the deps list) there is a reference to a script with the handle ‘wp-utils’, which as far as I can tell, doesn’t exist (you can var_dump the global $wp_scripts var to check which handles you can use, eg. global $wp_scripts; var_dump($wp_scripts);).

    There are two variants which do exist — utils, and wp-util. I tried using both instead of the wp-utils handle, and both fix this bug, however I am not sure which script the plugin author wants to use.

    Plugin Author Riad Benguella

    (@youknowriad)

    Thanks for catching and debugging the issue. It was indeed a Gutenberg breaking change I missed (wp-utils removal). It should be fixed in 1.5.5. Thanks

    Plugin Author Riad Benguella

    (@youknowriad)

    By the way, I’m more reactive in Github issues 🙂

    My preference would have been to create a pull request on Github, but I didn’t know which of the libs you wanted.

    Great, thanks a lot !

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Blank page when klicking on GCF’ is closed to new replies.