Support » Fixing WordPress » Blank page problem

  • Hi guys
    I make a website using the7.2 theme and the website was working perfectly .
    But suddenly when i open the website nothing appear !!!!
    I go to the wp-admin and go to wordpress dashboard and its working
    I try to use another theme and nothing
    Try to deactivate all plugins but nothing
    Pls help me with this
    Thanks

Viewing 8 replies - 1 through 8 (of 8 total)
  • Thread Starter ahmadqwer

    (@ahmadqwer)

    And yeah the wevsite domain is trak-link.net

    I would start by setting wp_debug to true in your wp-config.php-file.

    In this file you’ll see following line:
    define( ‘WP_DEBUG’, false );

    Change this to:
    define( ‘WP_DEBUG’, true );

    Normally, the blank page will then be replaced by the error that is causing it.

    Hi,

    I’m also getting this problem – http://www.conwaytennis.co.uk/diary.

    I’ve changed the WP_DEBUG to true and after much whirling of cogs I got the following error:

    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 57150 bytes) in /home/sites/conwaytennis.co.uk/public_html/wp-includes/functions.php on line 443

    Please con you advise…

    UPDATE:
    I’ve added ‘define( ‘WP_MEMORY_LIMIT’, ’96M’ );’ (also tried 64M) to the wp-config.php file but this hasn’t solved the problem.

    • This reply was modified 5 years, 8 months ago by decoderltd. Reason: Attempted a fix

    This error actually tells us that your PHP_memory_limit on the server is set to 128 MB, but that your site is trying to use more. Because of this, the action is aborted, resulting in the fatal error.
    I’d suggest contacting your hosting provider to set the PHP_memory_limit to a higher value (for example 196 MB) or you could try reducing plugins.
    I’d also remove the define( ‘WP_MEMORY_LIMIT’, ’96M’ ); from the wp-config.php.

    Thanks Brecht, I’ll try that.

    Sure, glad I can help out. Keep me up to date if one of those options doesn’t fix it. Glad to look into further if needed!

    Looks like the memory problems are not ready to go away quite yet!

    I spoke to my hosting company and they raised the memory limit to 500MB, which I thought should be more than enough, but I’m still getting the memory error:

    Fatal error: Out of memory (allocated 187957248) (tried to allocate 110863 bytes) in /home/sites/conwaytennis.co.uk/public_html/wp-includes/wp-db.php on line 3020

    I’m really not sure what to do next…

    Strange, it seems the limit hasn’t increased above 192 MB

    187 957 248 bytes =
    187.957248 megabytes

    Doesn’t really matter, since a WordPress site should rarely use that much memory. Can you indicate me how you disabled all of your plugins? Did you do this via the database or another way?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Blank page problem’ is closed to new replies.