Support » Installing WordPress » Blank page on install – I’ve tried everything and still nothing

  • I could find a lot of posts on this forum about this subject, and tried them all. And still I keep getting that stupid blank page. I’m desperate by now.

    I have a fresh and empty new host, doing a fresh install of wordpress 2.5 over MySql 4.1.20 and PHP Version 5.0.4.

    Here’s some of the tips I found (and didn’t work for me):

    The website host discovered that the PHP settings for my blog on the server had safe_mode turned on. Once safe_mode was disabled it worked fine.

    My safe mode is disabled, according to my host.

    “Tried joecwhite’s idea (edited the index.php file) and noticed that the directory for wp-blog-header.php was:
    require(‘./wp-blog-header.php’);
    I changed it to:
    require(‘wp-blog-header.php’);
    and now everything works!!

    Lucky you… I’m still with a blanck.

    You might also try re-uploading the core WordPress files, as occasionally when someone sets up WordPress not all of the files get transferred, creating these kinds of errors.

    It would be too easy…

    check to see if you have the file .htaccess in the root folder of your domain name.
    if you have check to see if the following line is there
    php_value zend.ze1_compatibility_mode Off
    if it isn’t try adding that line

    There was no .htaccces, I created one and added the line. And the blank page suddently turned…. blank.

    he error was an attempt to allocate 23040 bytes after the maximum memory was used. While you are editing the php.ini file, change the ‘memory_limit’ variable to something larger than the default 8M. I chose 20M and the install ran perfectly. If you don’t have access to your php.ini I guess you are hosed.

    Accordingly to my host, this still not the problem.

    fixing it :
    in php.ini : option log error in a file (don’t remember the exact syntaxe)
    -> log_error : On
    -> specify a filename for logerror some line after
    done.
    restart a fresh install
    worked with a 2.5 rc1 + php5 + mysql5

    Sorry, no access to php.ini.

    I believe its because the function is crashing on mysql_fetch_field the faulty code is :
    wp-includes/wp-db.php
    between lines 254 to 257 :
    while ($i < @mysql_num_fields($this->result)) {
    $this->col_info[$i] = mysql_fetch_field($this->result);
    $i++;
    }
    if you comment it you would have sorta working

    Great, if I comment all the lines in all the files, it will “sorta” working too…. Didn’t even tried this one, it seems to me that skiping code may cause cause more damage than good.

    I deleted the old .htacess file. It’s not visible in my usual ftp client. I had to invoke ftp from a command line and ran “delete .htaccess”. Be careful if there are some other bits on your site that may already use this file, make sure you know what you are doing.

    One tells me to create, another says “delete”. Obviousely, I got back to the starting point.

    It could be extra space in the wp-config file before the opening <?php or after the closing ?>

    No.

    I deleted all my files, reinstalled version [2.3.3] and opened my //domain.org/wordpress/wp-admin/upgrade.php instead of install.php. After uploading your files, DO NOT install “/wp-admin/install.php”… only upgrade.php to preserve your DB. I had a confirmation of an OK upgrade;

    Actually, this one seamed promissing… but it was not.

    open up the .htaccess file within the accounts public_html folder and add the following line to it:
    AddHandler application/x-httpd-php5 .php
    Once you put that in, WordPress will magically work

    It didn’t… yet it was the only one who gave me a different result.
    The page was not blank anymore, but shows some strange code:

    wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn't work for all server setups. The safest way is to manually create the file.
    
    Create a Configuration File"); require('../wp-config.php'); timer_start(); require_once(ABSPATH . 'wp-admin/includes/upgrade.php'); if (isset($_GET['step'])) $step = (int) $_GET['step']; else $step = 0; @header('Content-Type: ' . get_option('html_type') . '; charset=' . get_option('blog_charset')); ?> >

    followed by WP logo.

    This, in the “upgrading” version. When trying the “install” from fresh, it shows some more strange code and tags, along with the boxes to fill (I guess) the blog name and email, and the button… that unfortunely doesn’t work.
    So I’m still stucked.

    For those with the same problem: You have now a short-cut to the solutions presented in this forum.

    For all who managed to make it work:
    PLEASE HELP ME!!!! <desperate cry>

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hey forget the htaccess file thing and give this a try I found a workaround and with no errors. some server environments trip on wp 2.5.for some reason but if you follow my post you’ll most likely get 2.5 to run on your server. I have already spent several days on this issue because my host sucks and have to figure things out myself. Safe mode is on on my server also and not affecting my install steps in the workaround I figured out.

    Give it a whirl can’t hurt http://wordpress.org/support/topic/169990?replies=7#post-738429

    Good Luck,
    Skrill

    Hey This fix is double the length to complete but end result you’ll have 2.5 running on your server.
    Check it out http://wordpress.org/support/topic/169990?replies=7#post-738429

    Thanks skrill, but I tried that already (it was the “upgrading” description). Its came out with the same result.

    By the way, both your links point to the same page.

    I had the same problem, but I found a solution. Which of course isn’t possible if you haven’t fixed the config-file.

    I just went into wp-admin and into design->themes.
    Then it automatically changed to the standard-theme. All of a sudden everything worked!

    Excuse the (possibly) poor English.

    I had the same problem, but I found a solution. Which of course isn’t possible if you haven’t fixed the config-file.

    I just went into wp-admin and into design->themes.
    Then it automatically changed to the standard-theme. All of a sudden everything worked!

    I wish I could get that part… but I can’t even begin the install

    Imsalgado, I hope I have the answer for you but from reading the history you’ve been pretty thorough and may already have checked this! I had exactly the same problem on my newly installed WP site (a completely blank white screen) and like you, spent hours trying different options.

    Just before I reached for a hammer I mentally went over the installation steps to see whether I had done anything that would vary from the standard installation (not just process but actual configuration). The only things I had changed were the security keys and the wp-content directory – both in the wp-config.php file.

    The WP installation instructions quote specific guidance for editing wp-config.php

    The example they list for the WP_CONTENT_DIR is as follows: ‘define( ‘WP_CONTENT_DIR’, $_SERVER[‘DOCUMENT_ROOT’] . ‘/blog/wp-content’ );’

    My problem was that I used this example and only replaced the ‘/blog/wp-content’ bit with my local path and assumed that the preceeding bit was all valid syntax. It wasn’t. I tried changing the whole statement to: ‘define( ‘WP_CONTENT_DIR’, ‘./wp-content’ );’, refreshed the page and bada bing – there it was, my home page.

    My logic for trying this was that all the other posts suggested that php or WP would stop execution if any of the content was missing but what if it couldn’t actually see any of the content at all? Anyway, your issue might not be the same but it may be worth checking all the variables in wp-config that are set as part of the installation script.

    Alternatviely, I came across another link that may have some other suggestions you haven’t already tried.

    Hope this helps!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Blank page on install – I’ve tried everything and still nothing’ is closed to new replies.