[resolved] Blank page on fresh installation with old database (7 posts)

  1. tajna
    Posted 3 years ago #


    I couldn't find the solution to this strange problem.

    I needed to install a new, fresh installation of WP and I have wanted to connect that new installation to the old database.

    Before the removal of previous WP installation, I had updated to the newest WP version.

    When I have installed with Fantastico DeLuxe, a new database have been created and the website have been visible. But when I edit the wp-config.php to point to old DB, a blank page is shown. I am sure that I have entered correct data.

    When I tried to download WP installation and copy it directly via FTP, there is also a blank page. I also tried to copy the old wp-config.php with no success.

    The installation is fresh, so no plugin and no theme could cause the problem.

    Does anyone have any idea what could be wrong?

  2. RichardWPG
    Posted 3 years ago #

    Try a fresh download of the WordPress and a fresh installation again.

  3. tajna
    Posted 3 years ago #

    Thank you.

    I have tried that three times already. Always the same result.

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    You shouldn't need to run the install again. Just modify the wp-config.php to point to the old database and upload all of the WP files & folders.

  5. tajna
    Posted 3 years ago #

    Thank you guys, but I did all of that you are suggesting. I am a programmer, so I have a clue what should be done :-)

    But the problem is when I point the wp-config.php to the old database. Nothing is shown then on a website homepage. There is no record in the error log, no message, nothing.

  6. Sisir
    Posted 3 years ago #

    Do you have error reporting (wp_debug) turned on?

  7. tajna
    Posted 3 years ago #

    I finally found the solution.

    @prionkor, wp_debug did not put anything on the screen. Thanks for the advice.

    After hours of searching and trying different fixes, I found out that the default theme is not recognized well and that the theme folder could not be found. It was strange because it was a fresh installation. So I only activated the default theme again through dashboard and voila, the data from the old database appeared.

    Thank you all!

Topic Closed

This topic has been closed to new replies.

About this Topic