Support » Plugin: Advanced Custom Fields: Extended » Blank page after submitting form

  • Resolved Dennis Dallau

    (@yorlinqnl)


    I have a multi site environment and suddenly all sites give a blank page after submitting an ACF Extended form on frontend. This used to work correctly.

    Forwarding to a succes page does still work.

    Anyone else facing this?

    If you want you can try it yourself (see link).

    I’m using:
    ACF Pro v5.9.1
    ACF extended v0.8.7.3
    WordPress v5.5.1

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Konrad Chmielewski

    (@hwk-fr)

    Hello,

    Thanks for the feedback! I tested the form, and it correctly post the form data to the page. The Success Page is not blank, it correctly display your theme, but there is no “Success Message”, and the footer is missing, which makes me think that you got a PHP error which stop the page rendering right before displaying the success message.

    Can please enable the WP Debug mode (+ logs) and check if you got any error? See: https://wordpress.org/support/article/debugging-in-wordpress/

    Can you also try to display a simple “Success Message” setting, like “Success!”. Maybe you got some hook that isn’t working correctly there.

    Regards.

    Tnx.

    I have turned DEBUG on and got this message:

    Notice: Undefined variable: _FILES in /data/sites/web/yorlinqnl/www/wp-content/themes/yootheme/vendor/yootheme/http-message/src/ServerRequest.php on line 50
    
    Fatal error: Uncaught TypeError: Argument 1 passed to YOOtheme\Http\Message\UploadedFile::normalizeFiles() must be of the type array, null given, called in /data/sites/web/yorlinqnl/www/wp-content/themes/yootheme/vendor/yootheme/http-message/src/ServerRequest.php on line 50 and defined in /data/sites/web/yorlinqnl/www/wp-content/themes/yootheme/vendor/yootheme/http-message/src/UploadedFile.php:170 Stack trace: #0 /data/sites/web/yorlinqnl/www/wp-content/themes/yootheme/vendor/yootheme/http-message/src/ServerRequest.php(50): YOOtheme\Http\Message\UploadedFile::normalizeFiles() #1 /data/sites/web/yorlinqnl/www/wp-content/themes/yootheme/vendor/yootheme/container/src/Container.php(279): YOOtheme\Http\Message\ServerRequest::fromGlobals() #2 /data/sites/web/yorlinqnl/www/wp-content/themes/yootheme/vendor/yootheme/container/src/Container/Service.php(154): YOOtheme\Container->call() #3 /data/sites/web/yorlinqnl/www/wp-content/themes/yootheme/vendor/yootheme/container/src/Container.php(329): YOOtheme\Container\Service->resolveIns in /data/sites/web/yorlinqnl/www/wp-content/themes/yootheme/vendor/yootheme/http-message/src/UploadedFile.php on line 170

    So its YOOtheme that is the trigger.

    Plugin Author Konrad Chmielewski

    (@hwk-fr)

    Hello,

    Yes, it looks like the problem come from YooThemes. There was probably an update recently, which broke the submission (the latest ACF Extended update didn’t touch that module).

    What is weird is that it look like it tries to work with $_FILES variable, which is used for file upload, when there is none in your form.

    You should submit a report on their forum (with the log), they will most likely fix it.

    Hope it helps.

    Regards.

    PS: Feel free to post the support topic link here, so I can keep track of the ticket.

    Tnx for your help.

    Their looking into it: https://yootheme.com/support/question/140905#answer-449935

    I can confirm that YOOtheme has fixed the bug.

    Plugin Author Konrad Chmielewski

    (@hwk-fr)

    Hello,

    Thanks for the heads up. Great news! 🙂

    Have a nice day,

    Regards.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.