WordPress.org

Forums

WP-Members
[resolved] Blank page after login (4 posts)

  1. Popescu M
    Member
    Posted 2 years ago #

    I am using WP Member 2.8.0 and I get a blank page after I log in using the form in the sidebar (the widget). With the version 2.7.7 I didn't have this problem. How can I fix it?

    http://wordpress.org/extend/plugins/wp-members/

  2. Popescu M
    Member
    Posted 2 years ago #

    I found out the problem, it was in wp-members-deprecated.php. There is no $post_to variable to redirect after login. So i have added this code at the beginning of the function wpmem_old_forms_sidebar()

    if( isset( $_REQUEST['redirect_to'] ) ) {
    		$post_to = $_REQUEST['redirect_to'];
    	} elseif( is_home() ) {
    		$post_to = $_SERVER['PHP_SELF'];
    	} elseif( is_single() || is_page() ) {
    		$post_to = get_permalink();
    	} elseif( is_category() ) {
    		global $wp_query;
    		$cat_id  = get_query_var( 'cat' );
    		$post_to = get_category_link( $cat_id );
    	} elseif( is_search() ) {
    		$post_to = $url . '/?s=' . get_search_query();
    	} else {
    		$post_to = $_SERVER['PHP_SELF'];
    	}
  3. Chad Butler
    Member
    Plugin Author

    Posted 2 years ago #

    The problem is that those old forms are deprecated and are therefore no longer being updated. You should change your forms setting to not use those so that you don't have to do it when they are fully removed from the plugin.

  4. Keest1
    Member
    Posted 2 years ago #

    Hello Member

    I have the same problem, but it can not..

    Can you send or posting the complete code of the deprecaded file?

    Grt,
    Kees

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP-Members
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.