WordPress.org

Forums

[resolved] Blank page after loading (27 posts)

  1. lkeeney
    Member
    Posted 4 years ago #

    When I run install.php I end up with a blank page almost immediately. When I view the page source there is no code shown.

    I have spent most of the day trying to figure this out but I can't think of anything else to try.

    I started by downloading the WP files from the WP website. I unzipped the files and put then in a temporary file on my desktop. I opened the config file and edited it then saved it and renamed it as recommended.

    I then uploaded all the files to my website in the folder root/Blog. Then when I run the install.php file I get the results explained above.

    Where did I go wrong?

  2. govpatel
    Member
    Posted 4 years ago #

    delete wp-config.php file that you created and leave wp-config-sample.php and run your install program and let install program create a wp-config.php

    You need to create a database and enter that information as requested.

  3. spencerb
    Member
    Posted 4 years ago #

    Tried using govpatel's solution above, and at first, it seemed as if it would work. But once I entered in all of my database info, it said that it had an "Error establishing a database connection". Not sure what else to do.

    I'm installing this for the first time, latest version of WordPress downloaded today, hosted by Dreamhost. Should be easier than this... I've never run into problems installing WordPress until now.

  4. govpatel
    Member
    Posted 4 years ago #

    Check with your host if you need to use some other then default localhost as host I think dream host use a url of some sort.

  5. spencerb
    Member
    Posted 4 years ago #

    Dreamhost does not want you to use LOCALHOST. And so, I created one, and then entered it in, but still to no avail.

  6. lkeeney
    Member
    Posted 4 years ago #

    govpatel,

    I did as you suggested, and then I received the message "Error establishing a database connection".

    I too left localhost as the hostname. I am being hosted by gate.com, and did not see anything else that I could use here.

    Edit: I have contacted gate.com and asked them what I should use instead of localhost. I am waiting for a reply.

  7. govpatel
    Member
    Posted 4 years ago #

    Yes but they use something else and that what you need in wp-config.php

    /** MySQL hostname */
    define('DB_HOST', 'localhost');
  8. lkeeney
    Member
    Posted 4 years ago #

    I received the information from gate.com. However, I still can not connect to the database.

    I have only one database on my hosting site. Does this database have to be completely empty? I do have 5 tables in this database that I have been using for testing. Would this prevent WP from accessing my database?

  9. govpatel
    Member
    Posted 4 years ago #

    yes drop them tables if you are not using them and let wordpress install program create tables.

  10. lkeeney
    Member
    Posted 4 years ago #

    I dumped the tables, and I am still getting the same error message. I am about to give up on WordPress.

  11. govpatel
    Member
    Posted 4 years ago #

    Did you try and run install program

  12. janinechaidez
    Member
    Posted 4 years ago #

    I'm getting the same problem as well. I'm hosted on brinkster. I allowed my db_user to read/write the folder wordpress is in and it is still blank.

    I originally tried leaving wp-config-sample.php as is and got the database connection error.

    I was told it was possibly a bad file so I deleted the whole folder, downloaded wp again and uploaded it with blank page again. I never knew installing this would be so difficult. Any other things I should try?

  13. lkeeney
    Member
    Posted 4 years ago #

    govpatel,

    Yes, I did run the install program again, and this is where I am getting the error message "Error establishing a database connection".

    Apparently janinechaidez and I have the same problem, yet with different hosting sites.

  14. govpatel
    Member
    Posted 4 years ago #

    Yes, I did run the install program again, and this is where I am getting the error message "Error establishing a database connection".

    Recheck your wp-config.php file see if you have right information to connect to database ask your host if your need to use some thing else for DB_Host, localhost is set as default but some host use url

  15. lkeeney
    Member
    Posted 4 years ago #

    I have resolved my problem. The problem turned out to be the fact that I was using Firefox 3.6.15. I tried using Internet Explorer 8 and I could not even open the install.php file with this browser.

    I then tried Google Chrome, and everything worked like a charm. My page was up and available in minutes.

    Thanks for your help.

    janinechaidez - I don't know which browser you are using but you may want to try another browser.

  16. ornis1976
    Member
    Posted 4 years ago #

    Hello I do have the same problem I get a blank page trying to install wordpress but I am not using any hosting company. I am trying to use my mac to preview it locally. I enable PHP in my mac then I downloaded MAMP and wordpress and when I try to installed it I get the blank page. Does anybody know what am I doing wrong?

  17. esmi
    Forum Moderator
    Posted 4 years ago #

    Does any .php page work on your local server?

  18. lkeeney
    Member
    Posted 4 years ago #

    ornis1976,

    You may want to start a new thread with your problem. This morning I marked this thread as resolved when I fixed my problem, and I am not sure how many people will be looking at a resolved thread.

    Good luck in solving your problem. Unfortunately, I am not a Mac person, and don't know much about installing WP either.

    Lawrence

  19. ornis1976
    Member
    Posted 4 years ago #

    yes they do!I just try one as a test and it works!

  20. ornis1976
    Member
    Posted 4 years ago #

    Thanks Ikeeney I will!

  21. esmi
    Forum Moderator
    Posted 4 years ago #

    Download a fresh copy of WordPress. Also check your server's error log.

  22. ornis1976
    Member
    Posted 4 years ago #

    Sorry but how do I check the server's error log? I am new on this! :)

  23. esmi
    Forum Moderator
    Posted 4 years ago #

    Check the documentation for your local server software.

  24. govpatel
    Member
    Posted 4 years ago #

    Most likely you have database information wrong recheck your wp-config.php

  25. ornis1976
    Member
    Posted 4 years ago #

    This is the error that I am getting (look below) but I do have the right username and password so this is weird. I check MAMP and the status is green and I double check my username and password and everything looks ok. Any ideas would be great! I really want to learn how to use wordpress!!!

    Error message:
    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost. This could mean your host's database server is down.

    * Are you sure you have the correct username and password?
    * Are you sure that you have typed the correct hostname?
    * Are you sure that the database server is running?

  26. ornis1976
    Member
    Posted 4 years ago #

    Hello Esmi and govpel thanks for your help I did it, I was looking at the wrong http address! is a little bit different using MAMP, Sorry for that :)

  27. govpatel
    Member
    Posted 4 years ago #

    You are wlcome glad that you have problem solved.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags