Support » Plugin: WP Security Audit Log » Blank page after activating 1.0

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author WPWhiteSecurity


    Hi Marcelo,

    First of all thank you for using, or better trying to use our plugin. Sorry if it is causing any inconvenience.

    To start off with, is this an upgrade or a new install of the plugin? To be honest we never had a similar case to yours, and white screens are quite a pain to troubleshoot so would it be possible to contact us on for further troubleshooting?

    We would be more than willing to help you solve this issue. Looking forward to hearing from you.

    Hello. I’m not sure if it can be considered an upgrade because I tried the plugin some months ago. I then didnt needed it, so I uninstalled it. Today I installed the version from the WP repo and the whitescreen came up.
    For what I can recall, I really want to use this plugin, but it’s disappointing the white screen. Also, no PHP errors were found in the log. I uninstalled the plugin and then reinstall it again, and that’s still showing a blank page. I ended uninstalling everything 🙂
    In the meanwhile, I’m using Simple History, which is nice, but not as detailed as this one.

    If you guide me, I can search with phpmyadmin and show you some fields in the options table of this site. Maybe there were remaining, inconsistent, settings from that time when I tried the plugin. Perhaps deleting that old entries may help to solve the problem.

    Best regards

    Plugin Author WPWhiteSecurity


    Hi Marcelo,

    That explains a lot. We’ve changed the database structure 3 times since now hence unless you do sequential upgrades, things won’t work. Having said that white screens should not appear neither, such errors should be handled from our end.

    Since it is a brand new installation I recommend to remove all previous tables and start from scratch. Here is what you need to do;

    1. Access your WordPress database using phpmyadmin
    2. Look for any of the below listed tables and delete them (wp_ is the database prefix, hence if you changed it yours will be different):


    2. From the WordPress options table (wp_options) remove any of the following entries that you might have:


    3. Download the plugin again and try to install it.

    Please let me know how it went.

    Well… I found a couple tables and options. I deleted every one. Installed the plugin. Activate, OK. Gone to the settings page: blank. Browse to any other page: blank. Renamed the plugin to force deactivation, deleted files, deleted tables and options. 🙁

    I found two PHP errorlogs created in root and wp-admin folder at the same time the plugin was activated.
    Both files weigh 14 MB and shows basically two MySQL errors due to very large queries taking place, both them consisting in

    [29-May-2014 15:56:19 UTC] Error MySQL server has gone away de la base de datos de WordPress para la consulta REPLACE INTO cu2vn4ah_wsal_metadata (id,occurrence_id,name,value) VALUES (……………WSAL_DB_ActiveRecord->Save

    I cannot post the entire queries since they are extremely large and exposing lots of strings from the site.

    The error log at root folder ended with:

    [29-May-2014 15:56:20 UTC] PHP Fatal error:  Allowed memory size of 134217728 bytes exhausted (tried to allocate 46847281 bytes) in /home/marcelop/public_html/blog/wp-includes/wp-db.php on line 1033
    [29-May-2014 15:56:20 UTC] PHP Fatal error:  Allowed memory size of 134217728 bytes exhausted (tried to allocate 46868933 bytes) in /home/marcelop/public_html/blog/wp-includes/wp-db.php on line 1033

    which is odd since the server allows for 128 MB max mem for PHP.

    After this, I installed the plugin in a test site and it all gone just fine. No troubles. No errorlogs. Same server. Same configs.

    Maybe there are more options to look for?
    Maybe the plugin is conflicting with MySQL 5.6?
    Maybe the plugin is confused by the WP db prefix?
    From what I can tell, this website won’t be able to run the plugin. Others will do. But not this one.
    If you happen to have any idea, you’re welcome 🙂

    Plugin Author WPWhiteSecurity


    Hi Marcelo,

    First of all sorry for the delay in replying. Was exchanging some ideas with the developers before replying.

    It would be great if you can send us the log files with the query strings on so we can analyse them and give you more feedback on what the issue might be.

    Feel free to remove any usernames, passwords, IP addresses and any other sensitive data from the logs.

    Looking forward to hearing from you.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Blank page after activating 1.0’ is closed to new replies.